Cisco Support Community
Community Member

Incoming calls to SIP trunk on CME 4.0.3


I'm having a heck of a time getting incoming calls to appear on my CME 4.0.3 (12.4.15T8 on 2650XM). Outbound dialing works with the dial-peers I have and have configured sip-ua (to what I think it should be) and I am getting a SIP 400 (invalid host) coming back.

My CME is behind a Linux NAT router and wondering if this is a possibilty (but registration with outside SIP gateway works as does outbound dialing?).

Here's the message I get: SIP/2.0 400 Bad Request - 'Invalid Host'

Here's my sip-ua portion of the config:


authentication username 1204XXXXXXX password 7 <SNIP>

nat symmetric role passive

nat symmetric check-media-src

calling-info pstn-to-sip from name set <My Name>

no remote-party-id

retry invite 2

retry register 10

timers connect 100

registrar expires 120

presence enable


I've tried the settings with and without the nat commands to no avail. Thanks for any help!


Re: Incoming calls to SIP trunk on CME 4.0.3

It's best to get the provider involved for issues like these. SIP providers will reject calls for a variety of reasons:

-Source IP address does not match their records

-IP address in From: URI does not match their records (possible NAT problem / bind media problem)

-User field in From: URI does not match the registered phone number (translation patterns fix this)

-Not currently registered to the provider

-The To: URI includes their IP address instead of domain name (and vice versa)

-The From: URI includes your IP address instead of domain name (and vice versa)

This could also be an invalid number being sent to them ( trying adding a 9 before possibly?), although you should receive a 404 for this.

It's best to 'debug ccsip messages' on your gateway to find out what you're sending, try to get a capture of what the packet looks like after your NAT router to make sure it's doing proper fix-up.

Community Member

Re: Incoming calls to SIP trunk on CME 4.0.3

Thanks for the reply.

I don't think it's an issue of the SIP provider rejecting my calls. As mentioned in the original post - I am able to make calls out and I am registered when I do a "sh sip-ua reg stat". My SIP provider allows me to create any userid and map it to a particular DID (or group of them). I know the mapping works as I have tried the same userid/password with Asterisk 1.6.x).

I have done many of the 'debug ccsip' commands (that's how I managed to find the 400 error message). As I said earlier - I only get this message when I make an inbound call to a number I have mapped to the userid I have registered under the 'sip-ua' configuration. Outbound calling still works as expected.

Thanks again - I will get in touch with the ITSP - but trying to get technical help from their side will be a bit more difficult :)

Re: Incoming calls to SIP trunk on CME 4.0.3

Can you paste the SIP message that we're sending a 400 for? It may be improperly formatted.

You may want to check any translations and 'show dial-peer voice summary' to make sure that the numbers are matching up as expected.

'debug ccsip all' is very good at telling you why we send certain messages as well.

Community Member

Re: Incoming calls to SIP trunk on CME 4.0.3

I'd love to! Unfortunately I tried it again this morning and it was working!! (last running-config change was more then 48 hrs ago!)

When I rang one of the DIDs this morning I was getting '486 Busy Here' messages (using debug ccsip all). I didn't have any phones on at the time (it's in a lab). I powered up one of the phones that has a DN assigned that the DIDs appear on. Voila! it works!.

I don't know what to say :(

Community Member

Re: Incoming calls to SIP trunk on CME 4.0.3

I'm running into the same error and have forwarded the error to my ITSP for their review. I am behind an ASA with SIP inspection on. I've attached the text file with the error message. Outbound is fine, inbound does not work.

dial-peer voice 1001 voip

translation-profile incoming CH2202

voice-class sip dtmf-relay force rtp-nte

session protocol sipv2

session target ipv4:X.X.X.X

incoming called-number .

dtmf-relay rtp-nte

ip qos dscp cs5 media

ip qos dscp cs4 signaling

no vad

CreatePlease to create content