Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Intermittent mid-call one-way-audio loss on H.323 GWs

Hi There,

We have been having the issue of mid-call one-way-audio loss on intermittent calls. We have four locations where Cisco's H.323 GWs are configured to work with CUCM 7. Environment is of UCCE. On some calls, during the call our agents are facing the loss of audio to the caller i.e. caller cant hear them while they can hear the callers fine. Several packet captures were done and finally it looks that the audio packet towards PSTN are making their way till the H.323 GWs. This was determined by collecting WireShark captures on the port of the switch on which the GWs were connected. The captures show the audio of both sides however caller on PSTN does not hear all that.Sometimes after a while audio would resume by itself, but most of the time call is just abandoned.

Cisco had provided us a tcl script to collect the information. The script is triggered when an agent presses the * key three times. The agents were advised to press * three times whenever they face the one-way audio issue. However the situation became interesting that whenever agents face the issue and as soon as they press the *** the audio resumes and call goes on fine!!. Hence the tcl captures turn out to be collecting information where the call resumes fine - so those are no good. Cisco engineer is looking into the situation.

I would appreciate if someone has faced such situation of intermittent one-way-audio, and/ or if someone is aware of the flow of incidents after a user presses some keys "during a call".

Thanks for your help..

Athar

Everyone's tags (5)
4 REPLIES
New Member

Intermittent mid-call one-way-audio loss on H.323 GWs

Just to add that we tried upgrading the IOS on GWs to 15.1-4.M6; but didnt really help.

Thanks - Athar

Cisco Employee

Intermittent mid-call one-way-audio loss on H.323 GWs

Hi Athar,

     I have a few follow up questions to the above :

> How does the H.323 gateway connect to the PSTN? A PRI or an IP connection ?

> If it is a PRI, has the Cisco engineer checked the state of the DSPs on the gateway ?

>  Also, since this is a UCCE environement, I would imagine we have  multiple PRIs at each site, thus it would be difficut for TAC to gather a  PCM capture in a working environment. But if the issue can be  reproduced in non-working hours ( if any ), you could ask the engineer  to take a PCM for that call.

> Are we using the same provider for all sites?

> Have we checked the CPU utilization on the gateways at the time of the issue ?

Regards,

Jagpreet

New Member

Intermittent mid-call one-way-audio loss on H.323 GWs

Hi Jagpreet,

Thanks for your response. Here are the responses:

> How does the H.323 gateway connect to the PSTN? A PRI or an IP connection ?

Athar: PRIs

> If it is a PRI, has the Cisco engineer checked the state of the DSPs on the gateway ?

Athar: I guess he did. But there were no error logs for DSPs.

>  Also, since this is a UCCE environement, I would imagine we have  multiple PRIs at each site, thus it would be difficut for TAC to gather a  PCM capture in a working environment. But if the issue can be  reproduced in non-working hours ( if any ), you could ask the engineer  to take a PCM for that call. ..

Athar: As I mentioned above, we were provided with a TCL script which is only invoked when users presses ***. And we collected pcm captured during production calls and all above that I explained i.e. audio becoming normal happened during production calls/ hours.

> Are we using the same provider for all sites?

Athar: No. Two locatiojns have the same provider and other two have a second one.

> Have we checked the CPU utilization on the gateways at the time of the issue ?

Athar: I checked it sometime back and it seemed fine throughout.

Once again Thanks for your reply.

Athar

New Member

Intermittent mid-call one-way-audio loss on H.323 GWs

Hi Athar

     We are experiening the exact same issue on  CUCM 7.1 (5).

     Two weeks ago one of our Branch Offices experienced multiple instance of intermittant one-way voice inbound and outbound to the PSTN. We have a voice recording system and when I listen to the calls not all calls are one way, some are distorted but the user may percieve this as one-way voice. I believe the issue is either the gateway or the PSTN provider, we have the same provider at all sites.

     The issue started a few days ago at one of our other branch offices.

     It happens to random phones and random times of the day, we had no instances for 48 hours then just one.

     We have also had an instance where a call failed halfway through and then the call resumed as normal after 10/15 seconds of "one-way voice"

     I would be very keen to know if you have had anything back from Cisco? We are getting nowhere with the telephony provider.

Regards

Kev Richardson

780
Views
0
Helpful
4
Replies
CreatePlease login to create content