Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Intermittent T1 Drop

For the last few weeks I have been strugging with an intermittent voice T1 drop.  About 2-3 times a week I will get an alert (sample included below) showing I have a D Channel drop on circuit 80000 (S0/0/0:23).  To eliminate a cross-connect issue, I switched the cross-connects at the carrier's smart jacks.  After the switch the issue stays on circuit 80000 but now shows up on my router as S0/0/1:23.  This tells me the issue can't be related to my router and it can't be related to the cross-connects.  While the drops are short, they do drop all the calls in progress on that circuit (very bad for business).  The telco seems unable to find any issues.  Am I missing anything?  Any help would be appreciated.

*****Background Info******

1.  I have 4 voice T1s (Carrier circuit 80000, 80001, 80002, 80003)

2.  The circuits were connected to my router as follows

     80000 - S0/0/0:23 - Now switched to S0/0/1:23

     80001 - S0/0/1:23 - Now switched to S0/0/0:23

     80002 - S0/1/0:23

     80003 - S0/1/1:23

3.  I have SNMP traps set to report to my OpenNMS server

*******Sample drop report from OpenNMS******

9:14:21 - uei.opennms.org/vendor/Cisco/traps/ciscoICsuDsuSw56kLoopStatusNotification - Cisco Event: CSU/DSU Change in Sw56k Loop Status.

9:14:21 - uei.opennms.org/translator/traps/SNMP_Link_Down - Agent Interface Down (linkDown Trap) on interface index:11; ifDescr: T1 0/0/1; ifName:T1 0/0/1; ifAlias:

9:14:22 - uei.opennms.org/vendor/C5300/traps/5300DChanDown - Cisco Event: demandNbrLayer2Change trap received ifIndex=86 Line Status Down

9:14:22 - uei.opennms.org/vendor/C5300/traps/5300DChanDown - Cisco Event: demandNbrLayer2Change trap received ifIndex=86 Line Status Down

9:14:22 - uei.opennms.org/vendor/Cisco/traps/ciscoICsuDsuSw56kLoopStatusNotification - Cisco Event: CSU/DSU Change in Sw56k Loop Status.

9:14:23 - uei.opennms.org/vendor/Cisco/traps/clogMessageGenerated-Error - Cisco Event: SYSLOG Notification: Interface Serial0/0/1:23, changed state to down.

9:14:26 - uei.opennms.org/vendor/Cisco/traps/ciscoICsuDsuSw56kLoopStatusNotification - Cisco Event: CSU/DSU Change in Sw56k Loop Status

9:14:26 - uei.opennms.org/translator/traps/SNMP_Link_Up - Agent Interface Up (linkUp Trap) on interface index:11; ifDescr:T1 0/0/1; ifName:T1 0/0/1; IfAlias:

9:14:27 - uei.opennms.org/vendor/C5300/traps/5300DChanL1Up - demandNbrLayer2Change trap received ifIndex=86 Layer 1 UP

9:14:27 - uei.opennms.org/vendor/C5300/traps/5300DChanL1Up - demandNbrLayer2Change trap received ifIndex=86 Layer 1 UP

9:14:28 - uei.opennms.org/vendor/Cisco/traps/clogMessageGenerated-Error - Cisco Event: SYSLOG Notification: Interface Serial0/0/1:23, changed state to up.

9:14:36 - uei.opennms.org/vendor/C5300/traps/5300DChanUp - Cisco Event: demandNbrLayer2Change trap received ifIndex=86 Layer 2 UP-PRI Up

******Cisco 2821 Router Config ********

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname OTAGATEWAY
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
card type t1 0 1
enable secret 5 blahblah
!
aaa new-model
!
!
aaa authentication login userauthen local
aaa authorization network groupauthor local
!
aaa session-id common
!
resource policy
!
clock timezone MST -7
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-select 1 T1 0/0/0
network-clock-select 2 T1 0/0/1
network-clock-select 3 T1 0/1/0
network-clock-select 4 T1 0/1/1
ip subnet-zero
!
!
ip cef
!
!
!
isdn switch-type primary-ni
!
!
trunk group  Outbound_Lines
!
voice-card 0
no dspfarm
dsp services dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-3399614495
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3399614495
revocation-check none
rsakeypair TP-self-signed-3399614495
!
!
crypto pki certificate chain TP-self-signed-3399614495
certificate self-signed 01
  30820243 308201AC A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33333939 36313434 3935301E 170D3133 30393330 31383232
  31325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 33393936
  31343439 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100A80C 60CA3267 0B364DCC C7C40335 2DD4C2BF BF6D8247 49A263F6 93B98B64
  931222CD 9CDE0F95 92BB54FB 60186C3B 31CEFE2D E4C797EA D1D7083E 392AAB23
  5306CD13 59E06146 0D0457AF 70C672BB 086E789C 3106DE23 BB5018C1 BB344F90
  75544F82 5BCDCBE3 BCD8DF0D 2B597F50 2D9A0D20 4639A6B4 6EFED280 6415B130
  03E30203 010001A3 6B306930 0F060355 1D130101 FF040530 030101FF 30160603
  551D1104 0F300D82 0B4F5441 47415445 5741592E 301F0603 551D2304 18301680
  1448CF64 3DA477B6 77B0E913 286C4050 B461631C 86301D06 03551D0E 04160414
  48CF643D A477B677 B0E91328 6C4050B4 61631C86 300D0609 2A864886 F70D0101
  04050003 81810029 D78FAC58 0A130526 3FCFE102 0191879F EBFF74C4 AF1DA278
  E7097F66 558AC937 35008E08 5C568110 1C7BAADF 3ECA49F3 FC688035 60EB6D28
  B0BBC378 8768356E 7412560B B7E6B877 0F6BABB2 262298A8 BAB45CC5 EA766D3D
  93835B83 CDEDE986 B6FAC22D 359DCFD4 2266811D 86FF4AC0 5C242603 0C40D0BE
  E40A3681 2539B2
  quit
!
application
global
  service alternate DEFAULT
!
!
username blah password 7 blahblah
!
!
controller T1 0/0/0
framing esf
linecode b8zs
pri-group timeslots 1-24 service mgcp
!
controller T1 0/0/1
framing esf
linecode b8zs
pri-group timeslots 1-24 service mgcp
!
controller T1 0/1/0
framing esf
linecode b8zs
pri-group timeslots 1-24 service mgcp
!
controller T1 0/1/1
framing esf
linecode b8zs
pri-group timeslots 1-24 service mgcp
!
class-map match-all voice-traffic
match protocol rtp
match ip dscp ef
class-map match-any voice-signalling
match ip dscp cs3
match ip dscp af31
match protocol h323
match protocol mgcp
match protocol skinny
!
!
policy-map EGRESS
class voice-traffic
  priority percent 40
class voice-signalling
  bandwidth percent 5
class class-default
  fair-queue
  set ip dscp default
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
ip address 192.168.22.202 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 192.168.22.202
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice voice
isdn map address 011* plan unknown type unknown
isdn bind-l3 ccm-manager
no cdp enable
!
interface Serial0/0/1:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice voice
isdn map address 011* plan unknown type unknown
isdn bind-l3 ccm-manager
no cdp enable
!
interface Serial0/1/0:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice voice
isdn map address 011* plan unknown type unknown
isdn bind-l3 ccm-manager
no cdp enable
!
interface Serial0/1/1:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice voice
isdn map address 011* plan unknown type unknown
isdn bind-l3 ccm-manager
no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.22.1
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
snmp-server community public RO
snmp-server community OTACommunity RW
snmp-server ifindex persist
snmp-server location Phoenix, AZ, USA
snmp-server contact Davin Dameron - 602.478.2449
snmp-server chassis-id Cisco 2821 OTAGATEWAY
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps vrrp
snmp-server enable traps ds1
snmp-server enable traps tty
snmp-server enable traps eigrp
snmp-server enable traps xgcp
snmp-server enable traps flash insertion removal
snmp-server enable traps ds3
snmp-server enable traps envmon
snmp-server enable traps icsudsu
snmp-server enable traps isdn call-information
snmp-server enable traps isdn layer2
snmp-server enable traps isdn chan-not-avail
snmp-server enable traps isdn ietf
snmp-server enable traps ds0-busyout
snmp-server enable traps ds1-loopback
snmp-server enable traps atm subif
snmp-server enable traps bgp
snmp-server enable traps bulkstat collection transfer
snmp-server enable traps cnpd
snmp-server enable traps config-copy
snmp-server enable traps config
snmp-server enable traps dsp card-status
snmp-server enable traps entity
snmp-server enable traps event-manager
snmp-server enable traps frame-relay
snmp-server enable traps frame-relay subif
snmp-server enable traps hsrp
snmp-server enable traps ipmobile
snmp-server enable traps ipmulticast
snmp-server enable traps mpls ldp
snmp-server enable traps mpls traffic-eng
snmp-server enable traps mpls vpn
snmp-server enable traps msdp
snmp-server enable traps mvpn
snmp-server enable traps ospf state-change
snmp-server enable traps ospf errors
snmp-server enable traps ospf retransmit
snmp-server enable traps ospf lsa
snmp-server enable traps ospf cisco-specific state-change nssa-trans-change
snmp-server enable traps ospf cisco-specific state-change shamlink interface-old
snmp-server enable traps ospf cisco-specific state-change shamlink neighbor
snmp-server enable traps ospf cisco-specific errors
snmp-server enable traps ospf cisco-specific retransmit
snmp-server enable traps ospf cisco-specific lsa
snmp-server enable traps pim neighbor-change rp-mapping-change invalid-pim-messa
ge
snmp-server enable traps pppoe
snmp-server enable traps cpu threshold
snmp-server enable traps rsvp
snmp-server enable traps rtr
snmp-server enable traps syslog
snmp-server enable traps l2tun session
snmp-server enable traps vsimaster
snmp-server enable traps vtp
snmp-server enable traps isakmp policy add
snmp-server enable traps isakmp policy delete
snmp-server enable traps isakmp tunnel start
snmp-server enable traps isakmp tunnel stop
snmp-server enable traps ipsec cryptomap add
snmp-server enable traps ipsec cryptomap delete
snmp-server enable traps ipsec cryptomap attach
snmp-server enable traps ipsec cryptomap detach
snmp-server enable traps ipsec tunnel start
snmp-server enable traps ipsec tunnel stop
snmp-server enable traps ipsec too-many-sas
snmp-server enable traps voice fallback
snmp-server enable traps dnis
snmp-server host 192.168.22.6 version 2c OTACommunity
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:23
!
voice-port 0/1/0:23
!
voice-port 0/0/1:23
!
voice-port 0/1/1:23
!
voice-port 0/2/0
!
voice-port 0/2/1
!
voice-port 0/3/0
!
voice-port 0/3/1
!
voice-port 0/3/2
!
voice-port 0/3/3
!
ccm-manager fallback-mgcp
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 192.168.20.250
ccm-manager config
!
mgcp
mgcp call-agent 192.168.20.250 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
no mgcp package-capability fxr-package
mgcp package-capability pre-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
!
mgcp profile default
!
!
!
dial-peer voice 10 pots
destination-pattern 9911
port 0/0/0:23
forward-digits 3
!
dial-peer voice 11 pots
destination-pattern 9T
direct-inward-dial
port 0/0/1:23
!
dial-peer voice 20 pots
destination-pattern 9911
port 0/0/1:23
forward-digits 3
!
dial-peer voice 21 pots
destination-pattern 9T
direct-inward-dial
port 0/0/1:23
!
dial-peer voice 999020 pots
service mgcpapp
port 0/2/0
!
dial-peer voice 999021 pots
service mgcpapp
port 0/2/1
!
dial-peer voice 30 pots
destination-pattern 9911
port 0/1/0:23
forward-digits 3
!
dial-peer voice 31 pots
destination-pattern 9T
direct-inward-dial
port 0/1/1:23
!
dial-peer voice 40 pots
destination-pattern 9911
port 0/1/1:23
forward-digits 3
!
dial-peer voice 41 pots
destination-pattern 9T
direct-inward-dial
port 0/1/1:23
!
!
!
!
call-manager-fallback
secondary-dialtone 9
max-conferences 8 gain -6
transfer-system full-consult
timeouts interdigit 6
ip source-address 192.168.20.250 port 2000
max-ephones 30
max-dn 60
system message primary T1 DOWN - SRST ACTIVE
default-destination 8640
call-forward busy 8640
call-forward noan 8640 timeout 8
!
!
line con 0
line aux 0
line vty 0 4
access-class 12 in
password 7 07203149403D1C061F
transport input telnet ssh
line vty 5 15
password 7 07203149403D1C061F
!
scheduler allocate 20000 1000
ntp clock-period 17179355
ntp source GigabitEthernet0/0
ntp master
ntp server 192.168.20.20
!
end

1 REPLY

Intermittent T1 Drop

Hi Davin,

The log shows that there is a problem with CSU/DSU. And as you have already eliminated cross-connect issue then the issue is most likely with the remote end.

To find the root cause for this intermittent drop you can perform some below steps:-

1). Check the framing, line code and clocking at both sides (should be same).

2). Congestion on serial link during that interval.

3). Problem with CSU/DSU at local or either remote end.

4). Perfom local and remote loopback test to confirm faulty CSU/DSU end.

For more reference, please refer below link

http://www.cisco.com/en/US/tech/tk713/tk628/technologies_tech_note09186a00800a758d.shtml#topic9

Regards,

Nishant Savalia

Regards, Nishant Savalia
435
Views
0
Helpful
1
Replies