Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

IOS DHCP problem with Mitel VoIP set

I have a home user using a Cisco 880 router runing 15.2(4)M4 code with a Mitel VoIP set.

The phone was working fine, but now is stuck in DHCP discovery.

Phone port is configured as follows:

interface FastEthernet2

description VOICE

switchport voice vlan 2

no ip address

end


DHCP debugs reveal this:

001157: *Mar  3 13:39:27.195 EST: DHCPD: client's VPN is .

001158: *Mar  3 13:39:27.195 EST: DHCPD: No option 125

001159: *Mar  3 13:39:27.195 EST: DHCPD: Sending notification of DISCOVER:

001160: *Mar  3 13:39:27.195 EST:   DHCPD: htype 1 chaddr 0800.0f7b.3212

001161: *Mar  3 13:39:27.195 EST:   DHCPD: remote id 020a00000a643c0902000001

001162: *Mar  3 13:39:27.195 EST:   DHCPD: circuit id 00000000

001163: *Mar  3 13:39:27.195 EST: DHCPD: DHCPDISCOVER received from client 0108.000f.7b32.12 on interface Vlan1.

001164: *Mar  3 13:39:27.195 EST: DHCPD: Seeing if there is an internally specified pool class:

001165: *Mar  3 13:39:27.195 EST:   DHCPD: htype 1 chaddr 0800.0f7b.3212

001166: *Mar  3 13:39:27.195 EST:   DHCPD: remote id 020a00000a643c0902000001

001167: *Mar  3 13:39:27.195 EST:   DHCPD: circuit id 00000000

001168: *Mar  3 13:39:27.195 EST: DHCPD: Found previous server binding

001169: *Mar  3 13:39:27.195 EST: DHCPD: Sending DHCPOFFER to client 0108.000f.7b32.12 (10.200.60.10).

001170: *Mar  3 13:39:27.195 EST: DHCPD: no option 125

001171: *Mar  3 13:39:27.195 EST: DHCPD: broadcasting BOOTREPLY to client 0800.0f7b.3212.

The DHCP server seems to be providing the phone with an IP on the data vlan (VLAN 1), but not on VLAN 2.  Not sure why I'm seeing this "no option 125" though.

I've tried stopping and restarting the DHCP service to no avail.

My DHCP server config looks like this:

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.200.60.9

ip dhcp excluded-address 10.200.64.113

!

ip dhcp pool sdm-pool1

import all

network 10.200.60.8 255.255.255.248

dns-server 10.200.207.24 10.200.207.21

default-router 10.200.60.9

netbios-name-server 10.200.207.45 10.200.207.43

netbios-node-type h-node

!

ip dhcp pool VoIP-pool

import all

network 10.200.64.112 255.255.255.248

dns-server 10.200.207.24 10.200.207.21

default-router 10.200.64.113

netbios-name-server 10.200.207.45 10.200.207.43

netbios-node-type h-node

option 128 ip 10.200.179.10 10.200.179.11

option 129 ip 10.200.179.10 10.200.179.11

option 133 hex 0000.0005

option 132 hex 0000.0002

option 130 hex 4d49.5445.4c20.4950.2050.484f.4e45

lease 30

!

If you have any thoughts on what I can try next, I'd love to hear it!!

Thanks in advance.

John

2 REPLIES

IOS DHCP problem with Mitel VoIP set

The DHCP logs are complaining about option 125. For Mitel you can use Option 43 or 125. Look over the link below, it may help you.

http://www.unixwiz.net/techtips/mitel-ipphone-networking.html

HTH

Regards,

Yosh

HTH Regards, Yosh
New Member

IOS DHCP problem with Mitel VoIP set

Thanks Yosh... I will take a look at this link.

My confusion is that we have never had to specify either of those options elsewhere in our VoIP network.

Cheers,

John

804
Views
0
Helpful
2
Replies
CreatePlease to create content