Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IOS upgrade recommendation

Hello all,

I need an expert's opinion on upgrading our 2801's IOS.

We currently running IOS 12.4(6)T3, CME 3.4(0),CUE 2.3.4.

I would like to upgrade the IOS because of a bug we ran into (CSCsd58707). I see that 12.4(22)T has this bug fixed, and it also lists CME 3.4 as a supported feature.

Is it OK to upgrade to 12.4(22)T while leaving the CME and CUE at the current version?

Generally speaking is the version on the CME compatibility matrix (12.4(6)T in this case) the ONLY version the should be used or is it the minimum recommended version?

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: IOS upgrade recommendation

It's fairly odd because 12.5 has actually become part of 12.4(15)T I believe. We aren't expecting to see 12.5 for a long time, since 12.4(15)T is expected to go to something like 12.4(15)T20 or so.

I can check this later for you.

If you upgrade to 22T, CME is automatically upgraded. You would need to download the CME files for the GUI and phone loads though.

-nick

5 REPLIES

Re: IOS upgrade recommendation

A few things to note:

-You will need to download the CME GUI files to match your IOS version, or else it may not work properly.

-You may want to upgrade your CUE module to 3.x. The 2.x series isn't heavily supported by DEs anymore. If you're not having problems I wouldn't worry too much.

-Your phone loads should be upgraded with CME, and it should be included in the zip file.

-The CUE/CME compatibility is very loose, and you should be fine if you don't upgrade.

-You may want to think about 12.4(15)T8, as you may find it more stable than 22T. Although, IOS after 20T runs CME 7.0 which has considerably more features than 12.4(15)T.

hth,

nick

New Member

Re: IOS upgrade recommendation

Thanks Nick,

- Unfortunately 12.4(15)T also has the aforementioned bug. It was fixed in 12.5(0.7)M, 12.4(18.4)T1.

- So if I use 12.4(22)T, I would have to upgrade CME to 7.0.0.1? Or CME GUI? Or both?

Thanks again

Re: IOS upgrade recommendation

It's fairly odd because 12.5 has actually become part of 12.4(15)T I believe. We aren't expecting to see 12.5 for a long time, since 12.4(15)T is expected to go to something like 12.4(15)T20 or so.

I can check this later for you.

If you upgrade to 22T, CME is automatically upgraded. You would need to download the CME files for the GUI and phone loads though.

-nick

Re: IOS upgrade recommendation

Double checked - it looks like 12.4(20)T is considered 12.5 in bug tracker. 15T didn't have the fix for this.

-nick

New Member

Re: IOS upgrade recommendation

OK, I'll go with 22 then. Thanks!

118
Views
5
Helpful
5
Replies
CreatePlease login to create content