Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IP address of phones will not update when moving to a new subnet

We have several buildings and each building has a separate voice VLAN. When we move a phone from one building to another, it will not update with a new IP address. I don't think it's a DHCP problem, new phones register just fine. I can even take a new phone put that MAC in Callmanager on the old profile and the new phone will work correctly for the number.

I have tried a hard reset on the phones (this is happening to various models 7911, 7941G-GE, 7941G, 7961G-GE). The phones show they are updating, then go back to their original IP which will not work in the building they've been moved to.

When the phone is in this state I can't access the settings to change it to a static IP but if I take the phone back to the building it is from it will work just fine and I can access the settings button there.

I don't believe it's a VLAN problem, since the other phones all work just fine and new ones will register without an issue.

Our deployment is fairly new so I don't actually recall if we have moved any phones successfully previously.

Thanks for any help.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Red

Re: IP address of phones will not update when moving to a new su

Hi Teresa,

It almost surely is a problem with the DHCP server. We were experiencing these exact issues and spent many hours trying to troubleshoot them to no avail. The symptoms sound identical.

Rob

5 REPLIES
Hall of Fame Super Red

Re: IP address of phones will not update when moving to a new su

Hi Teresa,

We ran into this exact problem recently when planning in our lab for a Network re-design. DHCP Scopes and IP Helper addresses were all set properly and yet nothing worked when moving an existing phone from one subnet to another :( New phones were just fine and could register no problem. This turned out to be a problem (probably a bug) with the "built-in" Windows 2000 DHCP server in CCM and when built a Windows 2003 DHCP server with the same information everything started working perfectly. IP Phones can move between subnets without any intervention, just like it should be!

Hope this helps!

Rob

Please remember to rate helpful posts....

New Member

Re: IP address of phones will not update when moving to a new su

We are actually using an external DHCP server, so we aren't using the one in CCM. It is an older Windows server however, so maybe it's an older DHCP server problem.

Thanks much for the input.

Hall of Fame Super Red

Re: IP address of phones will not update when moving to a new su

Hi Teresa,

It almost surely is a problem with the DHCP server. We were experiencing these exact issues and spent many hours trying to troubleshoot them to no avail. The symptoms sound identical.

Rob

New Member

Re: IP address of phones will not update when moving to a new su

Thank you, thank you! You gave me the clue I needed. I went into the Address leases on the DHCP server and deleted the one associated with the phones that wouldn't re-register. When reset, they came up just fine!

Hall of Fame Super Red

Re: IP address of phones will not update when moving to a new su

Hi Teresa,

Great work on this! It is always good to fix something up b4 the weekend :)

Enjoy! And best of luck.

Rob

PS: With a little more tweaking you won't have to touch anything when you move the phones...

116
Views
0
Helpful
5
Replies