Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

IP Communicator and Vista (Corp Directory not accessible)

Here's an interesting issue:

I am able to register several IP Communicator apps with my CUCM 5.1.3c cluster successfully and everything works great - except no Corporate Direcory nor Personal Directory options appear in IPC when the Directory button is pressed and the IPC client OS is Vista.

Here's the kicker - only reproducable on Vista machines. Directories work great for all Win XP clients in this same cluster.

Some other info:

1. My URL for Directories is expressed as an IP address rather than a name.

2. We confirmed connectivity exists for the Vista PC by placing the following in the address field of a browser on the PC:

http://10.10.10.10:8080/ccmcip/xmldirectory.jsp

The Vista browser receives the same XML response provided to working XP and 2003 clients.

3. I reviewed and performed the suggested action for 'IP Communicator Users are Unable to View Corporate Directory' here: http://www.cisco.com/en/US/products/sw/voicesw/ps5475/products_tech_note09186a008026d36f.shtml#directory1

WinXp IPCs worked as before; Vista IPCs still do not.

4. We tried directly expressing a Directory username and password as suggested by the IP Communicator user guide. http://www.cusd.com/training/voip/cug21book.pdf

Also, no change.

5. I found a related Netpro post here but no direct resolution:

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Telephony&topicID=.ee6c829&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.2cc10fca/4#selected_message

We disabled all internal firewalls on the Vista PC as suggested in that post.

Does anyone have a suggestion how to resolve the inability to access the Corporate Directory for IPC on a Vista PC?

2 REPLIES
Bronze

Re: IP Communicator and Vista (Corp Directory not accessible)

Is Vista a 32 bit OS or a 64bit OS? As per release notes 2.1 version CIPC is supported only on 32 bit version of Vista.

If it is 32-bit disable all Web services that were listening on Port 80 on the Vista machines. These included SQL and IIS services that were operating as web servers.

New Member

Re: IP Communicator and Vista (Corp Directory not accessible)

Thank you jbayuka. We use 32-bit Vista. Good ideas.

My customer was able to resolve the issue with something else we originally suspected. It was a windows firewall problem. At some point

the user's account being tested was moved into a new Vista OU and it had GPO firewall settings on it. We did not know the account was configured as such and still thought I was in a wide open OU.

The customer removed the user account from this GPO, and unblocked IPC on the

windows firewall, and it works perfect now.

156
Views
0
Helpful
2
Replies
CreatePlease to create content