Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Ip phone 7821 licensing issue

Hello engineers!

 

I have fifteen ip phones 7821 model but I only could register 5 of them, the rest give me the "unknown" message. I have understood that this phones need UCL basic license.

My question is, that if I have some enhanced UCL licenses available, could this phones take this enhanced licenses in order to registering in the CUCM?

I have 9.1.2 CUCM version.

Actually, I have the next licensing:

 

 

Thanks for your help!

Regards!

 

Iván

21 REPLIES

If you have spare Enhanced or

If you have spare Enhanced or higher licenses, basic licenses will borrow from that pool. I dont think the 7821 not registering is related to your licenses, something else might be going on. 

Please rate useful posts.
VIP Purple

Hi Ivan,[+5] to friend George

Hi Ivan,

[+5] to friend George.

I think you are hitting the two bugs related to your issue.

 

7821 phones consume Enhanced UCL instead of Basic in CUCM 9.x and 10.x
CSCun94112
Symptom:
License usage

Conditions:
7821 phones consume Enhanced UCL instead of Basic - in CUCM 9.x and 10.x

 

 

7821 phones consume Enhanced UCL instead of Basic - in CUCM 9.x and 10.x
CSCun03177
Symptom:
For 9.x:
Adding a 7821 phone takes up an "Enhanced" license - contradictory to documentation which says it should be a "Basic" license.


For 10.x:
Issue 1: when adding phone, it shows as 1 license ENHANCED, not Basic (like documentation says)
Issue 2: when adding user to new phone, it disappears as a license completely

Conditions:
Must upgrade 9.1.2 using the cmterm-devicepack9.1.2.12024-1.cop.sgn so that the 7821 phone shows up.

Must upgrade 10.x using the UCSInstall_UCOS_10.0.1.11001-2.sgn to resolve issue #2 for CUCM 10.x

Workaround:
Please contact Cisco TAC so they can perform the workaround on the impacted system
 

 

regds,

aman

Thank you very much AmanSo,

Thank you very much Aman

So, is not possible that 7821 phones take enhanced licenses? Even if I do not have enough basic licenses, but I have enough enhanced licenses?

Regards!

Iván

VIP Purple

Hi Ivan, Can u share the

Hi Ivan,

 

Can u share the complete snapshot of Table View which shows Status/Unused as well?

 

Also,please share the Chart View and keep the mouse on Purple Colour if it appears  which Licenses borrowed from Upper Tier 

 

regds,

aman

VIP Purple

Hi Ivan , Sorry, I missed the

Hi Ivan ,

 

Sorry, I missed the attachment.I can also see you have got 14 unused licenses under Enhanced.

 

Did u run Synchronise Now?

 

regds,

aman

Hi Aman.Yeah I have 14 unused

Hi Aman.

Yeah I have 14 unused enhanced licenses, but I have not run Synchronise Now, do I need to run this?

Regards!  

Iván

VIP Purple

Hi Ivan, please do that .

Hi Ivan,

 

please do that .

 

regds,

aman

Thank you GeorgeRight now I

Thank you George

Right now I am doing more troubleshooting, because we have enough enhanced licenses available.

 

I'll inform you.

New Member

Hiwe are facing the same

Hi

we are facing the same issue.

as I checked in firmware release note. 10.1(1) SR1

this Bug is wait for new divice pack.

 

CSCun03177

7821 phones consume Enhanced UCL instead of Basic - in CUCM 9.x and 10.x.

Note    The fix for this defect will be available with the next device pack.
VIP Purple

Hi, have u installed any


Hi,

 

have u installed any Device pack?

 

can u share show version active ?

 

regds,

aman

New Member

This is a bug in cisco and I

This is a bug in cisco and I have opened TAC case as soon as its done i will post how to resolve. 

Currently TAC wants to access the root :).

 

Thanks 

 

VIP Purple

Hi, thanks for same.please do

Hi,

 

thanks for same.please do share the findings of TAC.

 

regds,

aman

New Member

Cisco confirmed that there is

Cisco confirmed that there is a problem in 9.x version and it has been resolved in 10.X latest version.
Since I have some licensing issues we sticked to the same version which is 
9.1(2.11012) instead upgrading it to version 10.x


Step) The engineer asked us upgrade the latest device pack codec which is 

Cisco Unified Communications Manager 9.1(2.12033) Device Package - Compatible UCM Version: 9.1

http://software.cisco.com/download/release.html?mdfid=284510097&flowid=45900&softwareid=282074299&release=9.1(2.12033)&relind=AVAILABLE&rellifecycle=&reltype=latest


Step2) Asked us to create the root access user with the below commands
 
utils remote_account enable (This will enable the remote account to be able to log on to the root)

utils remote_account create ciscotac 30 (This will create a new user called ciscotac and 30 is the number of days the the username will be valid )

utils remote_account status ( To show the user has been created)


http://docwiki.cisco.com/wiki/Enabling_root_account_from_CLI

Note: The password of the ciscotac user created is with the TAC engineer and they refused to give me upon asking they told its internally generated wit the hardware id .

Note: If you dont have TAC assistance you can still log on to root with the below steps mentioned, also please do it own risk :)

How ever here is the work around  once the user is created restart the server.

admin:utils system restart
-Proceed to insert the CentOS 5.2 Disk 1
-on the Boot option enter linux rescue(or press f12)
boot:linux rescue

-Once you are in Linux shell proceed to do the following:

chroot /mnt/sysimage
cd /etc
rm securetty (removes file protection)
chattr -i passwd (gain access to file system file.. (bascially))
chattr -i shadow (gain access to file system file.. (bascially))

passwd ciscotac

Enter a password for this account. Before proceeding note that the password change was successfull, if authentication fail you probably missed the earlier steps. 

Remove CentOS disc and restart server, when fully booted log in with ciscotac 
account and the password you just configured in rescue mode.

If login successfull you should be seeing:

Welcome to Remote Support :).

Step 3) Logon with the credentials to the cucm using the putty ssh client.

root@CMPUB:/home/ciscotac[root@CMPUB ciscotac]# su informix  (Press Enter)


Step 4)

bash-3.2$ dbaccess (Press Enter)

After pressing  a menu will appear and select your data base 

in my case it was below mentioned which is actually reflects the installed version on cucm

ccm9_1_2_10000_12 -  

Step 5)

dbaccess ccm9_1_2_10000_12 -  (Press Enter)
Database selected.

Step 6)

update typelicensedresourceproductmap set tklicensedresource='2' where tkproduct='508';

We are done :).

If you have more questions we can discuss over here to help the community. please feel free to ask me .

VIP Purple

thanks for sharing the info[

thanks for sharing the info[+5]

So,now licenses being consumed are OK[basic]

regds,

aman

New Member

Yes they are working perfect

Yes they are working perfect now. Have you faced the same problem ? 

 

VIP Purple

I did not face the same

I did not face the same problem.

thanks for sharing the info.

regds,

aman

New Member

Hi,My CUCM is version 10.x

Hi,

My CUCM is version 10.x and this issues is still not resolve.

refer to BugID "CSCun03177"

For version 9.x is resolved. but not yet for version 10.x

you need to request TAC and they will send you "Temporary License" for you depend on how many 7821 IP Phone you bought.

for version 10.x is waiting for new "Device pack" version "10.0(1.11005.1)" to solve.

 

Hello you all!My issue ha

Hello you all!

My issue has been resolved with TAC help, it turns out that it was not a license issue, I hit the next bug:

 

CSCun23612

7841 Cannot join VLAN if broadcast over 30kbps.

https://tools.cisco.com/bugsearch/bug/CSCun23612

 

Its weird because I have the 9.1.2 CUCM version, and it says that only 10.1.1 is affected, but we did the workaround and it worked.

Right now, I am only check if all the phones are registered.

Thank you to all of you for the help.

 

Regards!

Iván

VIP Purple

HI Ivan, thanks for sharing

HI Ivan,

 

thanks for sharing the bug[+5]

can u please let us know how TAC engr. found this issue since your issue was related to available Licenses being not consumed ? any findings ,let us know.

 

regds,

aman

Sure Aman,Reviewing the CDP

Sure Aman,

Reviewing the CDP process, the engineer realized that phones that were not registered did not get IP address and did not respond to ping messages, even if they were configured with static addresses. With these symptoms he found this bug in his database.
 

10.1.1SR1 is the firmware that contains the fix for this bug.

Thank you again.

VIP Purple

thanks...Basically,it was a

thanks...

Basically,it was a registration issue.

regds,

aman

3592
Views
20
Helpful
21
Replies
CreatePlease login to create content