Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IP Phone 7941G does not upgrade

Hello good morning.

I have a Cisco IP Phone 7941G and when I put on my network it appears on screen "term41default" and then "Upgrading" andnever leave the screen, no boot, the screen is only Upgrading.

My version of Call Manager is 5.1

Please help me.



IP Phone 7941G does not upgrade

Check on a few of these suggstions in the forum

sounds like you either have a bad DHCP server or bad firmware on the server.   You can also try and use your own TFTP server with something TFTPd32.exe, but the files in the folder on your desktop, point your IP tftp your desktop pc. (just to bypass CUCM if you have an issues)

New Member

IP Phone 7941G does not upgrade


I have several 7941 ip phone and they're OK

Only an IP phone is giving trouble. It is only in "Upgrading" and does not start.


Re: IP Phone 7941G does not upgrade

Have you tried a factory reset on the phone?

type on the phone :

1- From the Settings menu, PRESS **# ( to unlock the menu)

2-PRESS more button

3-PRESS erase button

II- To perform a FACTORY RESET

Step 1 Unplug the power cable from the phone and then plug it back in.

The phone begins its power up cycle.

Step 2 While the phone is powering up, and before the Speaker button flashes on and off,

press and hold #.

Continue to hold # until each line button flashes on and off in sequence in amber.

Step 3 Release # and press 123456789*0#.

You can press a key twice in a row, but if you press the keys out of sequence, the factory reset will not take place.

After you press these keys, the line buttons on the phone flash red and the phone goes through the factory reset process.

Do not power down the phone until it completes the factory reset process and the main screen appears.

New Member

Re: IP Phone 7941G does not upgrade


I can not access the menu of the IP Phone, I am sending a picture of the problem for you.

New Member

IP Phone 7941G does not upgrade

Hi Jaime,

Try upgrading to an intermediate load...

New Member

Re: IP Phone 7941G does not upgrade


How do I do this?


New Member

Re: IP Phone 7941G does not upgrade


Check the device default for that phone model. (Device > Device Default)

Install a lower version load (for instance it tried to pick 8.0.2 by default, install 7.0.3 etc) and force it on the phone by selecting that load under phone config for that phone (Phone Load Name)

I'm sure you must alrady have tried a factory reset and a different switch port.

Hope it helps,

CreatePlease login to create content