Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IP Phone 7942 showing "Configuraing IP"

Hi all,

I have one IP Phone 7942 showing "configuraing IP" connected to Switch WS-C3750E-24PD-S, I found that IP Phone got power 7.0 watts from the switch interface and voice traffic not able to come on voice vlan, it's coming on data vlan and in case delete data vlan it's coming on vlan 1, kindly looking to your advice and find below the interace confguration:

interface GigabitEthernet2/0/13
 switchport access vlan 504
 switchport mode access
 switchport nonegotiate
 switchport voice vlan 6
 switchport port-security maximum 2
 switchport port-security
 switchport port-security violation restrict
 srr-queue bandwidth share 1 30 35 35
 storm-control broadcast level 50.00
 storm-control multicast level 50.00
 storm-control unicast level 50.00
 spanning-tree portfast
 spanning-tree bpduguard enable
 spanning-tree guard root
 service-policy input IDF-MARKING

6 REPLIES
New Member

Hi Abakrbshat,Did you enter

Hi Abakrbshat,

Did you enter "ip helper" command in your interface vlan 504?

 

like this:

SW(config)#int vlan 504

SW(config-if)#ip helper-address 172.20.20.1

 

you should add your dhcp ip address instead of 172.20.20.1

New Member

Where is your DHCP server?Do

Where is your DHCP server?

Do you have other phones working on this switch?

if you do a "show cdp nei" and "show cdp nei det" on the switch can you see the phone?

can you confirm the vlan is up?

 

New Member

Hi seanalexanderYes, there

Hi seanalexander

Yes, there are other IP Phones working well as shown below :

#sh cdp nei
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
SEP5475d0dac02e     Gig 2/0/7         147             H P M  IP Phone  Port 1
SEPf866f29879c0      Gig 1/0/44        155             H P M  IP Phone  Port 1
SEP5475d0dab5a2   Gig 1/0/19        123             H P M  IP Phone  Port 1
SEP5475d0dabf32     Gig 1/0/18        123             H P M  IP Phone  Port 1
SEP5475d0dac02f     Gig 2/0/20        138             H P M  IP Phone  Port 1

SEP1C17D3404879  Gig 2/0/13        164             H P M  IP Phone  Port 1 (Not Working )

 

DHCP Server is IP_Helper
 

New Member

Can you post a port config

Can you post a port config from 2/0/20 and do a sh cdp nei detail and just check there is no IP being assigned to the phone.It might be getting an IP but unable to configure TFTP.

Also might be worth doing a hardware reset on the phone. Hold down # then connect up the power, once the speed dials flash hit 123456789*0#

New Member

Issue has been solved, I

Issue has been solved, I found that issue from Port patch panel in the rack, since I pugged the IP Phone direct to switch port found that IP Phone is working well on voice vlan, but once I plug it on the port through patchpanel rack I'm facing same issue "configuraing IP" on the phone screen and voice traffic coming on the vlan 1.

 

Thanks seanalexander & invincible_ms for your support smiley

New Member

Hi invincible_ms, Yes IP

Hi invincible_ms

Yes IP_helper command already there for vlan 504(DATA) & for vlan 6(Voice),

146
Views
4
Helpful
6
Replies