Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

IP Phone Services: Custom softkeys not working

I posted this over in the developer forum, but there is so little traffic over there, I thought I'd put it here also...

I am trying to create a customized Directory Input page.  All I want is  to add a 4th softkey that redirects to a new URL.  The problem is that  when I specify a softkey for position 4, it removes all of the default  softkeys (even though there is no default softkey for position 4).   "Fine," I think, "I'll just recreate the default softkeys." (Submit,  <<, and Exit).  However, when I do, even through the XML code that  is produced looks fine, the keys do not function.  They are not greyed  out, they just don't do anything when pressed.

Here is the XML  code.  Can anyone see a problem with what I'm doing or know why it isn't  working?  I'm using SCCP code 8.4.4 running on a 7961 with CUCM 6.1.4.

<SoftKeyItem>
<Name>Submit</Name>
<Position>1</Position>
<URL>Softkey:Submit</URL>
</SoftKeyItem>

<SoftKeyItem>
<Name><<</Name>
<Position>2</Position>
<URL>Softkey:<<</URL>
</SoftKeyItem>

<SoftKeyItem>
<Name>Exit</Name>
<Position>3</Position>
<URL>Softkey:Cancel</URL>
</SoftKeyItem>

2 REPLIES
Super Bronze

Re: IP Phone Services: Custom softkeys not working

Hi

I remember this being playful when I set up something recently.

I know this sounds daft, but try reordering your XML elements - specifically, suppy the softkey elements in this order:

Name

URL

Position

Might or might not work for you...

Aaron

Please rate helpful posts...

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Re: IP Phone Services: Custom softkeys not working

I tried that, and it didn't work. But it got me thinking about partitcular hokey things that might be causeing this and I found the problem...

Apperently, the the URL needs to be "SoftKey:XXXXX".  Whereas I had "Softkey:XXXXX".  Once I put a little more 'kah' in the 'k' (i.e capitalized it), it worked fine.

Thanks for kicking my brain into gear.

207
Views
0
Helpful
2
Replies
CreatePlease to create content