Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

IP Phone SSL VPN issues with missed calls

Hi mates,

We have several users working remotely with this Cisco solution.

Now, the problem we´re facing is the missed calls are not being displayed on IP phones when these are connected to ADSL (SSL VPN sesion enabled), on the other hand if I connect any of the IP phones to corporative network the missed calls are shown properly.

The IP Phones are Cisco 7962 model with firmware 9.2(1), so I understand the problem is not related to firmware version. CUCM version is 8.0.3.22900-5

Someone knows this issue?

Any idea will be welcome, many thanks for your time.

PRO.

3 REPLIES
New Member

IP Phone SSL VPN issues with missed calls

Hi there,

I am experiencing the same issue with a 7965 connected to the CUCM via VPN. Using the same phone load.

I tried the phone on the trusted LAN just now, and the missed calls worked okay.

This is affecting the missed calls, received calls, and placed calls functions.

It must be the case that the directories URL is working over the VPN, because we get the menu displayed which offers the choice of the missed / received / placed calls. It's definitely the individual services which are experiencing the problem.

I do not have a solution to this, but would like to know if anyone else has any ideas.

Thanks,

Chris

New Member

Re: IP Phone SSL VPN issues with missed calls

Hi all,

Well, I just took a look at another post which shows that you can access missed calls etc. from the phone's web-page. This made me think, that possibly the VPN connection has blocked access in the phone to it's own web-service as far as directories are concerned.

https://supportforums.cisco.com/message/3213018#3213018

Not sure this is the case, but it made me think... So I went to the phone whilst it was connected to the VPN, checked it's IP address and tried to access the web-server on the phone (which I had ensured was enabled in the phone configuration on CUCM) and guess what - I could not access the web-server on the phone...

/Chris

New Member

Re: IP Phone SSL VPN issues with missed calls

Guys,

I have an update for this case - the problem seems to be that the TFTP server had not been configured when the phones were set-up and passed to the remote users. Whilst the phones were getting a DHCP-assigned IP address from the local DSL router in the remote locations, and the VPN was being established, the phone was somehow not configured with the TFTP server from which it should obtain it's load - this is not something typically configurable in most domestic DSL routers, but is generally available in the office LAN where phones are set-up before issue.

This meant that the phone was operating on the same firmware which was put on it when configured, and was maintaining the connection to its last-registered CUCM (it was not getting revised config from TFTP). By setting the TFTP server address (manual setting of Alternative TFTP), the phone was able to get its updated image and then re-attempt registrration.

After this was done, the phone was able to access the missed / placed and received call logs correctly.

It is not specifically the TFTP change which has fixed this in my opinion, but the TFPT change allowed the phone to update firmware and operate correctly it seems.

Summary - check TFTP address and firmware.

/Chris

1859
Views
5
Helpful
3
Replies