Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

IP Phones and ATA not registering with CCM 4.2.3

Hi there,

For some reason we started having this issue one week ago, whenever we try to register s new or used IP Phones to CCM, we can see that the phones get stuck in the configuring IP phase, the only way for resolving out this situation is by hardcoding the IP, Sub; TFTP. I noticed 1 week ago that the configuration of the Switch was wrong (cat4507) so I changed it but the issue was exactly the same hence I went back to the previous configuration:

ip dhcp pool IP_PHONES

network 172.20.114.0 255.255.254.0

default-router 172.20.114.1

option 150 ip 172.20.114.245 172.20.114.246

dns-server 10.255.255.106

interface Vlan8

ip address 172.20.114.1 255.255.254.0

The above configuration was on the router last week, and it was changed to the following:

ip dhcp pool IP_PHONES

network 172.20.114.0 255.255.254.0

default-router 172.20.114.1

option 150 ip 172.20.114.245

dns-server 10.255.255.106

interface Vlan8

ip address 172.20.114.1 255.255.254.0

ip helper-address 172.20.114.246

However the last configuration didn't work neither, I am stuck with this issue and don't know whether or not I am doing something wrong.

Any help is much appreciated.

CC

9 REPLIES
New Member

Re: IP Phones and ATA not registering with CCM 4.2.3

Are you getting a dhcp address from Vlan8 interface?

New Member

Re: IP Phones and ATA not registering with CCM 4.2.3

Hi John,

Thanks for the reply, unfortunately I am not getting any information when I look at the phone settings, whenever I try to bring the phones up, I got nothing but the configuring IP even though I look at the phone settings, no Sub,TFTP, DHCP.

If you need the configuration, I can attach this one for you,

Thanks

New Member

Re: IP Phones and ATA not registering with CCM 4.2.3

Carlos, are any phones on that vlan registering to callmanger? Are all phones not getting DHCP address?

Can you get DHCP address on data vlan? Lets check that.

New Member

Re: IP Phones and ATA not registering with CCM 4.2.3

it seems that all the phones are being registered, but whenever I try to change an extension in CCM and try to register the new phone, the issue happens besides I had tried to register a couple of new phones to CCM but when I assign the extension number, the phones get stuck in configuring IP, I have seen this happening with a couple of phones and ATA's only, probably about 20 phones, however if I hard code the ip, subnet, tftp and default gateway then everything works just fine.

New Member

Re: IP Phones and ATA not registering with CCM 4.2.3

HellO Carlos ,

Can you configure the Switch Port connected to one of those Phones /ATA's with a Data Vlan ID and check whether the Phone will be able to retrieve any Settings from the DHCP ( No Problem if the Phone wont Register ) we just need to make sure that it is something wrong with the Interface VLAN and/or the Voice DHCP Pool.

I Suggest to configure the Switch Port as ( Switchport Access Vlan X ) where "X" is a working VLAN ID.

Regards

M.Tag

New Member

Re: IP Phones and ATA not registering with CCM 4.2.3

Carlos,

If you have made changes in the network environment and these new phones had been working under the old set up, you may need to reset them by going to Settings>Network Configuration>Erase Configuration and then hitting **# to allow you to choose it.

-Shikamaru

New Member

Re: IP Phones and ATA not registering with CCM 4.2.3

I received an RMA for the ATA's which were failing, I tried to configure 'em back in CCM and the same behaviour, however I was able to identify something different this time, when I just set up the ata's, they registered with my port, however when I moved 'em to the correct location, they did't register at all besides the all IP Address continues appearing in CCM, I am almost sure that there is something wrong with the DHCP configuration, I applied the change mentioned Mohamed indeed but it made no difference at all, and when I changed the switchport access vlan setting, I was able to see that the ATA didn't retrieve any information / setting from the DHCP, probably there is something wrong with the voice DHCP Pool because all other vlans are working just great, attached is the configuration of my core switch and IDF switches.

Any help is appreciated

New Member

Re: IP Phones and ATA not registering with CCM 4.2.3

Carlos, which switch port is the ATA connected to? It looks like Vlan8 is your voice vlan, correct?

-Shikamaru

New Member

Re: IP Phones and ATA not registering with CCM 4.2.3

Hello Carlos ,

It seems that these is something wrong with the Voice Vlan the ATA's are attached to them..Did you check Option 066 on the DHCP Server pointing to the TFTP Addrress whether it is pointing to the Correct TFTP Server Address or not..

Regards

M.Tag

140
Views
0
Helpful
9
Replies
CreatePlease to create content