Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IP Phones don't display Caller ID on incoming calls

We have recently installed a UC540 system with two BRI connections to the ISDN.
Incoming and outgoing calls are fine however when a call is received the phone displays 'Unknown number' and 'From: <blank>' regardless of the caller. Even numbers within the local directory show up like this. Any assistance with this would be appreciated!

Thanks Jim

4 REPLIES
Hall of Fame Super Gold

Re: IP Phones don't display Caller ID on incoming calls

As mentioned in so many other posts on the very same subject.

Take "debug isdn q931" with "term mon"

If no calling number is present, complain to telco.

Hello every one! I got the

Hello every one!

 

I got the same problem; but I can't execute the debug what Paolo says. My router are running Version 15.0(1)M1 of IOS, and there's imposible introduce it. I tried with many options and searched with "?":
 

Rotuer#
Rotuer#debug isdn q931
                          ^
% Invalid input detected at '^' marker.

Rotuer#

 

 

Paolo, can you post here the links about your other posts. Please :) . 

Hi, Can you share the output

Hi,

 

Can you share the output of debug voice ccapi

New Member

Jim, Please share "show run"

Jim,

 

Please share "show run" and "show version" from router.

~Avinash

759
Views
4
Helpful
4
Replies