Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ip phones don't receive dn or template after issuing ephone reset

I'm still a little new to iOS programmed telephony.  I recently swapped two handsets, and I needed to change the extensions.  I figured the easiest way would be to ssh into the router, head to the ephone, drop the MACs, and re-register the MACs to the new ephone it coresponded with.  It made logical sense... I don't know what the hell I did wrong, but now, when I issue a reset command to any of our ephones (or simply a power cycle), they don't load the template or have any dial tone.  They DO list the correct date and time, the correct company name at the bottom left, and the correct speed dial buttons.  No actual template for the softkeys or right button configurations are showing, but the speed-dial button is.  No description, no ability to ring the extension, nothing.  This is occuring for ALL phones that get reset on the system now, and NOT just the phones that I swapped...

I do recall issuing a "no telephony-service" command for some reason, I think one of the drop MAC commands I was trying to issue implied I needed to stop the service, and maybe I did the wrong command.  It might make sense that that would be causing these issues on reset phones, seeming like the telephony-service command was a service I could stop and start, but I see no way to "start", so to speak, the telephony-service.

 

9 REPLIES
Cisco Employee

When you do a no telephony

When you do a no telephony-service, you turn off the service and lose the configuration of all ephones that were done on the CME. Check the following:

1/ Navigate to the Settings -> Status -> Status messages on the phone to see what's happening on them. That should give you the first clue of where the phones are in their stage of registering to the CME.

2/ Check the configuration file located on the flash: of the router. You can do this by doing show flash. If you don't see any configuration files of the format 'SEP.cnf.xml, look for the XMLDefault.cnf.xml file. If you don't see this either, it means the phones can't receive any configuration from the CME.

I'd suggest adding the following commands under telephony-service:

cnf-file location flash:

cnf-file perphone

create cnf-files

This should create the config files for all the phones. You can then do 'more flash:/its/vrf1/SEP<>.cnf.xml to see if that file contains the right information for the phone to pick up.

 

3/ do a debug tftp events on the router so you can see the phones try to reach the CME and see what file they're unable to get.

 

Thanks

New Member

Current status messages are

First, thank you very much for taking a few minutes to look at this.  I think the issue/fix is something very minor, I'm just a little new to some of these commands.  I think this is all stemming from an accidental "no telephony-service" command having been issued...

 

Current status messages are:

11:18:05p File Not Found : CTLFile.tlv
11:18:05p No CTL installed
11:18:05p SEPB8621F6CD32B.cnf.xml
11:18:07p Error Updating Locale
11:18:07p Error Updating Locale
8:36:43a File Not Found : CTLFile.tlv
8:36:43a No CTL installed
8:36:43a SEPB8621F6CD32B.cnf.xml
8:36:45a Error Updating Locale
8:36:45a Error Updating Locale

So clearly it's not finding its configuration file... but, telephony-service looks like it has what it needs to issue those CNF files already, which is what you recommended.  If I did a "no telephony-service", what specifically would I need to do to reverse exactly that, and re-enable telephony-service?  I did a comparison of an old running-config, and the telephony-service options all seem identical.

 

Current telephony-service config is:

telephony-service
 sdspfarm units 2
 sdspfarm tag 1 ***************
 conference hardware
 max-ephones 20
 max-dn 300 no-reg both
 ip source-address (correct address) port 2000
 system message ***************
 cnf-file location flash:
 cnf-file perphone
 load 7942 SCCP42.8-5-3SR1S
 load 7965 SCCP45.9-1-1SR1S
 time-zone 5
 live-record 201
 voicemail 200
 max-conferences 8 gain -6
 call-forward pattern .T
 moh music-on-hold.au
 web admin system name *********** password ************
 dn-webedit
 time-webedit
 transfer-system full-consult
 transfer-pattern .T
 secondary-dialtone 9
 create cnf-files version-stamp Jan 01 2002 00:00:00

 

I can see the three options you recommend already in our running config file, so how would I simply re-enable all of this?  It seems like it's all correct, but the service itself simply isn't running...

 

 

Cisco Employee

On the contrary, it looks

On the contrary, it looks like the phone did find the configuration file. If it didn't, you would see a failure message in the status messages indicating it didn't get it, and it would then look for the default file.

Please take the debug tftp events on the CME and paste them here. That should tell us what's going on.

 

Thanks

New Member

Running "debug tftp events"

Running "debug tftp events" at the router seems to enable debugging, where would I find the log for this?  

Cisco Employee

Run the command terminal

Run the command terminal monitor. That should bring up the debugs on the telnet session with which you connected to the router.

you can also refer to this guide.

http://www.cisco.com/web/tsweb/tools/voice/multiservicedebuglookup.html

New Member

so I hit term mon to enable

so I hit term mon to enable terminal monitoring.

Next, "show debug" which only gives:

TFTP:
  TFTP Event debugging is on

 

This makes me thinkg I simply haven't logged anything.  I issue another reset to the ephone, and run show debug again.  Same thing as above.  :(

I checked out the link you posted, and ran everything it recommended for this scenario.  Tried a show debug again, same thing, just that TFTP event debugging is on.

 

Tried "router# tftp debug" as some research suggested would display the debug, but the response is that its an incomplete command.

Cisco Employee

Those are the logging monitor

Those are the logging monitor outpu on the router. Informational messages.

If we don't see tftp debugs show up on the logs after enabling debug tftp events, that means the phones may be unable to reach the CME.

Have you tried to reload the router?

We may need to take packet captures to see what's happening. Are you using a dhcp server for te phones? Where is that located?

Also, let's check if the debugging is working ok. Please do the debug ip tcp packet command and terminal monitor, and see if you can view the tcp packets on the router.You can check if any packets are arriving from the phone that's having the problem.

New Member

This is pretty much the only

This is pretty much the only logging I can get after enabling TFTP logging, and issuing "router#show logging"

 

Syslog logging: disabled (0 messages dropped, 2 messages rate-limited, 212 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.

 

 

No Inactive Message Discriminator.

 

    Console logging: level debugging, 235 messages logged, xml disabled,

                     filtering disabled

    Monitor logging: level debugging, 0 messages logged, xml disabled,

                     filtering disabled

        Logging to: vty389(0)

    Buffer logging:  level debugging, 18 messages logged, xml disabled,

                    filtering disabled

    Exception Logging: size (4096 bytes)

    Count and timestamp logging messages: disabled

    Persistent logging: disabled

    Trap logging: level debugging, 18 message lines logged

        Logging to 192.168.111.22  (udp port 514, audit disabled,

              link up),

              18 message lines logged, 

              0 message lines rate-limited, 

              0 message lines dropped-by-MD, 

              xml disabled, sequence number disabled

              filtering disabled

 

Log Buffer (8192 bytes):

 

Jan  2 12:00:04.663: %LICENSE-6-EULA_ACCEPT_ALL: The Right to Use End User License Agreement is accepted

Jan  2 12:00:04.755: %IOS_LICENSE_IMAGE_APPLICATION-6-LICENSE_LEVEL: Module name = c2900 Next reboot level = ipbasek9 and License = ipbasek9

Jan  2 12:00:04.911: %IOS_LICENSE_IMAGE_APPLICATION-6-LICENSE_LEVEL: Module name = c2900 Next reboot level = securityk9 and License = securityk9

Jan  2 12:00:05.115: %IOS_LICENSE_IMAGE_APPLICATION-6-LICENSE_LEVEL: Module name = c2900 Next reboot level = uck9 and License = uck9

Mar 20 19:19:03.615: %IFMGR-7-NO_IFINDEX_FILE: Unable to open nvram:/ifIndex-table No such file or directory

Mar 20 19:19:12.907: %PVDM-6-UNSUPPORTED: Codec G.723 is not supported on PVDM3.

Mar 20 19:19:29.363: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State changed to: Initialized 

Mar 20 19:19:29.367: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State changed to: Enabled 

Mar 20 19:19:30.127: %LINEPROTO-5-UPDOWN: Line protocol on Interface VoIP-Null0, changed state to up

Mar 20 19:19:30.127: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to up

Mar 20 19:19:30.131: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to up

Mar 20 19:19:30.131: %LINK-3-UPDOWN: Interface GigabitEthernet0/2, changed state to down

Mar 20 19:19:30.131: %LINK-3-UPDOWN: Interface ISM0/0, changed state to up

Mar 20 19:19:31.007: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down

Mar 20 19:19:31.231: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

Mar 20 19:19:31.231: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up

Mar 20 19:19:31.231: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/2, changed state to down

Mar 20 19:19:31.231: %LINEPROTO-5-UPDOWN: Line protocol on Interface ISM0/0, changed state to up

 

I'm not sure what any of that means, but it sure doesn't look like TFTP logs...

New Member

I'm starting to think the "no

I'm starting to think the "no telephony-service" is what made things screwy, and I just need to reverse whatever that did... would the restart/reset telephony-service command make any difference?

185
Views
0
Helpful
9
Replies
CreatePlease login to create content