Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IP Phones not pulling loads

The phone is a 7931, the router is an 1861ISR.

I have the tftp statements in the global config, as well as the load statement in the telephony-service. when I plug in the phone, it gets an IP address via dhcp and then just sits for a while until it reboots.

sh flash:

101        639 Jan 16 2009 10:49:54 -06:00 SCCP31.8-4-2S.loads

sh conf | b telephony-service

load 7931 SCCP31.8-4-2S

tftp-server flash:apps31.8-4-1-23.sbn
tftp-server flash:cnu31.8-4-1-23.sbn
tftp-server flash:cvm31sccp.8-4-1-23.sbn
tftp-server flash:dsp31.8-4-1-23.sbn
tftp-server flash:jar31sccp.8-4-1-23.sbn
tftp-server flash:SCCP31.8-4-2S.loads
tftp-server flash:term31.default.loads
tftp-server flash:SCCP31.8-4-2S

I have turned on debug ephone register, and I dont see anything at all while the phone's plugged in rebooting.

What have I forgotten, and what debugs would you reccomend?

3 REPLIES
Cisco Employee

Re: IP Phones not pulling loads

Can we verify that phone gets the correct TFTP IP via DHCP ?

If yes, get following:

deb tftp eve

deb ephone regis mac xxxx.yyyy.zzzz

Also use  show telephony tftp followed by more

to verify that XML is pointing to correct load file (without the .loads

extn)

example:

more  system:/its/vrf1/XMLDefault7931.cnf.xml

New Member

Re: IP Phones not pulling loads

here's the output from sh telephony tftp;

sh telephony-service tftp

tftp-server system:/its/united_states/7960-tones.xml alias United_States/7960-tones.xml

tftp-server system:/its/united_states/7960-font.xml alias English_United_States/7960-font.xml

tftp-server system:/its/united_states/7960-font.xml alias English_United_States/7920-font.xml

tftp-server system:/its/united_states/7960-dictionary.xml alias English_United_States/7960-dictionary.xml

tftp-server system:/its/united_states/7960-kate.xml alias English_United_States/7960-kate.xml

tftp-server system:/its/united_states/7960-kate.xml alias English_United_States/7920-kate.xml

tftp-server system:/its/united_states/SCCP-dictionary.xml alias English_United_States/SCCP-dictionary.xml

tftp-server system:/its/vrf1/XMLDefault7931.cnf.xml alias SEP2893FE1213BD.cnf.xml

tftp-server system:/its/SEPDEFAULT.cnf alias SEPDefault.cnf

tftp-server system:/its/vrf1/XMLDefault.cnf.xml alias XMLDefault.cnf.xml

tftp-server system:/its/vrf1/ATADefault.cnf.xml alias ATADefault.cnf.xml

Ah ha! What's the correct command to add my phone loads to this list?

Thanks.

Cisco Employee

Re: IP Phones not pulling loads

If you do more system:/its/vrf1/XMLDefault7931.cnf.xml do you

see load statement pointing to SCCP31.8-4-2S ?

If not, go ahead and configure

telephony-service

  load 7931 SCCP31.8-4-2S

  no create cnf

  creat cnf

then reset/power cycle the phone.

Pl. collect those debugs/info if the issue persists...

395
Views
0
Helpful
3
Replies
CreatePlease to create content