Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

IP Voice Media Streaming App won't start

I'm using CUCM 7.1.5, but this was occurring in 7.1.3 also.  I can start all of my other services except this one.  CUCM says it starts the service successfully, but it still says "Not Running."  This is the output of the service's log file.  At the bottom it says it can't find the device driver.  Any thoughts on how to fix this?  Thanks.

05/21/2010 07:27:31.552 VoiceStrm|   PITrace: *ERROR* [CRITIAL INFO]: platform install api isDeployedStandalone()= true|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.553 VoiceStrm|   PITrace: *ERROR* [CRITIAL INFO]: platform install api prods[0]=CallManager|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.553 VoiceStrm|   PITrace: *ERROR* [CRITIAL INFO]: Platform Box Configuration :0 (CCM:0,UNITY:1,CoRes:2,Unknown:3)|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.553 VoiceStrm|   PITrace: *ERROR* Important info only, Category[Cisco Tomcat]: productid_enable_flag=1, system_enable_flag=1|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.553 VoiceStrm|   PITrace: *ERROR* Important info only, Category[DBMon]: productid_enable_flag=1, system_enable_flag=1|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.553 VoiceStrm|   PITrace: *ERROR* Important info only, Category[CallManager]: productid_enable_flag=1, system_enable_flag=1|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.553 VoiceStrm|   PITrace: *ERROR* Important info only, Category[CmiManager]: productid_enable_flag=1, system_enable_flag=1|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.553 VoiceStrm|   PITrace: *ERROR* Important info only, Category[CtiManager]: productid_enable_flag=1, system_enable_flag=1|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.553 VoiceStrm|   PITrace: *ERROR* Important info only, Category[Cisco TcdSrv]: productid_enable_flag=1, system_enable_flag=1|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.553 VoiceStrm|   PITrace: *ERROR* Important info only, Category[Cisco TFTP]: productid_enable_flag=1, system_enable_flag=1|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.553 VoiceStrm|   PITrace: *ERROR* Important info only, Category[CiscoAXLWebService]: productid_enable_flag=1, system_enable_flag=1|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.553 VoiceStrm|   PITrace: *ERROR* Important info only, Category[Cisco Media Streaming App]: productid_enable_flag=1, system_enable_flag=1|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.553 VoiceStrm|   PITrace: *ERROR* Important info only, Category[CiscoEM]: productid_enable_flag=1, system_enable_flag=1|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.553 VoiceStrm|   PITrace: *ERROR* Important info only, Category[CiscoWebdialer]: productid_enable_flag=1, system_enable_flag=1|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.553 VoiceStrm|   PITrace: *ERROR* Important info only, Category[CiscoIPMA]: productid_enable_flag=1, system_enable_flag=1|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.553 VoiceStrm|   PITrace: *ERROR* Important info only, Category[RISSystemAccess]: productid_enable_flag=1, system_enable_flag=1|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.554 VoiceStrm|   PITrace: *ERROR* [IMPORTANT INFO]  AppCrashCheckBase::AppCrashCheckBase() the RW_Process_Mutex is :/dev/shm/Category_CiscoMediaStreamingApp_Mutex_crash_checker
|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.554 VoiceStrm|   PITrace: *ERROR* [IMPORTANT INFO] AppCrashCheckBase::AppCrashCheckBase() acquire lock successed. : errno = 0; strerr = Success|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.554 VoiceStrm|   PITrace: *ERROR* [IMPORTANT INFO]WriterSideCheck() open existing flag_check_mmf left from last run. : errno = 17; strerr = File exists|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.554 VoiceStrm|   PITrace: *ERROR* [IMPORTANT INFO]ExAppCrashCheck::WriterSideCheck() create/open flag_check_mmf successed!!! : errno = 17; strerr = File exists|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.555 VoiceStrm|   PITrace: *ERROR* {Debug infomation}: look from writer side, writer crashed last time : true|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.555 VoiceStrm|   PITrace: *ERROR* CPICategory::loadXmlFile() Category: [Cisco Media Streaming App] xmlfile: [/usr/local/cm/conf/MediaAppPerfmon.xml] |<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.558 VoiceStrm|   PITrace: *ERROR* CPIClass::createMMF() MMF file : [/Category_CiscoMediaStreamingApp_PIClass_MEDIAAPP_GLOBAL_OBJECT_MDB] is started.(no error)|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.562 VoiceStrm|   PITrace: *ERROR* ExObjectUpdateTracker::ExObjectUpdateTracker::_synchronizeMAP() m_nIndex  :0 m_nRoundCount : 0  m_nTick: 0|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.562 VoiceStrm|   PITrace: *ERROR* [SIGNIFICANT INFO]Category Name: Cisco Media Streaming App file: /usr/local/cm/conf/MediaAppPerfmon.xml enbled_flag: 1|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.562 VoiceStrm|   PITrace: *ERROR* [SIGNIFICANT INFO]Add ITraceObj for Category Name: Cisco Media Streaming App, tid:8971l|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.562 VoiceStrm|   PITrace: *ERROR* [SIGNIFICANT]::statsInit() enable_flag=1|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.563 VoiceStrm|   CIpVMSMgr::Init *ERROR* Failed Open device driver.|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>
05/21/2010 07:27:31.564 VoiceStrm|kIPVMSDeviceDriverNotFound - Cisco IP voice media streaming driver not found. App ID:Cisco IP Voice Media Streaming App Cluster ID:StandAloneCluster Node ID:cucmpub|<CLID::StandAloneCluster><NID::10.0.1.13><CT::Alarm><LVL::All><MASK::ffff>
05/21/2010 07:27:31.564 VoiceStrm|   CIpVMSMgr::MgrThreadProc *ERROR* Failure in Init, tell ipvmsd to quit|<CLID::StandAloneCluster><NID::10.0.1.13><LVL::Error><MASK::0002>

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Red

Re: IP Voice Media Streaming App won't start

Hi there,

Is this built on VMware by any chance? If so please check this thread

http://www.techexams.net/forums/ccvp/46458-cucmbe-7-1-2-vmware.html

Cheers!

Rob

Please support CSC Helps Haiti

https://supportforums.cisco.com/docs/DOC-8895

https://supportforums.cisco.com/docs/DOC-8727

6 REPLIES
Hall of Fame Super Red

Re: IP Voice Media Streaming App won't start

Hi there,

Is this built on VMware by any chance? If so please check this thread

http://www.techexams.net/forums/ccvp/46458-cucmbe-7-1-2-vmware.html

Cheers!

Rob

Please support CSC Helps Haiti

https://supportforums.cisco.com/docs/DOC-8895

https://supportforums.cisco.com/docs/DOC-8727

Bronze

Re: IP Voice Media Streaming App won't start

Yes, that is exactly right.  ESX 4.0 and I'm running AMD.  So this looks very promising.  I will give it a shot and report back my findings.  Thank you very much Rob.

Bronze

Re: IP Voice Media Streaming App won't start

Rob,

I used those directions and found some other ones that worked better for me and it solved my issue!  Here are the steps for the archives:

Download the CentOS 5.x CD

Restart the VM with that CD

At the "boot:" prompt type "linux rescue"

Then after it finishes booting up type "chroot /mnt/sysimage"

That will try to mount the CUCM file system to the root directory.

Then navigate to /lib/modules/cm_ipvms/ and identify directory xyz.i686
Create a new directory called xyz.athlon and copy all contents from xyz.i686 to the new directory xyz.athlon

Do the same for all directories ending .i686, so there is a .athlon equivalent for each i686 folder.

Restart CUCM vmware and boot normally

Then try to start the service.

New Member

Re: IP Voice Media Streaming App won't start

Hello, confirmed working on 7.1.5SU3 as well.

thx !

I am having the same issue.

I am having the same issue. The Cisco IP Voice Media Streaming App is activated but doesnt seem to want to start. I am also running on VMware ESXi, although I can not follow the link in your post. What was the solution to this issue?

Disregard the last post. I

Disregard the last post. I followed the guide and MoH is now working.

Thanks!

3339
Views
10
Helpful
6
Replies