Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

IPPhone unable to grab IP

Hi,

need assistance here. Have anyone encounter issue of setting up IPPhones with static Addressing on data VLAN?

Here are the set up on my L3 switch:

Vlan Assignment:

Vlan 420 - dhcp (data)

Vlan 120 - dhcp (voice)

Vlan 440 - static (data)

Port configuration

set-up1(both dchp):

interface FastE 0/1

switchport access vlan 420

switchport mode access

switchport voice vlan 120

Set-up2(Static on data and dhcp on phone):

interface fastE 0/2

switchport access vlan 440

switchport mode access

switchport voice vlan 120

DHCP Scope:

ip dhcp pool for_vlan420

network 10.150.2.0 255.255.255.0

default-router 10.150.2.1

domain-name newbies.com

option 242 ascii "L2Q=1,L2QVLAN=120"

dns-server A.B.C.D

(observation: IPPhone and Notebook able to grab IP)

ip dhcp pool Static_vlan440

host 10.150.3.19 255.255.255.128

client-identifier 0100.xxxx.xxxx.xx

default-router 10.150.3.1

domain-name newbies.com

option 242 ascii "L2Q=1,L2QVLAN=120"

dns-server A.B.C.D

(observation: Notebook only grabs the IP and IPPhone cannot)

Thanks in advance ;)

2 REPLIES
Hall of Fame Super Gold

Re: IPPhone unable to grab IP

Hi,

you need option 150 with the IP of CM in dhcp pools. Without that, IP phones will not accept DHCP offer.

Hope this helps, please rate post if it does!

Community Member

Re: IPPhone unable to grab IP

Hi,

We are using Avaya.

thanks

252
Views
0
Helpful
2
Replies
CreatePlease to create content