Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Is there any way to route an external number to a different internal number.

Hi All,

I am not a Cisco engineer but I would like to know if I am being given the correct information.  If a client calls us on our external number for example,  0161 123 2000 my understanding is that number can be routed through to the device with the number 2000.

Is there any way we can route the call made to  0161-123-2000   to a device with a different number such as 3000.

9 REPLIES
VIP Super Bronze

Is there any way to route an external number to a different inte

Yes you can do that. What platform are you running? CCME or CUCM. You can use either translation rules or translation pattern

Pls rate useful posts

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Is there any way to route an external number to a different inte

Thanks for your reply.   I'm not sure which platform we are using but is translation rules/pattern available on both?

Do you have any further information on how to implement that?

VIP Super Bronze

Is there any way to route an external number to a different inte

It depends on what platform you are using..I can help you with the configuration but need toknow what platform you are using..So if you can get the details of the platform and the configuration on the router then this is quite easy to do

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Is there any way to route an external number to a different inte

Thanks I'll find out.  What information do you need to know about the configuration of the router?

VIP Super Bronze

Is there any way to route an external number to a different inte

the running configuration..

on the router you will type

'sh run'

Then let me know the external number(s) you want to convert to internal number( I also need to internal number(s))

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Is there any way to route an external number to a different inte

Hi,  The numbers we are calling in on is:   0161 333 5800   to   0161 333 5869

The internal range is:    2400 to 2469

So for example, if we wanted to dial 0161-333-5806  we want that to route to   0161-333-2406

Current configuration : 9599 bytes

!

! Last configuration change at 11:35:50 GMT Fri Jun 1 2012

! NVRAM config last updated at 12:56:58 GMT Thu May 31 2012

!

version 15.0

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime

service timestamps log datetime localtime

service password-encryption

!

hostname welsp482-hydecheshi-2197721

!

boot-start-marker

boot-end-marker

!

card type e1 0 0

no logging console

enable secret 5 $1$lGDC$A2sExqr4De9rt5YQuItH/0

!

--More--                           no aaa new-model

clock timezone GMT 0

network-clock-participate wic 0

!

no ipv6 cef

no ip source-route

ip cef

!

!

!

!

no ip bootp server

no ip domain lookup

ip host WEL-CCMSERV-01 172.16.2.10

ip host WEL-CCMSERV-02 172.16.2.11

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-net5

!

!

--More--                           !

voice-card 0

dspfarm

dsp services dspfarm

!

!

!

!

!

!

!

application

global

  service alternate default

!

!

license udi pid CISCO2921/K9 sn FCZ14307232

hw-module pvdm 0/0

!

!

!

!

redundancy

--More--                           !

!

controller E1 0/0/0

pri-group timeslots 1-30 service mgcp

!

controller E1 0/0/1

!

!

class-map match-any af43

match access-group name af43

class-map match-any af42

match access-group name af42

class-map match-any af41

match access-group name af41

class-map match-any ef

match access-group name ef

class-map match-any af21

match access-group name af21

class-map match-any af12

match access-group name af12

class-map match-any af31

match access-group name af31

class-map match-any af13

--More--                            match access-group name af13

class-map match-any af32

match access-group name af32

class-map match-any af23

match access-group name af23

class-map match-any af11

match access-group name af11

class-map match-any af33

match access-group name af33

class-map match-any af22

match access-group name af22

class-map match-any be

match access-group name be

class-map match-any drop

match access-group name drop

class-map match-any besteffort

match ip dscp default

class-map match-any realtime

match ip dscp cs5  ef

class-map match-any priority

match ip dscp cs4  af41  af42  af43

class-map match-any cs1

match access-group name cs1

--More--                           class-map match-any cs2

match access-group name cs2

class-map match-any cs3

match access-group name cs3

class-map match-any cs4

match access-group name cs4

class-map match-any cs5

match access-group name cs5

class-map match-any cs6

match access-group name cs6

class-map match-any cs7

match access-group name cs7

class-map match-any missioncritical

match ip dscp cs3  af31  af32  af33  cs6  cs7

class-map match-any transactional

match ip dscp cs2  af21  af22  af23

class-map match-any general

match ip dscp cs1  af11  af12  af13

!

!

policy-map mark

class ef

  set ip dscp ef

--More--                            class af41

  set ip dscp af41

class af31

  set ip dscp af31

class af21

  set ip dscp af21

class af11

  set ip dscp af11

class cs5

  set ip dscp cs5

class cs4

  set ip dscp cs4

class af42

  set ip dscp af42

class af43

  set ip dscp af43

class cs3

  set ip dscp cs3

class af32

  set ip dscp af32

class af33

  set ip dscp af33

class cs6

--More--                             set ip dscp cs6

class cs7

  set ip dscp cs7

class cs2

  set ip dscp cs2

class af22

  set ip dscp af22

class af23

  set ip dscp af23

class cs1

  set ip dscp cs1

class af12

  set ip dscp af12

class af13

  set ip dscp af13

class drop

   drop

class be

  set ip dscp default

policy-map etm-WelspunCorp

class realtime

    priority 1536

    police 1536000 conform-action transmit  exceed-action drop

--More--                            class priority

    bandwidth remaining percent 40

     random-detect dscp-based

class missioncritical

    bandwidth remaining percent 39

     random-detect dscp-based

class transactional

    bandwidth remaining percent 16

     random-detect dscp-based

class general

    bandwidth remaining percent 1

     random-detect dscp-based

class class-default

    bandwidth remaining percent 4

     random-detect dscp-based

policy-map shape-etm-WelspunCorp

class class-default

    shape average 3400000 13600 0

  service-policy etm-WelspunCorp

!

!

!

!

--More--                           !

interface Loopback0

description VzB Management IP address

ip address 10.0.5.65 255.255.255.255

!

interface GigabitEthernet0/0

description welsp482-hydecheshi-2197721 WelspunCorp Port,Ckt:w0x73599

bandwidth 3400

ip address 152.183.21.146 255.255.255.252

ip nbar protocol-discovery

duplex full

speed 10

no cdp enable

max-reserved-bandwidth 90

service-policy output shape-etm-WelspunCorp

!

interface GigabitEthernet0/1

description welsp482-hydecheshi-2197721 LAN

ip address 10.0.5.69 255.255.255.254 secondary

ip address 172.16.15.1 255.255.255.0

duplex full

speed 100

service-policy input mark

--More--                           !

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/2/0

!

interface FastEthernet0/2/1

!

interface FastEthernet0/2/2

!

interface FastEthernet0/2/3

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

--More--                           interface Vlan1

no ip address

!

!

router bgp 65109

no synchronization

bgp log-neighbor-changes

redistribute connected

redistribute static route-map static-bgp

neighbor 152.183.21.145 remote-as 65000

no auto-summary

!

no ip forward-protocol nd

no ip forward-protocol udp tftp

no ip forward-protocol udp nameserver

no ip forward-protocol udp domain

no ip forward-protocol udp time

no ip forward-protocol udp netbios-ns

no ip forward-protocol udp netbios-dgm

no ip forward-protocol udp tacacs

!

no ip http server

no ip http secure-server

--More--                           !

ip route 10.0.5.64 255.255.255.248 Null0

ip route 172.16.15.0 255.255.255.0 GigabitEthernet0/1 172.16.15.2

ip route 192.168.4.0 255.255.255.0 GigabitEthernet0/1 192.68.232.11

ip route 192.168.230.0 255.255.254.0 GigabitEthernet0/1 192.168.230.11

ip route 192.168.232.0 255.255.255.0 GigabitEthernet0/1 192.168.232.11

!

ip access-list extended af11

ip access-list extended af12

ip access-list extended af13

ip access-list extended af21

ip access-list extended af22

ip access-list extended af23

ip access-list extended af31

permit ip any any

ip access-list extended af32

ip access-list extended af33

ip access-list extended af41

ip access-list extended af42

ip access-list extended af43

ip access-list extended be

ip access-list extended cs1

ip access-list extended cs2

--More--                           ip access-list extended cs3

ip access-list extended cs4

ip access-list extended cs5

ip access-list extended cs6

ip access-list extended cs7

ip access-list extended drop

ip access-list extended ef

permit udp 172.16.15.0 0.0.0.255 any

!

ip sla 300

icmp-echo 152.183.21.145 source-ip 152.183.21.146

request-data-size 64

tos 112

owner PPM_MCPA_RP-WGTNGE01

frequency 300

ip sla schedule 300 life forever start-time now

!

no cdp run

!

!

!

route-map static-bgp deny 10

--More--                            match tag 999

!

route-map static-bgp permit 20

!

!

!

control-plane

!

!

voice-port 0/0/0:15

!

voice-port 0/1/0

!

voice-port 0/1/1

!

voice-port 0/1/2

!

voice-port 0/1/3

!

ccm-manager switchback immediate

ccm-manager fallback-mgcp

ccm-manager redundant-host 172.16.2.11

ccm-manager mgcp

--More--                           ccm-manager music-on-hold

ccm-manager config

!

mgcp

mgcp call-agent 172.16.2.10 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

mgcp sdp simple

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface GigabitEthernet0/1

mgcp bind media source-interface GigabitEthernet0/1

!

mgcp profile default

!

sccp local GigabitEthernet0/1

sccp ccm 172.16.2.11 identifier 1 priority 1 version 6.0

sccp ccm 172.16.2.10 identifier 2 priority 2 version 6.0

sccp

!

sccp ccm group 1

--More--                            associate ccm 1 priority 1

associate ccm 2 priority 2

associate profile 1 register Cheadle-VG-CONF

associate profile 2 register Chealde-VC-XCOD

switchover method immediate

switchback method graceful

switchback interval 30

!

dspfarm profile 2 transcode 

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729br8

codec g729r8

maximum sessions 2

associate application SCCP

!

dspfarm profile 1 conference 

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

--More--                            codec g729r8

codec g729br8

maximum sessions 4

associate application SCCP

!

!

!

!

gatekeeper

shutdown

!

privilege exec level 1 traceroute

privilege exec level 1 ping

privilege exec level 1 show configuration

privilege exec level 1 show

banner motd ^C

*****************************************************************

*                           Warning                             *

*           THIS DEVICE IS PART OF A PRIVATE NETWORK            *

*                                                               *

*  DISCONNECT IMMEDIATELY IF YOU ARE NOT AN AUTHORISED USER !   *

*                                                               *

*             Unauthorised access is prohibited                 *

--More--                           *                And may be punishable by law                   *

*                                                               *

*      This device is monitored for unauthorised access         *

*                                                               *

*****************************************************************

^C

!

line con 0

exec-timeout 5 0

password 7 030752180500

line aux 0

exec-timeout 30 0

password 7 070C285F4D06

line vty 0 4

exec-timeout 30 0

password 7 1511021F0725

logging synchronous

login

length 0

transport input telnet

!

scheduler allocate 20000 1000

ntp update-calendar

--More--                           ntp server 146.170.67.132 prefer

ntp server 146.170.125.133

end

welsp482-hydecheshi-2197721#

welsp482-hydecheshi-2197721#

welsp482-hydecheshi-2197721#

welsp482-hydecheshi-2197721#

welsp482-hydecheshi-2197721#exit

New Member

Is there any way to route an external number to a different inte

I forgot to mention we are using:  CUCM v7.1.3a

Hall of Fame Super Red

Is there any way to route an external number to a different inte

Hi Anthony,

You can see the required config examples in this good Tech note;

http://www.cisco.com/en/US/tech/tk652/tk653/technologies_tech_note09186a00801c43f6.shtml

If you are routing in a 1 to 1 pattern ie; 5800 to 2400, 5801 to 2401 etc. you can use

wildcards as in the example. if not you will need "specific" patterns

Cheers!

Rob

"Show a little faith, there's magic in the night" - Springsteen

VIP Super Bronze

Is there any way to route an external number to a different inte

Rob +5 point for the excellent document...

Anthony,

The link above explains in detail how you should configure this...

In your case you need to create a xlation pattern

58XX

called party xfor mask:24XX

so 5806 will be xlated to 2406 and 5809 will change to 2409 etc...The last 2 digits will remain the same.

But you need to ensure that the partition of your xlation pattern is in the CSS of your gateway. You also need to ensure the CSS of your xlation pattern (58XX) has access to the partion of your internal numbers

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
365
Views
15
Helpful
9
Replies