Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

ISDN BRI to SIP Configuration on CISCO 2800 Gateway

Hi,

I want to transfer all the incoming calls on the interface BRI0/0/0 to SIP server, i can make outgoing calls but incoming is not working. rest all interfaces are configured with CCM and are working fine.

Thanks in Advance

Building configuration...

Current configuration : 5007 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ProcessVG
!
boot-start-marker
boot system flash c2801-spservicesk9-mz.124-11.T.bin
boot-end-marker
!
card type e1 0 1
no logging buffered
no logging console
enable secret 5 $1$TI5I$5v0fY73QNvWma33jM0lCI1
!
no aaa new-model
clock timezone PCTime -8
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-participate wic 3
network-clock-select 1 E1 0/1/0
ip cef
!
!
!
!
ip domain name process
ip host CCMPROCESS 192.168.0.204
multilink bundle-name authenticated
!
isdn switch-type primary-net5
!
!
trunk group  ANLG
!
voice-card 0
dsp services dspfarm
!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

redirect ip2ip

signaling forward unconditional

sip

  bind media source-interface FastEthernet0/0

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

controller E1 0/1/0

framing NO-CRC4

pri-group timeslots 1-31 service mgcp

!

!

!

!

interface FastEthernet0/0

ip address 192.168.0.222 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.0.222

!

interface FastEthernet0/1

ip address 172.16.10.13 255.255.0.0

duplex auto

speed auto

!

interface BRI0/0/0

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice

isdn static-tei 0

!

interface BRI0/0/1

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice

isdn bind-l3 ccm-manager service mgcp

isdn static-tei 0

!

interface Serial0/1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface BRI0/3/0

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice

isdn bind-l3 ccm-manager service mgcp

isdn static-tei 0

!

interface BRI0/3/1

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice

isdn bind-l3 ccm-manager service mgcp

isdn static-tei 0

!

ip route 0.0.0.0 0.0.0.0 192.168.0.221

ip route 69.60.6.160 255.255.255.224 192.168.0.157

!

!

ip http server

no ip http secure-server

!

logging 192.168.0.253

!

!

!

control-plane

!

disable-eadi

!

!

voice-port 0/0/0

compand-type a-law

!

voice-port 0/0/1

compand-type a-law

!

voice-port 0/1/0:15

!

voice-port 0/2/0

trunk-group ANLG

connection plar 6000

caller-id enable

!

voice-port 0/2/1

connection plar 6000

caller-id enable

!

voice-port 0/2/2

connection plar 6100

caller-id enable

!

voice-port 0/2/3

connection plar 6100

caller-id enable

!

voice-port 0/3/0

compand-type a-law

!

voice-port 0/3/1

compand-type a-law

!

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 192.168.0.204

ccm-manager config

!

mgcp

mgcp call-agent 192.168.0.204 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface FastEthernet0/0

mgcp bind media source-interface FastEthernet0/0

!

mgcp profile default

!

sccp local FastEthernet0/0

sccp ccm 192.168.0.204 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register Xcodex

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec gsmfr

codec g729r8

codec g729br8

maximum sessions 4

associate application SCCP

!

!

dial-peer voice 5 pots

service mgcp

direct-inward-dial

port 0/1/0:15

!

dial-peer voice 10 voip

destination-pattern 56.

session target ipv4:192.168.0.204

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 1000 voip

numbering-type unknown

destination-pattern .T

session protocol sipv2

session target ipv4:192.168.0.100:5060

session transport udp

dtmf-relay rtp-nte

codec g711ulaw

!

dial-peer voice 11 pots

destination-pattern 9T

incoming called-number .T

port 0/0/0

!

dial-peer voice 12 pots

trunkgroup ANLG

destination-pattern .T

!

!

sip-ua

retry invite 3

retry response 3

retry bye 3

retry cancel 3

retry options 0

timers trying 1000

sip-server ipv4:192.168.0.100

!

!

call-manager-fallback

secondary-dialtone 9

max-conferences 8 gain -6

transfer-system full-consult

ip source-address 192.168.0.222 port 2000

max-ephones 30

max-dn 40

transfer-pattern ...

call-forward pattern ...

!

!

line con 0

password 7 083B45430B100B4342

login

line aux 0

password 7 10540014071E1C5F5C

login

line vty 0 4

password 7 10540014071E1C5F5C

login

!

scheduler allocate 20000 1000

end

1 REPLY
Hall of Fame Super Gold

ISDN BRI to SIP Configuration on CISCO 2800 Gateway

You can take "debug isdn q931" and "debug ccsip message" with "term mon" to see what's wrong.

2115
Views
0
Helpful
1
Replies
CreatePlease to create content