Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

ISDN Layer 2 is not coming up in back to back PRI setup using MGCP

Hello gurus,

I desperately need help in bringing up isdn layer 2. I have configured a PSTN side (using a 2811) with VWIC-2MFT1 and user side (using a 3800) with VWIC-1MFT1.

I have verfied that T1 cross over cable pinouts are correct.

PSTN router is acting as MGCP gateway by PSTN CCM. Branch router is also acting as MGCP gateway by separate CCM cluster.

My dilemma is that I'm unable to bring up layer 2 on both PSTN gateway as well as branch gateway. I have attached the config from PSTN router and branch router. Both the CCMs are showing that gateways are registered but isdn layer 2 is not coming up.

When I do debug isdn q921 on both pstn and branch routers I don't get any debug at all (even though I'm using console). I even tried debug isdn all but there was no output.

CCM ver on both PSTN and brnach clusters is 4.1(3)

Thanks in advance

1 ACCEPTED SOLUTION

Accepted Solutions

Re: ISDN Layer 2 is not coming up in back to back PRI setup usin

Troubleshooting layer 2 connectivity with MGCP:

-Make sure that 'show ccm' shows registered and 'show mgcp endpoints' shows the correct T1. Layer 2 will not come up if the gateway is not registered with CUCM. Check the first line of 'show ccm' that shows what the gateway is registering as against what you have in the CUCM gateway entry. Don't forget to add the domain name if there is one configured.

-Make sure one of the routers is configured as network side in CUCM

-Configure the same switch type in CUCM on both sides.

It sounds like one of the sides isn't registered.

hth,

nick

3 REPLIES
Silver

Re: ISDN Layer 2 is not coming up in back to back PRI setup usin

I don`t see CCM CONFIG. on your set up though this should not be the problem. Also is the PRI up from the telco ? If this is not then eth GW will not register unless you do a "loopback diag" on the controller this will register the GW to CCM when yo do not have an E1/T1 available- proves the Card and GW

Community Member

Re: ISDN Layer 2 is not coming up in back to back PRI setup usin

Thanks for the reply. CCM config (router side for mgcp) is in each of the attachements.

Actually there is no telco involve. I'm simulating a PSTN using this back to back setup. One end of cross over is connected with PSTN router on VWIC-2MFTT1 and other is connected with branch router's VWIC-1MFTT1.

Re: ISDN Layer 2 is not coming up in back to back PRI setup usin

Troubleshooting layer 2 connectivity with MGCP:

-Make sure that 'show ccm' shows registered and 'show mgcp endpoints' shows the correct T1. Layer 2 will not come up if the gateway is not registered with CUCM. Check the first line of 'show ccm' that shows what the gateway is registering as against what you have in the CUCM gateway entry. Don't forget to add the domain name if there is one configured.

-Make sure one of the routers is configured as network side in CUCM

-Configure the same switch type in CUCM on both sides.

It sounds like one of the sides isn't registered.

hth,

nick

334
Views
0
Helpful
3
Replies
CreatePlease to create content