Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

ISDN PRI - Plan: Unknown, Type: Unknown showing up in debug

CUCM 7.1(3) with 2811 ISR 12.4(13r)T11

I opened a ticket with Verizon recently because all calls originating from CUCM were showing as having a caller ID of the main number instead of their DIDs. When testing I found out that this was not always the case. Outbound calls being triggered from MobileConnect were showing up with the correct caller ID. From the 2811 isdn q931 debug I confirmed that I'm sending 10 digits but there was a difference in the ISDN "Plan" and "Type" information:

Call triggered by MobileConnect (correct caller ID '8575559971' is displayed on called device)

        Calling Party Number i = 0x2183, '8575559971'

                Plan:ISDN, Type:National

Call originated by user at ext 3838 (incorrect caller ID '4105553000' is displayed on called device)

        Calling Party Number i = 0x0081, '4105553838'

                Plan:Unknown, Type:Unknown

Why would the calls be set up differently? Where does this get configured and would it affect Caller ID?

2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

Re: ISDN PRI - Plan: Unknown, Type: Unknown showing up in debug

Hi,

Is your gateway H.323 or MGCP? If this is H.323 you can control Plan and Type on the Gateway for all calls.

If  this is MGCP, you can check the plan and type for Calling Party on Gateway page.

HTH

Silver

Re: ISDN PRI - Plan: Unknown, Type: Unknown showing up in debug

In some cases if a carrier does not see a type and plan of their liking they will automaitcally mask the outgoing calling number to the billing number or pilot number of the carrier hunt group.  It sounds that is what you are up against.  If you will always be sending 10 digits NANP for the CLID out you might try setting the plan and type to match the successful situation at the route list, or the gateway (if there is only one gateway and you are running a recent CCM version) to Verizon.

Also, once this change is in place you will need to reset the route list and/or the gateway, whether it is H323 or MGCP.

HTH,

Art Sandborgh

6 REPLIES
Community Member

Re: ISDN PRI - Plan: Unknown, Type: Unknown showing up in debug

Not sure what version you're running but you can set the plan and type in both the route pattern and gateway in 7.1.

Cisco Employee

Re: ISDN PRI - Plan: Unknown, Type: Unknown showing up in debug

Hi,

Is your gateway H.323 or MGCP? If this is H.323 you can control Plan and Type on the Gateway for all calls.

If  this is MGCP, you can check the plan and type for Calling Party on Gateway page.

HTH

Silver

Re: ISDN PRI - Plan: Unknown, Type: Unknown showing up in debug

In some cases if a carrier does not see a type and plan of their liking they will automaitcally mask the outgoing calling number to the billing number or pilot number of the carrier hunt group.  It sounds that is what you are up against.  If you will always be sending 10 digits NANP for the CLID out you might try setting the plan and type to match the successful situation at the route list, or the gateway (if there is only one gateway and you are running a recent CCM version) to Verizon.

Also, once this change is in place you will need to reset the route list and/or the gateway, whether it is H323 or MGCP.

HTH,

Art Sandborgh

Community Member

Re: ISDN PRI - Plan: Unknown, Type: Unknown showing up in debug

Thanks for your responses. Changing the type/plan did the trick. I also had another issue where calling party info was being masked when the number was outside of our DID range. I'm working with VZ on that one.

Community Member

Re: ISDN PRI - Plan: Unknown, Type: Unknown showing up in debug

Hello,

I'm facing a same issue as described in this post, receiving Plan:Unknown, Type:Unknown. Can you please post the changes that solved the issue?

I tried to set the Number Type and Numbering Plan to National, International, Subscriber etc.. but no luck.

I'm using H323 Gateway with CUCM 7.1.5.

Thank you,

Silver

Re: ISDN PRI - Plan: Unknown, Type: Unknown showing up in debug

For an H323 GW I normally use the isdn map command on the serial interface.  If you have tried all the combinations on that I would strongly encourage you to speak with the CO and find out what they are expecting.  I have seen situations where the CO has had a request from the customer (many times in the distant past) to mask ALL CLID no matter what, and in that case you will never get one out.   It sounds like you really need to speak to them at this point.

HTH,

Art

7795
Views
0
Helpful
6
Replies
CreatePlease to create content