Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ISDN Se0/0/0:15 Q931: Ux_DLRelInd: DL_REL_IND received from L2

Guys,

I am having this issue and i just need to verify, or justify to the telco that my configs are correct and the issue is maybe a loop on their switching

i've tried changing isdn switch-type and related configs to primary-net5 as this is E1, but no changes.

the debugs just show bad frames, i have been following this post as well. Any assistance i can get i will appreciate thanks

https://supportforums.cisco.com/thread/2038702

Config

--------------------------------------

network-clock-participate wic 0

network-clock-select 1 E1 0/0/0

!

controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-31

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-qsig

isdn incoming-voice voice

isdn sending-complete

no cdp enable

!

-----------------------------------------

Router#sh controllers e1

E1 0/0/0 is up.

  Applique type is Channelized E1 - balanced

  Description: DIGICEL

  No alarms detected.

  alarm-trigger is not set

  Version info Firmware: 20100222, FPGA: 13, spm_count = 0

  Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.

  Data in current interval (883 seconds elapsed):

     0 Line Code Violations, 0 Path Code Violations

     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

  Total Data (last 60 15 minute intervals):

     26 Line Code Violations, 1 Path Code Violations,

     0 Slip Secs, 0 Fr Loss Secs, 22 Line Err Secs, 0 Degraded Mins,

     22 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Router#sh isdn stat

Global ISDN Switchtype = primary-qsig

ISDN Serial0/0/0:15 interface

        dsl 0, interface ISDN Switchtype = primary-qsig

         **** Slave side configuration ****

    Layer 1 Status:

        ACTIVE

    Layer 2 Status:

        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

        TEI = 255, Ces = 255, SAPI = 0, State = TEI_ASSIGNED

    Layer 3 Status:

        0 Active Layer 3 Call(s)

    Active dsl 0 CCBs = 0

    The Free Channel Mask:  0xFFFF7FFF

    Number of L2 Discards = 0, L2 Session ID = 239

    Total Allocated ISDN CCBs = 0

debug isdn q921 is              ON.

*Dec 24 15:36:13.260: ISDN Se0/0/0:15 Q921: L2_EstablishDataLink: sending SABME

*Dec 24 15:36:13.260: ISDN Se0/0/0:15 Q921: User TX -> SABMEp sapi=0 tei=127

*Dec 24 15:36:13.260: ISDN Se0/0/0:15 Q921: User RX <- BAD FRAME(0x00FF7F)

*Dec 24 15:36:14.260: ISDN Se0/0/0:15 Q921: User TX -> SABMEp sapi=0 tei=127

Router#

*Dec 24 15:36:14.260: ISDN Se0/0/0:15 Q921: User RX <- BAD FRAME(0x00FF7F)

*Dec 24 15:36:15.260: ISDN Se0/0/0:15 Q921: User TX -> SABMEp sapi=0 tei=127

Router#

*Dec 24 15:36:15.260: ISDN Se0/0/0:15 Q921: User RX <- BAD FRAME(0x00FF7F)

*Dec 24 15:36:16.260: ISDN Se0/0/0:15 Q921: User TX -> SABMEp sapi=0 tei=127

Router#

*Dec 24 15:36:16.260: ISDN Se0/0/0:15 Q921: User RX <- BAD FRAME(0x00FF7F)

---------------------------------------------

debug isdn q931 is              ON.

Router##BAD FRAME()

Router#BAD FRAME()

Router#BAD FRAME()

Router#BAD FRAME()

*Dec 24 15:37:29.259: ISDN Se0/0/0:15 Q931: Ux_DLRelInd: DL_REL_IND received from L2

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: ISDN Se0/0/0:15 Q931: Ux_DLRelInd: DL_REL_IND received from

Ask telco to revise their config, because it seems like they're set user-side.

5 REPLIES
Green

Re: ISDN Se0/0/0:15 Q931: Ux_DLRelInd: DL_REL_IND received from

Hi Arnela,

I think you have 2 issues.

Can you try chanmging your config a little

Conf t

!

!

!

interface Serial0/0/0:15

shut

isdn switch-type primary-net5

no shut

!

!

controller E1 0/0/0

shut

framing CRC4

no shut

!

HTH

Festive Greetings to You & Yours

Alex

Regards, Alex. Please rate useful posts.
New Member

ISDN Se0/0/0:15 Q931: Ux_DLRelInd: DL_REL_IND received from L2

Hi Alex,

thanks for your quick response, think maybe i confused everyone...

The service provider is using isdn switch-type primary-qsig its why i have qsig in the configs.

what i was trying to say is that i also reconfigured with the configs you posted as well but it didnt work either.

however if you think of anything else i would appreciate..thanks a mil..

thanks for your greeting,

Hope you also have a wonderful holiday Season! All best wishes to you and yours

Hall of Fame Super Gold

Re: ISDN Se0/0/0:15 Q931: Ux_DLRelInd: DL_REL_IND received from

Ask telco to revise their config, because it seems like they're set user-side.

New Member

ISDN Se0/0/0:15 Q931: Ux_DLRelInd: DL_REL_IND received from L2

Hi Paolo,

I was thinking the same, but they keep telling me their configs are good.. I will ask again.

thanks alot!

will let you know

New Member

ISDN Se0/0/0:15 Q931: Ux_DLRelInd: DL_REL_IND received from L2

thanks everyone, the problem was definitely on the service provider's end once they resolved it came up fine

3808
Views
0
Helpful
5
Replies