Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ISP SIP Trunk Issues

Hello, we are installing a new SIP trunk from our ISP to replace our PRI.  With the setup the way we have it we are getting ring no answer on inbound calls and fast busy on outbound calls.  The ISP has a Cisco 2900 router that is NATing over to our Cisco 2851 with advipservices firmware.  Behind our Cisco 2851 we have CUCM 8.0.  What could be causing our issues?  Attached is the configuration in the voice gateway.  The ISP Router has the public IP and is NATing the traffic across to 130.0.100.1.  Then there is an outbound dial-peer going to the call manager.  The phone will ring, but the calling party just hears endless ringing even if the called party picks up the phone.  I've only been testing one number since we don't have all of the numbers ported over, i have it translated with a num-exp value.  Also, it works with a phone plugged directly into an FXS port.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Silver

ISP SIP Trunk Issues

I also see the calls failing with a cause value of 21 which means that the Toll Fraud feature is blocking these calls. Here's how you configure/disable Toll Fraud on CUBE,

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a0080b3e123.shtml

---

Posted by WebUser Asad Raza from Cisco Support Community App

Silver

Re: ISP SIP Trunk Issues

It's just sending UDP invites out over and never gets a response.  Are you sure you have the IP address right?  Also, do they expect TCP or UDP?

21 REPLIES
Silver

ISP SIP Trunk Issues

Grab "debug ccsip messages" for an inbound and outbound call and attach.

New Member

Re: ISP SIP Trunk Issues

Thanks for your reply.  Attached are links to two files, one is a debug ccsip all and the other is a debug ccsip messages.

For outbound calls, I'm not able to run a debug since it is a live environment.  I will try and schedule some outbound calls tomorrow to grab those debugs.

Thanks again for your help.

Cisco Employee

Re: ISP SIP Trunk Issues

Joseph,

I checked your configuration attached above.. can you try to remove the below commnads under SIP section and try to make a test call??

header-passing

early-offer forced

sip-profiles 1

If it still fails, can u please share the debugs

debug voice dialpeer inout

debug ccsip all

New Member

Re: ISP SIP Trunk Issues

I removed the options you suggested and I am still having the same issue with inbound calls.  Attached is the log file for an inbound call.

Silver

ISP SIP Trunk Issues

This looks like an ip routing / networking issue where the CUBE can reach the CUCM but the CUCM's return traffic is not reaching the CUBE (this is why the CUBE keeps sending the invites to the CUCM even when the phone is answered, the CUCM's 200 OK is not received by the CUBE). Also explains why outbound calls from CUCM fail with a fast busy.

---

Posted by WebUser Asad Raza from Cisco Support Community App

New Member

Re: ISP SIP Trunk Issues

The call manager and cube are in the same subnet.  CUBE = 130.0.100.1, CUCM = 130.0.100.146 so I'm not sure how there could be a routing or networking issue between the two devices.  Could this have anything to do with the SIP Trunk between the CUBE and CUCM not being setup properly?

Silver

ISP SIP Trunk Issues

I also see the calls failing with a cause value of 21 which means that the Toll Fraud feature is blocking these calls. Here's how you configure/disable Toll Fraud on CUBE,

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a0080b3e123.shtml

---

Posted by WebUser Asad Raza from Cisco Support Community App

New Member

Re: ISP SIP Trunk Issues

I will read the documentation on this and try it out.  Thanks for your reply.

New Member

Re: ISP SIP Trunk Issues

I read the documentation and setup the trusted IP list under voice services voip and it is now up and working at least on inbound calls.  I have yet to have a chance to test outbound calls but I will do that this afternoon and let you guys know if it works.  Current config is attached for future reference.  Thanks again for all of the help.

New Member

Re: ISP SIP Trunk Issues

I'm still having issues with Outbound calls.  I've set this up in a CME enviroment so as not to interfere with there normal call processing.  Attached is a log of what I'm seeing with outbound calls.  Any advice is appreciated.

Thanks

Silver

Re: ISP SIP Trunk Issues

Did you have debug ccsip messages turned on for that call?  I don't see any SIP messaging.

New Member

Re: ISP SIP Trunk Issues

Sorry I did not have ccsip messages debugging on that one.  Attached is a new debug with that enabled.

Thanks for your response.

Silver

Re: ISP SIP Trunk Issues

Joseph,

This shows your SIP Trunk is trying to register and the provider is sending back a "405 Method Not Allowed".  Are you sure your carrier needs you to register your SIP Trunk?

Brian

New Member

Re: ISP SIP Trunk Issues

You are correct, I don't believe they do require registration, I'm removing those options and retrying a test call.  I will post the results momentarily.

New Member

Re: ISP SIP Trunk Issues

Attached are the results of the debug with the registration removed from sip-ua.

Thanks for your help.

Silver

Re: ISP SIP Trunk Issues

It's just sending UDP invites out over and never gets a response.  Are you sure you have the IP address right?  Also, do they expect TCP or UDP?

New Member

Re: ISP SIP Trunk Issues

I believe I do have the IP addresses correct for their equipment.  I'm not onsite, I'm checking now to make sure everything is powered up since this isn't running live.

Thanks

New Member

Re: ISP SIP Trunk Issues

Attached is the latest debug I ran.  The cabling to the Telco Router had been unplugged for some reason so that's why it wasn't communicating before on my previous debug.  I'm still getting a fast busy on outbound calls but it waits a few seconds before it gives the fast busy

VIP Super Bronze

ISP SIP Trunk Issues

The debug is incomplete. We only see the outbound INVITE...Pls post the full debugs

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Re: ISP SIP Trunk Issues

I'm testing on the live network now so please disregard the prevoius post.  I am getting a 503 service unavailable.  A fastbusy on outbound calls and I see no SIP traffic between my CUBE and the telco's equipment.  Below is the debug in it's entirety for the call

Sep  4 22:22:20.198: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

INVITE sip:92566138703@130.0.100.1:5060 SIP/2.0

Via: SIP/2.0/TCP 130.0.100.146:5060;branch=z9hG4bK4051db5294

From: <2565476386>;tag=1f4823e6-e05d-4f53-ab96-a322c4ecf282-27

142664

To: <92566138703>

Date: Wed, 04 Sep 2013 22:22:20 GMT

Call-ID: 7569fb80-2271b29c-2b-92640082@130.0.100.146

Supported: 100rel,timer,resource-priority,replaces

Min-SE:  1800

User-Agent: Cisco-CUCM8.0

Allow: INVITE, OPTIONS, INFO, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE,

NOTIFY

CSeq: 101 INVITE

Contact: <2565476386>

Expires: 180

Allow-Events: presence, kpml

Supported: X-cisco-srtp-fallback

Supported: Geolocation

Call-Info: <130.0.100.146:5060>;method="NOTIFY;Event=telephone-event;Duratio

n=500"

Cisco-Guid: 1969879936-0000065536-0000000043-2456027266

Session-Expires:  1800

P-Asserted-Identity: <2565476386>

Remote-Party-ID: <2565476386>;party=calling;screen=yes;privacy

=off

Max-Forwards: 70

Content-Length: 0

Sep  4 22:22:20.214: //39335/7569FB800000/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 100 Trying

Via: SIP/2.0/TCP 130.0.100.146:5060;branch=z9hG4bK4051db5294

From: <2565476386>;tag=1f4823e6-e05d-4f53-ab96-a322c4ecf282-27

142664

To: <92566138703>

Date: Wed, 04 Sep 2013 22:22:20 GMT

Call-ID: 7569fb80-2271b29c-2b-92640082@130.0.100.146

CSeq: 101 INVITE

Allow-Events: telephone-event

Server: Cisco-SIPGateway/IOS-12.x

Content-Length: 0

Sep  4 22:22:20.226: //39335/7569FB800000/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 503 Service Unavailable

Via: SIP/2.0/TCP 130.0.100.146:5060;branch=z9hG4bK4051db5294

From: <2565476386>;tag=1f4823e6-e05d-4f53-ab96-a322c4ecf282-27

142664

To: <92566138703>;tag=32D99D64-5B5

Date: Wed, 04 Sep 2013 22:22:20 GMT

Call-ID: 7569fb80-2271b29c-2b-92640082@130.0.100.146

CSeq: 101 INVITE

Allow-Events: telephone-event

Server: Cisco-SIPGateway/IOS-12.x

Reason: Q.850;cause=38

Content-Length: 0

Sep  4 22:22:20.226: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

McCartney_R1#ACK sip:92566138703@130.0.100.1:5060 SIP/2.0

Via: SIP/2.0/TCP 130.0.100.146:5060;branch=z9hG4bK4051db5294

From: <2565476386>;tag=1f4823e6-e05d-4f53-ab96-a322c4ecf282-27

142664

To: <92566138703>;tag=32D99D64-5B5

Date: Wed, 04 Sep 2013 22:22:20 GMT

Call-ID: 7569fb80-2271b29c-2b-92640082@130.0.100.146

Max-Forwards: 70

CSeq: 101 ACK

Allow-Events: presence, kpml

Content-Length: 0

New Member

Re: ISP SIP Trunk Issues

After looking at this closer, the ISP had given me an incorrect IP  address.  I corrected this and made a few dial-peer changes and calls  are now completing outbound.

Thanks all for your help with these issues.

871
Views
0
Helpful
21
Replies