Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ISR 2921 Voice Gateway

Hello guys!

     Im currently implementing a CUCM 8.5 and Unity Connection 8.5 solution on a Healthcare Clinic. It will consist of a main site with two remote regions. On the main site the devices are the CUCM8.5 on an MCS, the Unity on an MCS, a Catalyst 4500 as the core switch, two Catalyst 3560X for access (IP Phones will be connecting to) and a CISCO2921-V/K9 as the gateway into the PSTN which will provide the SIP trunk. Each of the two remote regions will consist of a CISCO2901/K9 with SL-29-UC-K9 license and a Catalyst 3560X for the IP Phone connections.

The Telco will be providing a SIP trunk and I will configure the three routers as H323 gateways for the integration with the CUCM. My question is the following: How to configure the three remote routers in this scenario? Any configuration guide to H323 gateways integration with CUCM8.5? Configuration examples, guidelines and scripts will be of great help. 

Also, in the switches, since the bandwith is not a problem, do you recommend configuring QoS or no Qos for the switchports?

Im new to the Uniffied Communication world. Thanks a lot guys!

  • IP Telephony
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

ISR 2921 Voice Gateway

Here is a link to the h.323 configuration guide.  There is a lot of good info here on h.323. 

http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/cisco_ios_h323_configuration_guide/old_archives_h323/323confg.html

Here are the highligts of the last h.323/sip trunk implmentation i did. 

voice service voip

dtmf-interworking rtp-nte

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

h323

sip

  early-offer forced

  midcall-signaling passthru

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g711ulaw

!

voice class h323 1

  h225 timeout tcp establish 3

  h225 timeout setup 3

!

!

!

(your translation rules will vary depending your needs)

voice translation-rule 9

rule 2 /\(^.*\)/ /91\1/

!

voice translation-rule 11

rule 1 /^[1-7]...$/ /5555555555/

!

voice translation-rule 91

rule 1 /^91\(..........\)/ /\1/

rule 2 /^9\(..........\)/ /\1/

rule 3 /^9011\(.*\)/ /011\1/

rule 4 /^9911/ /911/

!

!

voice translation-profile DIGITADD-9

translate calling 9

!

voice translation-profile DIGITSTRIP-9

translate called 91

translate redirect-called 91

(bind h.323 to an interface)

interface GigabitEthernet0/0.20

description SIP to CM H323 interface

encapsulation dot1Q 20

ip address 172.20.1.3 255.255.255.0

no ip redirects

no ip proxy-arp

ip nat inside

ip virtual-reassembly

h323-gateway voip interface

h323-gateway voip bind srcaddr 172.20.1.3

(sccp stuff for DSP resources if you are using them)

sccp local GigabitEthernet0/0.20

sccp ccm IP OF CUCM identifier 1 priority 1 version 7.0

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 12 register MTP_DC

associate profile 10 register XCODE_DC

associate profile 11 register CONF_DC

!

dspfarm profile 10 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

maximum sessions 4

associate application SCCP

!

dspfarm profile 11 conference

description Conference Bridge

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 4

associate application SCCP

!

dspfarm profile 12 mtp

codec g711ulaw

maximum sessions software 100

associate application SCCP

!

dial-peer voice 10 voip

description OUTBOUND Voice SIP calls to VzB

translation-profile outgoing DIGITSTRIP-9

destination-pattern 9T

session protocol sipv2

session target sip-server

voice-class codec 1

voice-class sip early-offer forced

dtmf-relay rtp-nte digit-drop

no vad

!

dial-peer voice 20 voip

description INBOUND Voice SIP calls from VzB

session protocol sipv2

session target sip-server

incoming called-number .

voice-class codec 1

dtmf-relay rtp-nte digit-drop

no vad

!

dial-peer voice 21 voip

description to CM from Gateway

translation-profile outgoing DIGITADD-9

destination-pattern

session protocol sipv2

session target ipv4:ip address of cm

incoming called-number .

voice-class codec 1

dtmf-relay rtp-nte digit-drop

no vad

!

dial-peer voice 11 voip

description voip dial peer to Verizon

translation-profile outgoing DIGITSTRIP-9

destination-pattern 9911

session protocol sipv2

session target sip-server

voice-class codec 1

dtmf-relay rtp-nte digit-drop

no vad

!

dial-peer voice 911 voip

description voip dial peer to Verizon

destination-pattern 911

session protocol sipv2

session target sip-server

voice-class codec 1

dtmf-relay rtp-nte digit-drop

no vad

!

dial-peer voice 111 voip

description voip dial peer to Verizon international

translation-profile outgoing DIGITSTRIP-9

destination-pattern 9011T

session protocol sipv2

session target sip-server

voice-class codec 1

dtmf-relay rtp-nte digit-drop

no vad

!

!

(This is the SIP information you get from your provider regarding the registar and server they provide you.)

sip-ua

retry invite 2

retry bye 2

retry cancel 2

retry options 1

registrar ipv4:172.xxx.xxx.164 expires 3600

sip-server ipv4:172.xxx.xxx.49:5091

g729-annexb override

I would always do qos.  You could probley get away with using Cisco's auto qos feature unless you have other traffic to account for. 

on the switch ports:

auto qos voip  cisco-phone

On the trunk ports:

auto qos voip trust

Here is some info on auto qos:

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/auto_qos.html

I hope this helps. 

James

2 REPLIES
New Member

ISR 2921 Voice Gateway

Here is a link to the h.323 configuration guide.  There is a lot of good info here on h.323. 

http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/cisco_ios_h323_configuration_guide/old_archives_h323/323confg.html

Here are the highligts of the last h.323/sip trunk implmentation i did. 

voice service voip

dtmf-interworking rtp-nte

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

h323

sip

  early-offer forced

  midcall-signaling passthru

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g711ulaw

!

voice class h323 1

  h225 timeout tcp establish 3

  h225 timeout setup 3

!

!

!

(your translation rules will vary depending your needs)

voice translation-rule 9

rule 2 /\(^.*\)/ /91\1/

!

voice translation-rule 11

rule 1 /^[1-7]...$/ /5555555555/

!

voice translation-rule 91

rule 1 /^91\(..........\)/ /\1/

rule 2 /^9\(..........\)/ /\1/

rule 3 /^9011\(.*\)/ /011\1/

rule 4 /^9911/ /911/

!

!

voice translation-profile DIGITADD-9

translate calling 9

!

voice translation-profile DIGITSTRIP-9

translate called 91

translate redirect-called 91

(bind h.323 to an interface)

interface GigabitEthernet0/0.20

description SIP to CM H323 interface

encapsulation dot1Q 20

ip address 172.20.1.3 255.255.255.0

no ip redirects

no ip proxy-arp

ip nat inside

ip virtual-reassembly

h323-gateway voip interface

h323-gateway voip bind srcaddr 172.20.1.3

(sccp stuff for DSP resources if you are using them)

sccp local GigabitEthernet0/0.20

sccp ccm IP OF CUCM identifier 1 priority 1 version 7.0

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 12 register MTP_DC

associate profile 10 register XCODE_DC

associate profile 11 register CONF_DC

!

dspfarm profile 10 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

maximum sessions 4

associate application SCCP

!

dspfarm profile 11 conference

description Conference Bridge

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 4

associate application SCCP

!

dspfarm profile 12 mtp

codec g711ulaw

maximum sessions software 100

associate application SCCP

!

dial-peer voice 10 voip

description OUTBOUND Voice SIP calls to VzB

translation-profile outgoing DIGITSTRIP-9

destination-pattern 9T

session protocol sipv2

session target sip-server

voice-class codec 1

voice-class sip early-offer forced

dtmf-relay rtp-nte digit-drop

no vad

!

dial-peer voice 20 voip

description INBOUND Voice SIP calls from VzB

session protocol sipv2

session target sip-server

incoming called-number .

voice-class codec 1

dtmf-relay rtp-nte digit-drop

no vad

!

dial-peer voice 21 voip

description to CM from Gateway

translation-profile outgoing DIGITADD-9

destination-pattern

session protocol sipv2

session target ipv4:ip address of cm

incoming called-number .

voice-class codec 1

dtmf-relay rtp-nte digit-drop

no vad

!

dial-peer voice 11 voip

description voip dial peer to Verizon

translation-profile outgoing DIGITSTRIP-9

destination-pattern 9911

session protocol sipv2

session target sip-server

voice-class codec 1

dtmf-relay rtp-nte digit-drop

no vad

!

dial-peer voice 911 voip

description voip dial peer to Verizon

destination-pattern 911

session protocol sipv2

session target sip-server

voice-class codec 1

dtmf-relay rtp-nte digit-drop

no vad

!

dial-peer voice 111 voip

description voip dial peer to Verizon international

translation-profile outgoing DIGITSTRIP-9

destination-pattern 9011T

session protocol sipv2

session target sip-server

voice-class codec 1

dtmf-relay rtp-nte digit-drop

no vad

!

!

(This is the SIP information you get from your provider regarding the registar and server they provide you.)

sip-ua

retry invite 2

retry bye 2

retry cancel 2

retry options 1

registrar ipv4:172.xxx.xxx.164 expires 3600

sip-server ipv4:172.xxx.xxx.49:5091

g729-annexb override

I would always do qos.  You could probley get away with using Cisco's auto qos feature unless you have other traffic to account for. 

on the switch ports:

auto qos voip  cisco-phone

On the trunk ports:

auto qos voip trust

Here is some info on auto qos:

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/auto_qos.html

I hope this helps. 

James

New Member

ISR 2921 Voice Gateway

Excellent James. Thanks a lot! Great material. 

2761
Views
0
Helpful
2
Replies
This widget could not be displayed.