Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Issue updateing firm ware on a 7942 phone

Hello All,

I am working for a company that is purchasing refurbished 7942 phones for their system  Several of the phones have firmware that is two old and cannot be upgraded to the current ccm version.  I am not allowed (company policy) to install an older version on CCM so I am using tftp on a cisco 881 router to do the upgade to the jumper version that will allow me to up grade on ccm.

Current config on router

Current configuration : 2048 bytes

!

! Last configuration change at 16:18:38 UTC Thu Feb 6 2014

! NVRAM config last updated at 16:18:40 UTC Thu Feb 6 2014

! NVRAM config last updated at 16:18:40 UTC Thu Feb 6 2014

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

enable password cisco

!

no aaa new-model

!

memory-size iomem 10

crypto pki token default removal timeout 0

!        

!

ip source-route

!

!

!

!

ip dhcp pool vlan 2

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

option 150 ip 192.168.1.1

!

!

ip cef

no ipv6 cef

!

!

multilink bundle-name authenticated

license udi pid CISCO881-K9 sn FTX153381AE

!

!

!

!

!

!        

!

!

!

!

!

!

!

interface FastEthernet0

switchport access vlan 2

no ip address

!

interface FastEthernet1

switchport access vlan 2

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

no ip address

shutdown

duplex auto

speed auto

!

interface Vlan1

no ip address

!

interface Vlan2

ip address 192.168.1.1 255.255.255.0

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

!

!

!

!

tftp-server cnu41.8-4-0-79.sbn

tftp-server cvm41sccp.8-4-0-79.sbn

tftp-server dsp41.8-4-0-79.sbn

tftp-server jar41sccp.8-4-0-79.sbn

tftp-server SCCP41.8-4-1S.loads

tftp-server term41.default.loads

tftp-server apps41.8-4-0-79.sbn

tftp-server cmterm_7936.3-3-20-0.bin

tftp-server XMLDefault.cnf.xml

tftp-server XMLDefault_polycom.cnf.xml

tftp-server SEP0004f2e246cd.cnf.xml

tftp-server SEP0004f2e246cd_polycom.cnf.xml

tftp-server flash:apps42.8-5-3ES4.sbn

tftp-server flash:cnu42.8-5-3ES4.sbn

tftp-server flash:cvm42sccp.8-5-3ES4.sbn

tftp-server flash:dsp42.8-5-3ES4.sbn

tftp-server flash:jar42sccp.8-5-3ES4.sbn

tftp-server flash:SCCP42.8-5-3SR1S.loads

tftp-server flash:term42.default.loads

tftp-server flash:term62.default.loads

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

password cisco

login   

transport input all

!

end

Cisco IOS version -> Cisco IOS Software, C880 Software (C880DATA-UNIVERSALK9-M), Version 15.1(4)M4, RELEASE SOFTWARE (fc1)

If I hook up the phone to the router and have not done a factory reset I get the following log:

Feb  6 15:15:17.959: TFTP: Looking for CTLSEP0023EBC81FB8.tlv
Feb  6 15:15:18.027: TFTP: Looking for SEP0023EBC81FB8.cnf.xml
Feb  6 15:15:18.071: TFTP: Looking for XMLDefault.cnf.xml
Feb  6 15:15:18.071: TFTP: Opened flash:XMLDefault.cnf.xml, fd 0, size 3814 for process 269
Feb  6 15:15:18.083: TFTP: Finished flash:XMLDefault.cnf.xml, time 00:00:00 for process 269
Feb  6 15:15:24.547: TFTP: Looking for cmterm_7936.3-3-20-0.loads
Feb  6 15:15:39.023: TFTP: Looking for CTLSEP0023EBC81FB8.tlv
Feb  6 15:15:39.079: TFTP: Looking for SEP0023EBC81FB8.cnf.xml
Feb  6 15:15:39.131: TFTP: Looking for XMLDefault.cnf.xml
Feb  6 15:15:39.131: TFTP: Opened flash:XMLDefault.cnf.xml, fd 0, size 3814 for process 269
Feb  6 15:15:39.143: TFTP: Finished flash:XMLDefault.cnf.xml, time 00:00:00 for process 269
Feb  6 15:15:40.455: TFTP: Looking for English_United_States/mk-sccp.jar
Feb  6 15:15:40.551: TFTP: Looking for United_States/g3-tones.xml

The phone hangs at the last line then reboots to start the process again.   I am also wondering why it is looking for 

cmterm_7936.3-3-20-0.loads instead of the 7942 loads.

If I do a factory reset prior to the upgrade attempt I get the following event log.  (phone is in the upgrade screen during this)

Feb  6 16:59:53.559: %LINK-3-UPDOWN: Interface FastEthernet0, changed state to up

Feb  6 16:59:54.559: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0, changed state to up

Feb  6 17:00:22.579: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state to up

Feb  6 17:00:31.931: TFTP: Looking for term42.default.loads

Feb  6 17:00:31.935: TFTP: Opened flash:term42.default.loads, fd 0, size 662 for process 269

Feb  6 17:00:31.935: TFTP: Finished flash:term42.default.loads, time 00:00:00 for process 269

Feb  6 17:00:33.259: TFTP: Looking for term42.default.loads

Feb  6 17:00:33.259: TFTP: Opened flash:term42.default.loads, fd 0, size 662 for process 269

Feb  6 17:00:33.263: TFTP: Finished flash:term42.default.loads, time 00:00:00 for process 269 Feb  6 16:59:53.559: %LINK-3-UPDOWN: Interface FastEthernet0, changed state to up

The phone then reboots hangs for several minutes than repeats with the same event logs.  . 

Any help that can be offered would be greatly appreciated. 

Thank you

John

5 REPLIES

Issue updateing firm ware on a 7942 phone

Remove the following:

tftp-server flash:apps42.8-5-3ES4.sbn

tftp-server flash:cnu42.8-5-3ES4.sbn

tftp-server flash:cvm42sccp.8-5-3ES4.sbn

tftp-server flash:dsp42.8-5-3ES4.sbn

tftp-server flash:jar42sccp.8-5-3ES4.sbn

tftp-server flash:SCCP42.8-5-3SR1S.loads

tftp-server flash:term42.default.loads

tftp-server flash:term62.default.loads

Paste the following:

tftp-server flash:apps42.8-5-3ES4.sbn alias apps42.8-5-3ES4.sbn

tftp-server flash:cnu42.8-5-3ES4.sbn alias cnu42.8-5-3ES4.sbn

tftp-server flash:cvm42sccp.8-5-3ES4.sbn alias cvm42sccp.8-5-3ES4.sbn

tftp-server flash:dsp42.8-5-3ES4.sbn alias dsp42.8-5-3ES4.sbn

tftp-server flash:jar42sccp.8-5-3ES4.sbn alias jar42sccp.8-5-3ES4.sbn

tftp-server flash:SCCP42.8-5-3SR1S.loads alias flash:SCCP42.8-5-3SR1S.loads

tftp-server flash:term42.default.loads alias term42.default.loads

tftp-server flash:term62.default.loads alias term62.default.loads

HTH

Regards,

Yosh

HTH Regards, Yosh
Hall of Fame Super Red

Issue updateing firm ware on a 7942 phone

Hi John,

Just one small note to add to the good tips from my friend Yosh (+5)

It's quite possible that if the 7942's are running an old firmware that it

may be too old of a load to move directly to 8.5(3) as well. I would try 8-3-3

or 8-4-x as an interim step

Firmware Upgrade Issues for SCCP

Note  For all SCCP firmware upgrades from firmware release versions earlier  than 8.3(3) to version 8.5(3) or greater, you must first upgrade your  firmware to version 8.5(2). Once you have upgraded to version 8.5(2),  you can upgrade your IP Phone to version 8.5(3) or later.

http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/firmware/8_5_3/english/release/notes/7900_853.html#wp57602

Cheers!

Rob

"Seek it out and ye shall find  " 

- OneRepublic

Issue updateing firm ware on a 7942 phone

That's good stuff. +5 Rob

Regards,

Yosh

HTH Regards, Yosh
New Member

Re: Issue updateing firm ware on a 7942 phone

I have tried what you have suggested and got the following results.

Phone without factory reset.   firmware - 8-3-2-27  no apparent change

Feb  7 16:32:37.425: %LINK-3-UPDOWN: Interface FastEthernet0, changed state to up

Feb  7 16:32:38.425: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0, changed state to up

Feb  7 16:33:06.445: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state to up

Feb  7 16:33:10.285: TFTP: Looking for CTLSEP081FF3621B99.tlv

Feb  7 16:33:10.345: TFTP: Looking for SEP081FF3621B99.cnf.xml

Feb  7 16:33:10.393: TFTP: Looking for XMLDefault.cnf.xml

Feb  7 16:33:10.397: TFTP: Opened flash:XMLDefault.cnf.xml, fd 0, size 3814 for process 169

Feb  7 16:33:10.405: TFTP: Finished flash:XMLDefault.cnf.xml, time 00:00:00 for process 169

Feb  7 16:33:17.317: TFTP: Looking for cmterm_7936.3-3-20-0.loads

Feb  7 16:33:32.549: TFTP: Looking for CTLSEP081FF3621B99.tlv

Feb  7 16:33:32.649: TFTP: Looking for SEP081FF3621B99.cnf.xml

Feb  7 16:33:32.697: TFTP: Looking for XMLDefault.cnf.xml

Feb  7 16:33:32.697: TFTP: Opened flash:XMLDefault.cnf.xml, fd 0, size 3814 for process 169

Feb  7 16:33:32.709: TFTP: Finished flash:XMLDefault.cnf.xml, time 00:00:00 for process 169

Feb  7 16:33:34.361: TFTP: Looking for English_United_States/mk-sccp.jar

Feb  7 16:33:34.529: TFTP: Looking for United_States/g3-tones.xml

Phone with factory reset - firmware  8-3-1-22 - I tried 3 phones.  2 with unknown firmware as the phone had already been factory reset and onwe with the firmware listed above.  1 had one of the unknown phones work the other two are giving me the events listed below and then reboots for the same process. 

Feb  7 17:07:22.289: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0, changed state to up

Feb  7 17:07:50.305: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state to up

Feb  7 17:07:59.677: TFTP: Looking for term42.default.loads

Feb  7 17:07:59.677: TFTP: Opened flash:term42.default.loads, fd 0, size 662 for process 169

Feb  7 17:07:59.681: TFTP: Finished flash:term42.default.loads, time 00:00:00 for process 169

Feb  7 17:08:00.989: TFTP: Looking for term42.default.loads

Feb  7 17:08:00.993: TFTP: Opened flash:term42.default.loads, fd 0, size 662 for process 169

Feb  7 17:08:00.993: TFTP: Finished flash:term42.default.loads, time 00:00:00 for process 169 Feb  7 17:07:22.289: %

Once the phone has started the factory reset (upgrading process) is there a way that check the firmware.  Also I am not sure if it matter.  The phones were all set maunally to enable 802.1x.  Do I need to disable that prior to starting the firmware upgrade.  I found the phone that did work had that feature disabled after it came back up. 

Thank you

John

New Member

Issue updateing firm ware on a 7942 phone

It seems that if I disable 802.1x anything 8-3-2-27 and newer will work with a factory reset.  Anything older still does not work and all phones that have not had a factory reset will not upgrade. 

So the process that I am using now is:

Disable 802.1x from the phone.

Verifiy the firmware (needing 8-3-27 or newer)

Factory reset.

Phone works.

So given this I should be able to get most all my phones up.  However there have been a couple phones that had a factory reset done on them prior to me figuring out the above.  Does anyone know how to pull the settings so I can change the 802.1x settings after the phone has started the upgrade process?

982
Views
10
Helpful
5
Replies
CreatePlease to create content