Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Issue with Aastra phones on Cisco switch

We are trying to connect Aastra 6737i phones to a Cisco 4507 switch.  The phone system has its own router connect to the Cisco switch and the router is also acting as the dhcp server for the phones.  The PC's will be plugged into the phones and will need to go into the data vlan.  Here is where we have an issue:

Data Vlan: 100 172.25.1.0/24

Voice Vlan: 10  10.20.10.0/24

From what all i have read about Aastra phones we should be ussing lldp for these phones.  We have issues the lldp run command on the switch.  When we use the following configuration which is recommended.  The phone never gets an ip from the dhcp server running on the voice router and there is not connectivity:

interface GigabitEthernet6/4

switchport access vlan 100

switchport mode access

switchport voice vlan 10

spanning-tree portfast

end

With using this configuration and issues the show lldp neighbors Gig6/4 det command you can see that the network policy cleary states the voice vlan as 10 put we are unable to ping the phone:

sh lldp neighbors gigabitEthernet 6/4 det
------------------------------------------------
Chassis id: 172.25.1.229
Port id: 0008.5d30.d073
Port Description: port 0
System Name: Aastra IP Phone

System Description:
Aastra IP Phone

Time remaining: 105 seconds
System Capabilities: B,T
Enabled Capabilities: B,T
Management Addresses:
    IP: 172.25.1.229
Auto Negotiation - supported, enabled
Physical media capabilities:
    Other/unknown
    10base-T(HD)
    Symm Pause(FD)
    Symm, Asym Pause(FD)
    1000baseX(FD)
    1000baseT(HD)
Media Attachment Unit type: 30
Vlan ID: - not advertised

MED Information:

    MED Codes:
          (NP) Network Policy, (LI) Location Identification
          (PS) Power Source Entity, (PD) Power Device
          (IN) Inventory

    H/W revision: 6737i
    F/W revision: 3.2.2.6286
    S/W revision: 3.2.2.6286
    Serial number: 00-08-5D-30-D0-73
    Manufacturer: Aastra
    Model: 6737i
    Asset id: 00-08-5D-30-D0-73
    Capabilities: NP, PD, IN
    Device type: Endpoint Class III
   Network Policy(Voice): VLAN 10, tagged, Layer-2 priority: 5, DSCP: 46
    PD device, Power source: Unknown, Power Priority: High, Wattage: 6.5
    Location - not advertised


Total entries displayed: 1

ping 10.20.10.11

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.20.10.11, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

The only way we can get the phones to come up and grab the correct ip and stay online is to trunk the port and allow only the voice vlan.  This does not help because now the pc's will not work.  We can add the vlan 100 to the allowed list and the phones still work but not the pc's.  They try to come up in the native vlan which is 1 and it is shutdown.  When we issue the switchport trunk native vlan using either 10 or 100 the phones no longer work.  Here is the configuration that allows the phones to work:

interface GigabitEthernet6/4

switchport trunk allowed vlan 10

switchport mode trunk

spanning-tree portfast

ping 10.20.10.11

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.20.10.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms

The phone vendor stated the do have the configuration on the phone tagging its packets to vlan 10.  Any ideas as to why this does not work with the switchport access mode and stating the voice vlan in the interface configuration?

Everyone's tags (2)
2 REPLIES
Green

Issue with Aastra phones on Cisco switch

Mitchell,

This sounds like a bug with the 4500 IOS something like

CSCsq34665

What happens if you turn off LLDP on the switch and use the original config

interface GigabitEthernet6/4

switchport access vlan 100

switchport mode access

switchport voice vlan 10

spanning-tree portfast

end

 

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.

Issue with Aastra phones on Cisco switch

Hi ,

Since thrid party phones use lldp please try with below config

interface GigabitEthernet6/4

switchport trunk encapsulation dot1q

switchport mode trunk

switch trunk native vlan 100

switchport voice vlan 10

switch port trunk allowed vlan 100

4088
Views
0
Helpful
2
Replies
CreatePlease to create content