Cisco Support Community
Community Member

Issue with FAX connected with ATA

                   Hi there,  we have CUCM 8.6 cluser in sydney and local fax connected via ATA 186, when send fax  to area code 02, it goes via local Voice Gateway (ISDN), there is no issue. but when we send fax to 08 area code, since we used the TEHO, the fax go throught the perth voice gateway (ISDN), the fax always get busy tone. when I try to ring tfrom my IP phone to the 08 fax number, I can hear the fax tone, can call is going via perth gateway.  after I debug on the Perth Voice Gateway, I can see the following error:

Jul 17 2012 07:03:27.582 WST: %FLEXDSPRM-3-UNSUPPORTED_CODEC: codec g723r63 is not supported on dsp 0/0
Jul 17 2012 07:03:27.582 WST: %FLEXDSPRM-5-OUT_OF_RESOURCES: No dsps found either locally or globally.  

the voice gatewayn router is 2901 with PVDMIII-64 in Perth.  I am aware that the PVDMIII do not support  codec g723r63, and in sydney we have 2801 router with PVDMII which supports g723r63, but I don't know why the packets from fax has been sent as codec g723r63 by CUCM not codec g711a. any chance can we change it to g711a so it can be sent via the Perth voice gateway. Otherwise I have to stopt the TEHO for the FAX, so fax to 08 will only go via Sydney  voice Gateway.



Everyone's tags (5)
Community Member

Hi ciscoroyzhang,I was facing

Hi ciscoroyzhang,

I was facing a similar situation, while installing FXS, my router started to show same logs and I had to remove line "codec preference 2 g723r63", however for some awkward reason, it was keeping showing the same logs.

It worked using below script into my router:

dial-peer voice 40 voip
description Entrada especifica para conexao de modem
max-conn 1
translation-profile outgoing Remove#
destination-pattern ##T
modem passthrough nse codec g711alaw <<<<<<<
session protocol sipv2
session target sip-server
session transport udp
dtmf-relay rtp-nte
playout-delay nominal 200
playout-delay mode fixed no-timestamps
codec g711alaw
ip qos dscp ef signaling
no vad

after that it worked properly.

CreatePlease to create content