Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Jabber/LDAP using iPhone Error

Hi,

I'm trying to connect an Apple iPhone(OS 6) to Microsoft 2008 Active directory, but I'm getting the below error when I enter the username and password.

  • Credentials required or incorrect search base

When I exported the logs from android, I see that It connects to AD succefully for a second:

-- 2014-01-02 13:08:53.045 DEBUG [3b7f918c] - [UMCAccountViewController _initAccount:<UMCDirectoryAccount>:  X.X.X.X:389  isNewAccount:1

- 2014-01-02 13:10:46.229 DEBUG [82c1000] - -[CSILDAPQueryOperation performOperation]

-- 2014-01-02 13:10:46.233 DEBUG [3b7f918c] - Connected to an ActiveDirectory LDAP server

-- 2014-01-02 13:10:46.233 INFO [3b7f918c] - Naming Context found: DC=example,DC=com

       --[CSILDAPPersonDataSource ldapConnectionQueryDidComplete:]

After that everything goes downhill after that:

-- 2014-01-02 13:10:46.240 DEBUG [3b7f918c] - -[UMCAddressBook dataSourceDidFailConnect:]

-- 2014-01-02 13:10:46.241 INFO [3b7f918c] - [UMCAccountViewController account:didFailVerificationWithError] Error: Credentials required or incorrect search base

-- 2014-01-02 13:10:46.250 DEBUG [3b7f918c] - [UMCDirectoryAccount setConnectionStatus]: Disconnected

-- 2014-01-02 13:10:46.250 DEBUG [3b7f918c] - -[CSILDAPPersonDataSource stopDataSource]

-- 2014-01-02 13:10:46.251 DEBUG [3b7f918c] - -[CSILDAPDirectory unbind]

-- 2014-01-02 13:10:46.252 DEBUG [3b7f918c] - CSILDAPDirectory addOperation: CSILDAPUnbindOperation

-- 2014-01-02 13:10:46.252 DEBUG [3b7f918c] - CSILDAPDirectory addOperation: CSILDAPUnbindOperation

-- 2014-01-02 13:10:46.254 DEBUG [3b7f918c] - [UMCAccountManager connectionStatusDidChange]: new otherServices is 2

-- 2014-01-02 13:10:46.254 DEBUG [82c1000] - [CSILDAPUnbindOperation performOperation] Unbinding self.directory (<CSILDAPDirectory: 0x6a509d0>)


I have used the same IP and port for android phones and they connect seemlesly. I have used  port 3268 and 3269 both didnt work. This is my current settings:

ldap-cucm.JPG

Everyone's tags (5)
1 REPLY

Jabber/LDAP using iPhone Error

Hi Zekeria.

Give a look to this DOC if it can be useful

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a0080bbcd05.shtml

HTH

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
239
Views
0
Helpful
1
Replies
CreatePlease to create content