Cisco Support Community
Community Member

Latest UCM version support for 7940?

Hi, I'm currently running CM7.1 and have a large amount of 7940 handsets. Wanted to go to 10.5 but concerned whether it will work with current handset range.

I was trying to find latest version of CM that 7940 was tested/supported on I can see this in the release notes for 8.6 but the format of documentation has changed since then. Compatibilty matrixes seems to go round in circles.

I know 7940 are EOL, but there must be a latest version of CM known to work (would compromise with upgrade to 9.1). Also, does anyone have any experience with 7940's on 10 / 10.5?



Hi,I recently had a client as


I recently had a client as the same question, I tested in our Lab 7940 and 7960 and both worked with CUCM 10.0 and 10.5 

If you have a CCO login you should be able to access the following;

If you Select the version you are planning on migrating too i.e Collaboration Systems Release 10.5 and search fro 7900 you will see the following;


Cisco Unified IP Phone 7900 SeriesVersion NoBundled with Unified CM; Firmware 9.3(1) SR4 
EarliestBundled with Unified CM; Firmware 9.3(1) SR4


Whilst the 7940/60 doesn't run that version of firmware if you upgrade them to the latest release it will work fine.



Community Member

Thanks, I did see this and

Thanks, I did see this and noticed mention of 7900 series - that implied 7940. For the earlier versions of Call Manager (9.x) in the same tool, they had listed the 79xx phones individually and had excluded the 7940 sepcifically. I thought it was a bit misleading to then collapse this section in '7900 series' later in the tool, because it implied ALL phones within that range.

General consensus is they should work, but not supported - which fits with your experience, thanks for updating with your testing results.

Cisco Employee

Looking at the dates for EOS

Looking at the dates for EOS/EOL,

Probably this were last tested in something in the 8.x train, this were not tested with 9.x and above, so, they officially fall under the not supported category, all CUCM releases still have them, and the phone should work just fine with the features that are provided by their latest FW.

If something is ruled out to be directly related to the phone HW/FW, nothing we can do about it.



if this helps, please rate
CreatePlease to create content