Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Line busy when calling from phone A to phone B

Hi All,

 

I have an issue with my ip phones. When phone A calls phone B, A is getting busy sound. This happens when I set the Max call and busy trigger to 4 and 2 of phone B. When I tried changing the values to 8 and 7 the call works fine.

Call flow:

IP PHONE A --> CUCM 8.5 --> Transalation Pattern (to convert 4 digt to 7 digit) --> IP PHONE B

Traces are attaced, Calling number : 3527036, called number : 3527122 (Diall 122 from IP Phone A)

 

Kindly help.

 

Thanks,

Lajith P

11 REPLIES

Hi Lajith,

Hi Lajith, If you call phone-B with its complete 7 digits, does it work? It seems the attachment is missing.
//Suresh Please rate all the useful posts.

Hi,No. It does not work. The

Hi,

No. It does not work. The problem here is not with call routing, I feel the line always has 4 active calls WRT to CUCM and when an actual first call comes its giving busy. I see that in traces, so I have deleted the DN and re added it got worked. But I don't know how the line shows 4 calls when there is really no active calls.

Can you check? Traces attaced, for failed calls as well as successful calls.

 

Thanks,

Lajith P

What is the MAC address of

What is the MAC address of the called phone?

time stamp of working & non-working calls?

//Suresh Please rate all the useful posts.

Non Working Call @ 3

Non Working Call @ 3:20

Working call @ 3:35

Calling number : 3527036 SEPECC882111002

called number : 3527122 (Diall 122 from IP Phone A) SEP18339D158E84

 

 

Hi Lajith, I went thru the

Hi Lajith,

 

I went thru the traces but couldn't find any information on why the line control always shows 4 calls.

 

>> The device was reset at 3:18.48

03:18:48.910 |Setting extension (3527122) to unregistered status|*^*^*
03:18:48.910 |<--RISCMAccess::DeviceUnRegister(...)|*^*^*

 

The line control shows 4 calls when the phone was being unregistered.

 

03:18:48.910 |LineControl::sendSNFNotifyIndForPresenceWithAlerting mPrecenceWithAlertingChangeNotifySubscribed=0, calllist#=4|11,100,50,1.185287704^19.198.179.105^SEP18339D158E84


03:18:48.910 |LineControl(9286) - 4 calls, 0 CiReq, busyTrigger=1, maxCall=1|11,100,50,1.185287704^19.198.179.105^SEP18339D158E84.

 

>> at 03:18:57, the phone is re-registering.

 

03:18:57.553 |SCCP Device Register from Unregister: deviceName(SEP18339D158E84), Protocol(1), RegisteredSCCP(941), RegisteredSIP(0), Registered(941)|*^*^*


03:18:57.553 |Device Register deviceName : SEP18339D158E84, IPAdress : 19.198.179.105, IPv6Address : not shown, IPv4Attribute : 3, IPv6Attribute : 0, LoadID : SCCP42.9-3-1SR2-1S, ActiveLoadID : SCCP42.9-3-1SR2-1S, InactiveLoadID : , DeviceType : 404, Protocol : 1|*^*^*


03:18:57.554 |LineControl(9286) - SEP18339D158E84 registered, CEPN=91767fc9-685b-adae-120f-510d1d23841c, deviceType=1|11,100,50,1.185288328^19.198.179.105^SEP18339D158E84

>> The line controls has been updated with 4 calls again.

 

03:18:57.554 |LineControl::sendSNFNotifyIndForPresenceWithAlerting mPrecenceWithAlertingChangeNotifySubscribed=0, calllist#=4|11,100,50,1.185288328^19.198.179.105^SEP18339D158E84


03:18:57.554 |LineControl(9286) - 4 calls, 0 CiReq, busyTrigger=2, maxCall=4|11,100,50,1.185288328^19.198.179.105^SEP18339D158E84

 

>> when phone 3527036 called 3527122, the call was rejected with user busy cause code 17, as there were 4 calls on the line control and the max call was also set to 4.

 

03:22:17.982 |StationD:    (0035010) DialedNumber dialedNumber=122 lineInstance=1 callReference=199878641.|11,100,50,1.185303254^19.237.142.63^SEPECC882111002


03:22:17.982 |StationD:    (0035010) CallState callState=12 lineInstance=1 callReference=199878641 privacy=0 sccp_precedenceLv=4 precedenceDm=0|11,100,50,1.185303254^19.237.142.63^SEPECC882111002


03:22:17.982 |StationD:    (0035010) (11,100,9,98863) CallInfo callingPartyName='TEST' callingParty=3527036 cgpnVoiceMailbox=             alternateCallingParty=              calledPartyName='FAIZAL DEDONCKER' calledParty=3527122 cdpnVoiceMailbox=             originalCalledPartyName='FAIZAL DEDONCKER' originalCalledParty=3527122 originalCdpnVoiceMailbox= originalCdpnRedirectReason=0             lastRedirectingPartyName='FAIZAL DEDONCKER' lastRedirectingParty=3527122 lastRedirectingVoiceMailbox= lastRedirectingReason=0             callType=2(OutBound) lineInstance=1 callReference=199878641. version: 85720016|11,100,50,1.185303254^19.237.142.63^SEPECC882111002


03:22:17.982 |StationD:    (0035010) DEBUG- star_DSetCallState(6) State of cdpc(305746) is 5.|11,100,50,1.185303254^19.237.142.63^SEPECC882111002


03:22:17.982 |LineControl(9286) - 4 calls, 0 CiReq, busyTrigger=2, maxCall=4|11,100,50,1.185303254^19.237.142.63^SEPECC882111002


03:22:17.982 |processCCMFeatureData: operationIeIdd=0|11,100,50,1.185303254^19.237.142.63^SEPECC882111002


03:22:17.982 |AAR Data: aaren = 0  daaren = 1  CallingNgbrhood = 1  CalledNgbrhood = 1   dAlternateRouteExternalNumber = 4067122|11,100,50,1.185303254^19.237.142.63^SEPECC882111002


03:22:17.982 |Cdcc::CcRejInd: ccRejInd.c.cv = 17|11,100,50,1.185303254^19.237.142.63^SEPECC882111002

 

>> but I'm unable to see why the line control is not updated with current status of active calls.

>> is that happened for only one phone? one thing I assume is it could be because of firmware?

>> good to know it is working after deleted and readded the phone.

 

//Suresh Please rate all the useful posts.

Hi Suresh,Thank you for your

Hi Suresh,

Thank you for your findings.

Yes. Since I feel the line always updates with 4 calles I deleted the dn from route plan report and tested couples of calls and found working.

 

This issue is isoated to a single site where this site was migrated from one cluster to another. Initially I faced this issue for only one phone but as the days increase the issue phone count also getting increased.

 

Either it could be a firmware issue, because we dont have any problem with another phones registered in another site under the same cucm.

 

I  have one query here.. When the phone re registeres does it instructs the CUCM that the phone line has 4 calls or CUCM's call database has already 4 calls assigned on that DN?

 

Thanks,

Lajith P

The firmware on this

The firmware on this nonworking 7962 phone is SCCP42.9-3-1SR2-1S. is this the default load?

what is the firmware on the working site phones?

To answer your query, It is CUCM that updates the line control with active call list.

 

what is the complete version of your CUCM? may be some bug related to call leak in your version?

 

//Suresh

Please rate all the useful posts

//Suresh Please rate all the useful posts.

Yes. SCCP42.9-3-1SR2-1S is

Yes. SCCP42.9-3-1SR2-1S is the default firmware and it works fine with other ip phones.

My CUCM version is 8.5.1.16102-1

 

//Lajith

 

We had  replication issues

We had  replication issues also there with this cluster, so a cluster reboot had fixed all our issues. :)

 

//Lajith

Thanks for the update Lajith.

Thanks for the update Lajith. It would help someone.

//Suresh Please rate all the useful posts.

The original issue is back

The original issue is back again, escalated to Cisco and the DE team found it as a bug CSCub55072.

614
Views
3
Helpful
11
Replies
CreatePlease login to create content