Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

linecode issue with CCM 5.1(1) and MGCP gateway (2801 router)

Hello

i have the following setup:

Cisco Callmanager 5.1(1)

Cisco 2801 router 12.4(9) with VWIC2-1MFT-T1E1-E1 module

in then CCM i have setup the gateway as an MGCP gateway.

The issue is, that every time i reboot the router, and the CCM tries to register with the gateway, it sets the linecode to ami (which is the standard for T1), and then the CCM cannot register with the gateway. THen i have to manually enter the "linecode hdb3" command in the router CLI to get the CCM to register. and then everything works just fine, until i reboot the router, and then the linecode i set back to ami.

i tried different IOS versions, without any luck.

can anyone help me out with this problem ? thanks in advance...

here is the config output:

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname ccmgate

!

boot-start-marker

boot-end-marker

!

card type e1 0 2

enable secret "REMOVED"

enable password "REMOVED"

!

no aaa new-model

!

resource policy

!

network-clock-participate wic 2

ip cef

!

!

no ip dhcp use vrf connected

!

ip dhcp pool IPTX

network 10.10.10.0 255.255.255.0

default-router 10.10.10.2

option 150 ip 10.10.10.3

!

!

ip domain name "REMOVED"

ip host CCM 10.10.10.3

!

isdn switch-type primary-net5

!

voice-card 0

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

controller E1 0/2/0

pri-group timeslots 1-16 service mgcp

!

!

!

!

interface FastEthernet0/0

ip address 10.10.10.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/2/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

ip route 0.0.0.0 0.0.0.0 10.10.10.1

!

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

!

disable-eadi

!

!

voice-port 0/2/0:15

cptone DK

!

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.10.10.3

ccm-manager config

!

mgcp

mgcp call-agent CCM 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

!

!

!

!

line con 0

password "REMOVED"

login

line aux 0

line vty 0 4

password "REMOVED"

login

!

scheduler allocate 20000 1000

end

3 REPLIES
New Member

Re: linecode issue with CCM 5.1(1) and MGCP gateway (2801 router

Rasmus,

It appears you are configuring the controller as a PRI. The linecode "ami" is traditionally used for analog lines, PRI is digital or not channelized. Do you have a analog T1 or digital PRI?

New Member

Re: linecode issue with CCM 5.1(1) and MGCP gateway (2801 router

it's a E1 PRI (digital)

Re: linecode issue with CCM 5.1(1) and MGCP gateway (2801 router

You can remove the 'ccm-manager config' command so the config is not downloaded from the CCM which may be causing your problem....

You can also do a 'debug ccm-manager config-download' I believe (or similar) to see what commands the ccm-manager config is pushing down.

206
Views
0
Helpful
3
Replies
CreatePlease to create content