Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Local directory service not working

Hello all. I am using ccme 4.0 and 7970G-Ge Ip phone. I configured the directory numbers, however when I do show run..I do not see this line "local directory service: enabled." hence, my phones do not have access to the local directory..Please can any one help

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Local directory service not working

Also try,

telephony-service

directory-entry last-name-first (syntax may be wrong here)

create cnf-files

reset all

8 REPLIES
Green

Re: Local directory service not working

AVVID6#conf t

Enter configuration commands, one per line. End with CNTL/Z.

AVVID6(config)#telephony-service

AVVID6(config-telephony)#service local-directory

New Member

Re: Local directory service not working

Hi, I am not sure you got my post. I have this command configured on the router, however, My phones still do not have access to the local directory..is ther anything else I need to do.

Re: Local directory service not working

Also try,

telephony-service

directory-entry last-name-first (syntax may be wrong here)

create cnf-files

reset all

New Member

Re: Local directory service not working

If your still having issues with the local directory service, can you confirm that the "ip http server" is enabled in your config.

The Local Directory services require xml web services

Mike.

New Member

Re: Local directory service not working

Thank you so much!!! You need to see how happy I am. Please I have one other issue...

When external calls come in, I do not see the the caller -id...It usually shows unknown number..Is there any thing I can do to see the caller-ids...

New Member

Re: Local directory service not working

Hi, I observed that not all the phones have access to the local directory. Some do and some do not. This is disturbing. What I obserevd is that, in the device configuration menu on the phones, the phones that have access to the local directory have the directories url http://192.168.2.1:80/localdirectory on them while the phones that do not have access do not have this...How can i resolve this please..

Thank you

New Member

Re: Local directory service not working

On further troubleshooting, I obserevd that,all the 7912 Phones have access to the directory services,including any new phones just configured or added to the cme.However its only the 7970 phone connected to the cme at the time I issued those set of commands ( telephony-service, directory last-name-first, create cnf files) that has access to the services. So the issue I have now is with the 7970 phones..Thank you

New Member

Re: Local directory service not working

Just to let you know I have resolved the problem...The command..type 7970 was missing on the 7970 phones..That solved it.

Thanks

230
Views
0
Helpful
8
Replies
CreatePlease login to create content