Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Loop MoH - Enable music on hold multicast call quality issues

Hi,


We have two CUCM 9.1 ( Pub / Sub ) servers run at two sites connected via a 1Gb layer 2 Ethernet link on VLAN 100.

When we enabled multicast for MOH on the subscriber to loop the music on hold when a call is placed on hold ( otherwise the moh file restart from the start from the begining each time the call has been placed on hold)  - we get call quality issues with external calls via the gateway.

We have Auto Qos enabled on all our swiches expect the gateways, as only being used with Voice.

What would be my best options to loop music on hold and not get call qaulity issues or how I troubleshoot this issue?   

5 REPLIES

Loop MoH - Enable music on hold multicast call quality issues

Not sure if there is a connection between the MoH quality issues and the music being played continuously.

I would start by making sure your MoH server is set in a region with codec G711 and your incoming VoIP dial peer to CM is set to G711 as well.

Hall of Fame Super Silver

Loop MoH - Enable music on hold multicast call quality issues

Sounds like the port where the servers are connected are misconfigured (i.e. policy restricting voice bandwidth), can you post the config of the switch ports where the servers are connected with all relative config?

Chris

New Member

Loop MoH - Enable music on hold multicast call quality issues

Hi Chris,

I've added the config for that server and gateway.

On the daul stacked 3750 - you have port Gi1/0/10 and Gi2/0/10 connected to CUMC 9.1 server and port  Gi1/0/12 and gi2/0/12 connected to the Cisco 2921 on port G0/0 and G0/1

Thanks again  

Hall of Fame Super Silver

Loop MoH - Enable music on hold multicast call quality issues

I am sorry, what did you add?

Your server and GW ports should not have any policy defined on them, and should have "mls qos trust dscp" configured on the ports.

HTH, please rate all useful posts!

Chris

New Member

Loop MoH - Enable music on hold multicast call quality issues

Thanks 

I've attached the config's in the discussion.

So these configurations below for ports are incorrect ?

Server Ports -

interface GigabitEthernet1/0/10

switchport access vlan 100

switchport mode access

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

interface GigabitEthernet2/0/10

switchport access vlan 100

switchport mode access

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

interface GigabitEthernet2/0/12

switchport access vlan 100

switchport mode access

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

interface GigabitEthernet1/0/12

switchport access vlan 100

switchport mode access

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

interface GigabitEthernet2/0/10
switchport access vlan 100
switchport mode access
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust

Gateway Ports :

interface GigabitEthernet1/0/12
switchport access vlan 100
switchport mode access
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust

interface GigabitEthernet2/0/12
switchport access vlan 100
switchport mode access
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust

722
Views
0
Helpful
5
Replies
CreatePlease login to create content