Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MDA configured for Linux PCs, but getting err-disable due to security violation

Hi all,

Sorry if this is a well known issue I couldn't find anything.  I am having troubles testing Linux PCs hanging off 797x phones with MDS configured on c3750's running 12.2(55)SE3.

I am working with a variety of PC builds at a customer site and I found when I shut/no shut the switch interfaces to clear the sessions, connect clean built desktop Linux machines to the phones, the 3750 switch ports err-disable themselves and logs say its a security violations, with (correct) machine MAC xxxxxx seen on interfaces fa1/0/x.  So far I've found this happens with RHEL v5 or v6, CentOS v6, and Fedora19.

Switch ports are are configured for multi-domain access and Windows7_x64 boxes and printers connect to the same phone access ports and all is OK. At first I thought I had a problem with _all_ Linux boxes but then Ubunu v12 and v13 worked fine. Retesting the others just shut the switch ports again. 

Yesterday I cleared the mac table shut/no shut the switch ports, even rebooted the phones and connected Windows and it all worked as expected.  I did the same with a Fedora box and the switch err-disabled again which is just nutz!  When I patch any of these boxes directly to a switch and they are all fine, but run them through a phone and the problem returns.  It seems like an MDA issue to me but I can't prove either way yet.

I'm not a big user of Linux but I believe Ubuntu is different in that its Debian-based and I'm told the others are all Red Hat based OS's.  So maybe something there to consider.. maybe?

Has anyone seen this before or can suggest anything please?  I have to go back to this customer in a couple of days and trying to get my head around this in the meantime.  Next I want to try this on their 6500s and see what happens.

Thanks in advance,

Paul

1 REPLY

Re: MDA configured for Linux PCs, but getting err-disable due to

Hi Paul.
Please attach switch configuration where you recently viewed the issue
Thanks

Carlo

Sent from Cisco Technical Support iPhone App

Please rate all helpful posts "The more you help the more you learn"
111
Views
0
Helpful
1
Replies