Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

MGCP Configuration error

Hello everyone!

I am  trying to configure MGCP on Cisco Router with E1 card and CUCM. I have  done it several times before, but this time E1 is not connected yet.

However, I am pretty sure that I should be seeing router's IP address on CUCM in the Gateway Section

show mgcp statistics shows me this strange failed messages:

IP address based Call Agents statistics:

IP address 192.168.x.x, Total msg rx 7,

                 successful 0, failed 7

What is this? And should I see my router's IP address on CUCM eventhough E1 is not connected?

debug mgcp error:

Sep 30 08:37:58.675: cmapp_mgr_process_ev_active_host_failed: Active host 0 (192

.168.246.6) failed

Sep 30 08:37:58.675: //-1/xxxxxxxxxxxx/MGCP/mgcp_mp_get_not_entity(830):[lvl=2]I

nvalid parameter (pkt 0x300086A0 pkt->mgcp_parm_lines 0x0)

Sep 30 08:38:28.675: cmapp_mgr_process_ev_active_host_failed: Active host 0 (192

.168.246.6) failed

Sep 30 08:38:28.675: //-1/xxxxxxxxxxxx/MGCP/mgcp_mp_get_not_entity(830):[lvl=2]I

nvalid parameter (pkt 0x300086A0 pkt->mgcp_parm_lines 0x0)

Thank you!

P.S. One more thing I noticed regarding TFTP:

Sep 30 08:40:01.159: cmapp_xml_tftp_download_file: Unable to read file tftp://19

2.168.246.6/Azans_vgw.cnf.xml, rc=-2

Sep 30 08:40:01.159: cmapp_xml_get_xml_file: Could not read file tftp://192.168.

246.6/Azans_vgw.cnf.xml, len = 0

Sep 30 08:40:01.159: cmapp_xml_tftp_download_file: Unable to read file tftp:///A

zans_vgw.cnf.xml, rc=-2 ccm-manager confi

Sep 30 08:40:01.159: cmapp_xml_get_xml_file: Could not read file tftp:///Azans_v

gw.cnf.xml, len = 0

Sep 30 08:40:01.159: cmapp_xml_tftp_download_file: Unable to read file tftp:///A

zans_vgw.cnf.xml, rc=-2

Sep 30 08:40:01.159: cmapp_xml_get_xml_file: Could not read file tftp:///Azans_v

gw.cnf.xml, len = 0

Sep 30 08:40:01.159: cmapp_xml_exec_fsm: New state = CMAPP_XML_FILE_DNLD, ep = 2

A2DD130

Sep 30 08:40:01.675: //-1/xxxxxxxxxxxx/MGCP/mgcp_mp_get_not_entity(830):[lvl=2]I

nvalid parameter (pkt 0x300086A0 pkt->mg

I am using IP addresses, no DNS for now. Is it going to be a problem?

8 REPLIES
VIP Purple

MGCP Configuration error

Hi ,

regarding your TFTP problem, can  u share the show ccm-manager and show run from router?

also, share snapshot of show gateway config from CUCM.

regds,

aman

New Member

MGCP Configuration error

I have added router's name to DNS, not I can see the end points Unregistered (which is fine, E1 is not connected yet), but the gateway's status in CUCM is still unknown under IP address column

hostname Voice

!

boot-start-marker

boot-end-marker

!

!

card type e1 0 0

logging buffered 51200 warnings

!

no aaa new-model

network-clock-participate wic 0

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

!

no ip domain lookup

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-net5

!

!

trunk group Telco_out

hunt-scheme round-robin

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-3098560452

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3098560452

revocation-check none

rsakeypair TP-self-signed-3098560452

!

!

crypto pki certificate chain TP-self-signed-3098560452

certificate self-signed 01

  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33303938 35363034 3532301E 170D3133 30333036 31393436

  31385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 30393835

  36303435 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100A959 59FA6C77 884ABCE2 5EE87969 FF9C33E1 9035A360 12CBC6D1 FEFE9066

  19C306AD 593D776C F9412E59 85A9DE07 7D3FF526 BCDA25CC 7E4F911E 042C77D7

  B3BE33CA 13B484BE 897DEDB2 25CFE7A3 620E7B73 A1EFBB99 C5541297 FA6DBD07

  444B0210 02949478 B0744481 FFB0203A 20F248E3 43275A0E 283ED3D9 9041A002

  04F10203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

  551D2304 18301680 14B1E232 35F97EA5 0CCCFCBB 92D91657 91CF6384 20301D06

  03551D0E 04160414 B1E23235 F97EA50C CCFCBB92 D9165791 CF638420 300D0609

  2A864886 F70D0101 05050003 81810062 D01B98AD B9447BAE 70815CEA 24521792

  8CF35F85 3C53D560 59E33377 E77B0011 499B7CD6 981F11A7 31872A9D AA6F8467

  B72DA077 5F0E8F4F ABDC00B5 871754AB 9EECBA8D DAA65659 CCB1F305 42FC4661

  4E2DF4D9 D6EB4358 89B9418B 61BEC80F C63DDBCA 0B77D669 B67C72EF BDA352CF

  E73A03CA 3DE3BB66 1D6B76DE 552B77

        quit

voice-card 0

codec complexity medium

dsp services dspfarm

!

!

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g729br8

codec preference 3 g723r53

codec preference 4 g723r63

codec preference 5 g723ar53

codec preference 6 g723ar63

codec preference 7 g711ulaw

codec preference 8 g711alaw

!

voice class codec 2

codec preference 1 g711ulaw

codec preference 2 g711alaw

codec preference 3 g729r8

codec preference 4 g729br8

codec preference 5 g723r53

codec preference 6 g723r63

codec preference 7 g723ar53

codec preference 8 g723ar63

!

!

!

!

!

!

application

service Karsilama flash://TCL.tcl

  param pilotno 1111

  param alerttimeout 30

!

!

license udi pid CISCO2911/K9 sn FCZ16337UYJ

hw-module pvdm 0/0

!

!

!

!

redundancy

!

!

controller E1 0/0/0

pri-group timeslots 1-31 service mgcp

!

controller E1 0/0/1

pri-group timeslots 1-12,16 service mgcp

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface Serial0/0/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

ip default-gateway 192.168.1.10

ip forward-protocol nd

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip route 0.0.0.0 0.0.0.0 192.168.1.10

!

!

!

!

control-plane

!

!

voice-port 0/0/0:15

!

voice-port 0/0/1:15

!

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 192.168.1.11

ccm-manager config

!

mgcp

mgcp call-agent 192.168.1.11 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 ecm

mgcp fax t38 inhibit

no mgcp explicit hookstate

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface GigabitEthernet0/0

mgcp bind media source-interface GigabitEthernet0/0

!

mgcp profile default

!

!

dspfarm profile 7 mtp

codec g711ulaw

maximum sessions software 100

associate application SCCP

shutdown

!

!

!

!

gatekeeper

shutdown

!

!

!

line con 0

line aux 0

!

scheduler allocate 20000 1000

end

Voice#

New Member

MGCP Configuration error

TFTP problem is now gone as well btw

VIP Purple

MGCP Configuration error

Hi,

You connect the E1 and if it is UP, u should see Gateway : Voice , Registration :REGISTERED WITH Cisco Unified Communications Manager hostname of Server , IP address  : LAN Router under Device Gateway.

regds,

aman

New Member

MGCP Configuration error

Snapshot

New Member

MGCP Configuration error

Usually these erors are associated with the name not matching.

If I were you - set the hostname

hostname VoiceRouter

set the domain


ip domain name MyDomain.com

so now make sure the device is defined on call manager

voicerouter.mydomain.com

You need to ensure that the router is sending the exact name defined on call manager.

Bronze

MGCP Configuration error

Gateways always show an unknown IP address. Only the endpoints report IP address and registration status.

Gareth

New Member

MGCP Configuration error

you should add the MGCP gateway by Hostname of the voice gateway

the name should be "Voice" and since i dont see any domain name configured on the router , so simply hostname will work

please send the " Show isdn status " out put as well,

Regards

Anurag Siddhu

802
Views
0
Helpful
8
Replies
CreatePlease to create content