Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

MGCP configuration issue (isdn --> invalid input)

Hi all,

I have a 2801 router. I inserted a VWIC2-1MFT-T1/E1 card. I configured it on a CUCM 7.1 by adding a new gateway using MGCP (I want it work using QSIG).

On the router I inserted the following commands:

no ip domain-lookup

mgcp

ccm-manager config server 172.17.7.5

ccm-manager config

exit

wr mem

After inserting these commands I could see the following debug:

Loading MU-GW-2801.cnf.xml from 172.17.7.5 (via FastEthernet0/0): !

[OK - 4749 bytes]

MU-GW-2801#

*Feb 10 11:43:57.786: %SYS-5-CONFIG_I: Configured from console by admin on console

This package type is not the default package type.

isdn switch-type primary-4ess

  ^

% Invalid input detected at '^' marker.

Could anyone help on what is the matter? I have tried several IOS:

   - c2801-adventerprisek9-mz.124-24.T2.bin

   - c2801-advipservicesk9-mz.124-24.T2.bin

   - c2801-entservicesk9-mz.124-24.T2.bin

I thought it could be that the command was not supported. But, none of these IOS worked.

Thank you very much,

JOSU

3 REPLIES
Bronze

Re: MGCP configuration issue (isdn --> invalid input)


There are alot more commands you need to add try

   pri-group timeslots 1-?? service mgcp
   
under controller interface

   isdn bind-l3 ccm-manager

under serial interface

then these addtional commands

  ccm-manager mgcp

   ccm-manager music-on-hold

 

   mgcp

   mgcp call-agent "IP address of callmanager "service-type mgcp version 0.1

   mgcp dtmf-relay voip codec all mode out-of-band

   mgcp modem passthrough voip mode nse

   mgcp package-capability rtp-package

   mgcp package-capability sst-package

   no mgcp package-capability fxr-package

   mgcp package-capability pre-package

   no mgcp timer receive-rtcp

   mgcp sdp simple

   mgcp fax t38 inhibit

   mgcp rtp payload-type g726r16 static

You need to make sure that in Callmanager the port says "registered" if it doesn't then you have the configuration wrong

 

New Member

Re: MGCP configuration issue (isdn --> invalid input)

Thank you very much for your answer markbatts

I discovered I had a problem. I saw this on the running-conf: "card type command needed for slot/vwic-slot 0/1".

So I introduced the command "card type e1 0 1". So, after that I saw "controller E1 0/1/0" on running. I was quite surprised not to see it before.

Afterwards I re-enter the commands:

   - mgcp

   - ccm-manager config server 172.17.7.5

   - ccm-manager config

I got this result:

Loading MU-GW-2801.cnf.xml from 172.17.7.5 (via FastEthernet0/0): !

[OK - 4757 bytes]

I checked the running-config and I saw these new lines:

isdn switch-type primary-5ess

no ccm-manager fax protocol cisco
ccm-manager music-on-hold

mgcp
mgcp call-agent 172.17.7.5 2427 service-type mgcp version 0.1
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
!
mgcp profile default

But when I checked on the CUCM I saw that it still appeared as "unregistered". So I selected the gateway and reset it. Doing so, I got these entries in gateway's console:

%Please configure network-clock-participate wic 1 first

%Insufficient resources to create pri-group - it has been removed

interface Serial0/1/0:15

          ^

% Invalid input detected at '^' marker.

isdn bind-l3 ccm-manager

      ^

% Invalid input detected at '^' marker.

What am I missing? I do not have any serial interface. Those commands are which you told me in your answer. Why should I have a serial interface. I am quite new in MGCP so every help is welcommed...

THANK YOU VERY MUCH

JOSU

New Member

Re: MGCP configuration issue (isdn --> invalid input)

Hi again,

I keep making some tries. The first line of the errors was:

%Please configure network-clock-participate wic 1 first

So I introduced the command "MU-GW-2801(config)#network-clock-participate wic 1". Afterwards I reset the gateway from the CUCM and I got these error:

echo-cancel coverage 8

                       ^

% Invalid input detected at '^' marker.

%At least one pri-group was configured already for E1 0/1/0

Please remove it before changing timing mode.

*Feb 10 17:35:38.979:  voice_port is not initialized

*Feb 10 17:35:39.955: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0:0, changed state to down

*Feb 10 17:35:39.955: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0:1, changed state to down

*Feb 10 17:35:39.955: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0:2, changed state to down

*Feb 10 17:35:39.955: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0:3, changed state to down

*Feb 10 17:35:39.955: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0:4, changed state to down

*Feb 10 17:35:39.955: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0:5, changed state to down

*Feb 10 17:35:39.955: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0:6, changed state to down

*Feb 10 17:35:39.959: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0:7, changed state to down

*Feb 10 17:35:39.959: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0:15, changed state to down

I can see now the serial interface. But, I do not know how to solve the pri-group issue..

THANK YOU!!!

JOSU

1764
Views
0
Helpful
3
Replies
CreatePlease to create content