Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

MGCP controlled 2821 and FXS to RightFax?

I have a CCM 4.3(1) with a 2821 running 12.4(11)T MGCP controlled. There are 3 PRI's coming into the system and 12 FXS ports tied to Caparis RightFax Server 9.X.

Calls come into CCM just fine and all call routing works even to the RightFax server through RL-->RG configuration that I have route patterns pointing to from within CCM.

Call Flow goes PSTN-->2821-MGCP(PRI)-->CCM(4.3(1))-->2821-MGCP(FXS Ports)-->Caparis-RightFax.

The faxes are getting to the server, however it is placing them in a default account because there is no DTMF being passed to it according to running the card in debug mode. So no ANI nor DNIS.

I was thinking of going to H323 to make this work if needed but would like to stick with MGCP if possible.

Should I switch the "MGCP" command from dtmf out of band to other parameters

or

Will I have to enable Fax-Relay and not passthrough to get this to see the DTMF digits ANI/DNIS?

5 REPLIES
Anonymous
N/A

Re: MGCP controlled 2821 and FXS to RightFax?

You can use DTMG relay.DTMF relay provides a way to transport DTMF digits in an RTP voice stream when the voice codec cannot accurately reproduce the digits, or the sender or receiver digital signal processor (DSP) cannot perform digit sampling. Each DTMF digit is encoded as an RTP named event packed, which is transmitted and received instead of the usual digit samples carried in voice packets. The named events are sent as RTP packets over UDP. The packets are encoded with a payload type which is negotiated during connection establishment between the GWs using SDP.

http://cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080087eb3.html#wp1028560

Community Member

MGCP controlled 2821 and FXS to RightFax?

I know this is a pretty old thread but I am having the same issue except I am running H323.   So my topology looks like thiis

DID from the PSTN over T1 >>> Cisco 2921 >>> FXS Port >>> RightFax Server

So calls rote over the T1 (4 digit DID) and I have a pots dial-peer pointed to the FXS port that the RightFax server is plugged into.  The Fax server nswers up but DID is never passed so the Fax is never routed to the intended recipient

because the routing code is always 0.

Any help would be appreciated.

Green

MGCP controlled 2821 and FXS to RightFax?

Hi

Can you paste in your router config.

Regards

Alex

Regards, Alex. Please rate useful posts.
Community Member

MGCP controlled 2821 and FXS to RightFax?

APPVG1#sho run

Building configuration...

Current configuration : 6342 bytes

!

! Last configuration change at 11:13:07 EDT Mon Jul 25 2011 by tekadmin

!

version 15.1

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

hostname APPVG1

!

boot-start-marker

boot system flash flash:c2900-universalk9-mz.SPA.151-3.T1.bin

boot-end-marker

!

!

card type t1 0 0

logging buffered 5000000

no logging console

no logging monitor

!

no aaa new-model

clock timezone EST -5 0

clock summer-time EDT recurring

network-clock-participate wic 0

network-clock-select 1 T1 0/0/0

!

no ipv6 cef

ip source-route

ip cef

!

!

!

ip multicast-routing

ip multicast multipath

no ip dhcp conflict logging

ip dhcp excluded-address 192.32.15.1 192.32.15.99

!

ip dhcp pool VOICE

   network 192.32.15.0 255.255.255.0

   default-router 192.32.15.1

   dns-server 192.32.11.11 192.32.11.37

   domain-name app.com

   option 150 ip 192.32.15.30

!

!        

no ip domain lookup

ip domain name app.com

multilink bundle-name authenticated

!

!

!

stcapp supplementary-services

port 0/2/3

  fallback-dn 3737

!

!

!

!

trunk group Copper

hunt-scheme round-robin

!

crypto pki token default removal timeout 0

!

!

voice-card 0

!

!

!        

voice service pots

!

voice service voip

allow-connections h323 to h323

supplementary-service h450.12

fax protocol t38 version 0 ls-redundancy 2 hs-redundancy 0 fallback none

h323

  call preserve

  session transport udp

modem passthrough nse codec g711ulaw

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

codec preference 3 g729r8

!

voice class h323 1

  h225 timeout tcp establish 3

!

!

!

!

!        

license udi pid CISCO2921/K9 sn FTX1522AH73

hw-module pvdm 0/0

!

!

!

archive

log config

  hidekeys

username tekadmin privilege 15 password 7 045558121B72470A584B56

!

redundancy

!

!

controller T1 0/0/0

cablelength long 0db

ds0-group 0 timeslots 1-24 type e&m-wink-start

!

ip ssh version 2

!

!

!

!

interface GigabitEthernet0/0

description ** Voice Interface **

backup interface GigabitEthernet0/1

ip address x.x.x.x

duplex auto

speed auto

no mop enabled

h323-gateway voip interface

h323-gateway voip bind srcaddr x.x.x.x

!

interface GigabitEthernet0/1

description Backup Interface

ip address x.x.x.x

duplex auto

speed auto

no mop enabled

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

no mop enabled

!        

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 x.x.x.x

!

!

!

!

control-plane

!

!

voice-port 0/0/0:0

no vad

!

voice-port 0/1/0

description Paging Access

!

voice-port 0/1/1

trunk-group Copper

description 911 Backup

!        

voice-port 0/1/2

trunk-group Copper

description 911 Backup

!

voice-port 0/1/3

trunk-group Copper

description 911 Backup

!

voice-port 0/2/0

description Customer Service Fax

station-id name 0128

station-id number 0128

caller-id enable

!

voice-port 0/2/1

description HR Fax

station-id name 3177

station-id number 3177

caller-id enable

!

voice-port 0/2/2

description Finance

station-id name 0557

station-id number 0557

caller-id enable

!

voice-port 0/2/3

timeouts ringing infinity

description Fax Test

caller-id enable

!

!

!

mgcp profile default

!

!

dial-peer voice 1000 pots

preference 1

destination-pattern 91[2-9]..[2-9]......

port 0/0/0:0

forward-digits 11

!

dial-peer voice 1001 pots

preference 1

destination-pattern 9[2-9]..[2-9]......

port 0/0/0:0

forward-digits 10

prefix 1

!

dial-peer voice 1002 pots

destination-pattern 9011T

port 0/0/0:0

prefix 011

!

dial-peer voice 1003 voip

destination-pattern 3[68]..

session target ipv4:x.x.x.x

incoming called-number .

voice-class codec 1 

dtmf-relay h245-signal h245-alphanumeric

!

dial-peer voice 1004 voip

destination-pattern 3700

modem passthrough nse codec g711ulaw

session target ipv4:x.x.x.x

codec g711alaw

fax rate disable

!

dial-peer voice 1005 pots

description Inbound to RightFax

destination-pattern 37..

port 0/2/0

!

dial-peer voice 1006 voip

destination-pattern 3702

modem passthrough nse codec g711ulaw

session target ipv4:x.x.x.x

codec g711alaw

fax rate disable

!

dial-peer voice 1007 voip

destination-pattern 3703

modem passthrough nse codec g711ulaw

session target ipv4:x.x.x.x

codec g711alaw

fax rate disable

!

dial-peer voice 1008 pots

destination-pattern 9911

port 0/0/0:0

forward-digits 3

!        

dial-peer voice 1009 pots

destination-pattern 911

port 0/0/0:0

forward-digits all

!

dial-peer voice 1010 pots

trunkgroup Copper

destination-pattern 9911

forward-digits 3

!

dial-peer voice 1011 pots

trunkgroup Copper

destination-pattern 911

forward-digits all

!

dial-peer voice 1012 pots

destination-pattern 5000

port 0/1/0

forward-digits 0

!

dial-peer voice 2000 pots

description Cust Serv Fax

destination-pattern 0128

port 0/2/0

!

dial-peer voice 2001 pots

description HR Fax

destination-pattern 3177

port 0/2/1

!

dial-peer voice 2002 pots

description Finance Fax

destination-pattern 0557

port 0/2/2

!

dial-peer voice 2003 pots

destination-pattern 3737

no digit-strip

port 0/2/3

forward-digits all

!

!

!

!

gatekeeper

shutdown

!

!

!

banner motd ^CC

  * * * * * * * * * * * * * * Warning * * * * * * * * * * * * * *

  *  This system is restricted to authorized users for business *

  *  purposes. Unauthorized access is a violation of the law.   *

  *  This system may be monitored for administrative and        *

  *  security reasons. By proceeding, you consent to this       *

  *  monitoring.                                                *

  * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

^C

!

line con 0

line aux 0

login local

transport input ssh

transport output ssh

line vty 0 4

exec-timeout 20 0

login local

transport input ssh

transport output ssh

line vty 5 15

exec-timeout 20 0

login local

transport input ssh

transport output ssh

!

scheduler allocate 20000 1000

end

*********************

I opened a tac case amd the engineer did a pcm trace and verified that the digits were being sent.  I just don't understand why right fax doesn't see it.

The voice-port is 0/2/3 and dial-peer is 2003.  This is the one that the Right Fax server is plugged into 

Green

MGCP controlled 2821 and FXS to RightFax?

Hi,

From what I can see calls from the PSTN for RIGHTFAX are determined by a last 4 digits of 3737.
This should then forward to voice-port 0/2/3 which should be a DID trunk not an FXS.
!
!
voice-port 0/2/3
timeouts ringing infinity
description Fax Test
caller-id enable
!
!
dial-peer voice 2003 pots
destination-pattern 3737
no digit-strip
port 0/2/3
forward-digits all
!


Caller-id is not supported on DID trunk.

Could you try adding this:-

!
voice-port 0/2/3
shut
no timeouts ringing infinity
description Fax Test
no caller-id enable
signal did wink-start
dial-type dtmf
no shut
!
!

Looking at google for RIGHT FAX it also states that you must have 3737 assigned to a user
http://www.scribd.com/doc/53713678/67/Appendix-B-Troubleshooting


Hope this helps
Regards
Alex

Regards, Alex. Please rate useful posts.
537
Views
0
Helpful
5
Replies
CreatePlease to create content