Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

MGCP FXO port unregistered in CCM

Hi, all,

I am new to Cisco VoIP, I am trying to set up a SRST router in remote office. The router is a 2801, it has 4 FXO ports on it. I configured MGCP and pointed MGCP call-agent to HQ CCM. "sh ccm-manager" on router shows that it is registered with CCM, but on CCM, the FXO port status is "unregistered" although 2801's IP address is recognized correctly. When I configured the rest 3 FXO ports, both registration and IP appear in CCM as as unknown/unknow for all 3 analog end points.

What could be wrong? what debug should I turn on? thanks a lot ...

Jian

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: MGCP FXO port unregistered in CCM

Yes y ou should see those auto-generated dial peers 999000, 999001, 999002, and 999003. If you are not, then there is definitely a problem. I have had issues where I had to manually configure those same dial peers and the ports magically registered. Try it and see.

ex:

dial-peer voice 999000 pots

service mgcpapp

port 0/0/0

Hope that helped, if so please rate.

Re: MGCP FXO port unregistered in CCM

Sometimes we see this when the TFTP service isn't acting correctly. It's worth a try to restart the TFTP service if you want to see the auto-config take effect.

It's possible that the auto config would change some of the mgcp parameters and change the registration status, but it's kind of along shot.

20 REPLIES
Cisco Employee

Re: MGCP FXO port unregistered in CCM

do you have the dial-peers configured with application mgcpapp??

HTH

java

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
Community Member

Re: MGCP FXO port unregistered in CCM

Yes, I do ...

Re: MGCP FXO port unregistered in CCM

'show ccm' only shows if the *Router* is registered. 'show mgcp endpoints' shows our known endpoints.

If the router is registered that means your hostname/domain matches the entry in CUCM. That is good.

You probably don't have a dial-peer with the port and service mgcpapp on it.

Or, you have incorrectly put the cards in the wrong ports in CUCM when entering endpoint information.

Community Member

Re: MGCP FXO port unregistered in CCM

Thank you for your time, the running configuration is attached. On CUCM, I chose 4 port FXO in slot 0.

c2801# sh mgcp endpoint

aaln/S0/SU0/0@c2801

aaln/S0/SU0/1@c2801

aaln/S0/SU0/2@c2801

aaln/S0/SU0/3@c2801

Re: MGCP FXO port unregistered in CCM

get 'debug mgcp packet', do a 'no mgcp' 'mgcp', see what types of messages we send.

If we send endpoint not available:

Probably want to check 'show voice port summary' 'show voice call summary' and 'show dial-peer voice summary' to make sure that those ports are in the UP state.

Community Member

Re: MGCP FXO port unregistered in CCM

c2801#sh voice port summary

IN OUT

PORT CH SIG-TYPE ADMIN OPER STATUS STATUS EC

============== == ============ ===== ==== ======== ======== ==

0/0/0 -- fxo-ls up dorm idle on-hook y

0/0/1 -- fxo-ls up dorm idle on-hook y

0/0/2 -- fxo-ls up dorm idle on-hook y

0/0/3 -- fxo-ls up dorm idle on-hook y

50/0/1 1 efxs up up on-hook idle y

50/0/2 1 efxs up up on-hook idle y

50/0/3 1 efxs up up on-hook idle y

c2801#sh voice call sum

PORT CODEC VAD VTSP STATE VPM STATE

============== ========= === ==================== ======================

0/0/0 - - - FXOLS_ONHOOK

0/0/1 - - - FXOLS_ONHOOK

0/0/2 - - - FXOLS_ONHOOK

0/0/3 - - - FXOLS_ONHOOK

50/0/1 .1 - - - EFXS_INIT

50/0/2 .1 - - - EFXS_INIT

c2801#sh dial-peer voice sum

dial-peer hunt 0

AD PRE PASS OUT

TAG TYPE MIN OPER PREFIX DEST-PATTERN FER THRU SESS-TARGET STAT PORT

1 pots up down 91.......... 1 down

100 pots up up 0 down 0/0/0

101 pots up up 0 down 0/0/1

102 pots up up 0 down 0/0/2

103 pots up up 0 down 0/0/3

20001 pots up down 0 50/0/1

20002 pots up down 0 50/0/2

Re: MGCP FXO port unregistered in CCM

This appears to be normal.

Debugs look like all 4 ports register fine, from mgcp side.

Try taking any dial peers that have the ports defined that aren't the 999xxx mgcp dial peers off. Other than that, it may be an issue with CCM not showing the right status.

Cisco Employee

Re: MGCP FXO port unregistered in CCM

have you tried restarting RIS???

HTH

java

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
Community Member

Re: MGCP FXO port unregistered in CCM

Restarted, still no go ...

Community Member

Re: MGCP FXO port unregistered in CCM

Although sh mgcp endpoint shows 4 FXO ports, show mpcp connection does not show anything ...

Re: MGCP FXO port unregistered in CCM

'show mgcp connection' will show active voice calls. If there aren't active voice calls this isn't a problem.

It looks like the usual suspects have been mostly eliminated. You can try removing the gateway completely and adding it back. You could try restarting the CCM service. You could reload the pub/sub even. If you don't want to go that far, you could try getting CCM traces and having TAC look at it. Maybe try a few test calls and see which side misbehaves when the call is made.

I don't see anything wrong with the gateway on this. It sees the right ports, it responds the correct way.

Re: MGCP FXO port unregistered in CCM

I had this problem once before, except I was seeing the port unregistered on the pub, but when I went to the sub, the very same port showed registered. I took this as some sort of replication problem between pub and sub, and just ended up rebooting the cluster. (I even ran dbhelper to no avail). After that, all was well and the port showed registered on both pub and sub.

Hope that helped, if so please rate.

Cisco Employee

Re: MGCP FXO port unregistered in CCM

have you tried a call????

once i also saw an issue, the status was not right but calls were OK (we ran debugs and confirmed it). there was some SDL issue and a cluster reboot cleared it

HTH

java

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
Community Member

Re: MGCP FXO port unregistered in CCM

I will try that again tomorrow, one thing I don't understand is that if my c2801 is talking to CUCM and end-points are registered with CUCM, am not I supposed to see auto-generated dial-peer voice 999000 pots configuration? but I don't see the configuration on the router.

6758
Views
30
Helpful
20
Replies
CreatePlease to create content