Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

MGCP <-> CCM <-> H323 Fax Server / Resource unavailable


We have a Cisco Fax Server, Captaris 9.3 installed. Connecting via H323

to a Cisco CCM Cluster 4.2(3). The CCM is connected via MGCP PRI to the


PSTN<->MGCP VGW E1/PRI <-> CCM 4.2(3) <-> Fax Server H323

If I call in from PSTN I can see resource unavailable on the Q931 Debug

of IOS. I could not test from inside currently, because we configured

remotely with no one onsite.

I receive this error after 3 rings. If I call out from Fax Server it

seems to be the same, the called FAX or phone rings, but after 3 rings

the Fax server says destination busy.

I have checked for codec mismatches, but could not find any error. Also

I have MTP, Transcoding and Conferencing configured. I will test

tomorrow without Media Resources, only to be sure.

Has anyone had this before?

Has anyone this setup running, if so could you please pass me the

running MGCP Config and the setup in the Fax Server.

Many Thanks and all the best.

New Member

Re: MGCP <-> CCM <-> H323 Fax Server / Resource unavailable

We would need to see detailed traces from CallManager of the call setup to know for sure, but here are a couple of suggestions.

It could be an issue with mismatched fax protocols such as T.38 vs Fax Relay vs Fax Passthrough.

You might also check that the CSS is correct for the MGCP GW to be able to call the Faxserver and for the Fax server to place outbound calls.

If you can let us know what version of IOS is on the gateway and the existing MGCP configuration that will also help.

Detailed CCM traces woudl be a good place to start. Please include a date/time and the calling/called number of the failed fax call.

New Member

Re: MGCP <-> CCM <-> H323 Fax Server / Resource unavailable


fax sending is now working I have changed the gateway protocol from MGCP to H323.

The gateway is now diverting directly to the fax server. Nevertheless the Fax server is not answering calls. I can see them in the Fax Board. There is shown answering on the fax server, but nothing happens.

Later I see unallocated number on ISDN.


I have attached the debug from IOS and from Fax server.

New Member

Re: MGCP <-> CCM <-> H323 Fax Server / Resource unavailable

Unallocated number would indicate to me that the fax server is not configured to answer calls to 6445. Usually unallocated number is returned immediately. In this case, it seems to take 30 seconds. Its hard to coorelate the debugs because the timestamps are off, but both sides seem to indicate a 30 second delay while the line is ringing. -- almost like the Fax server is choosing not to answer calls to 6445.

I am not really experienced with the fax server, so I will see if someone else chimes in here.

New Member

Re: MGCP <-> CCM <-> H323 Fax Server / Resource unavailable


with the help of Captaris we solved the problem you need to configure under h323 settings. Slow start or fast start and h323_h245tunneling to 1.

That solved it.