Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

MGCP QSIG Issue after upgrade from CUCM 7.0 to 7.1(2b)

We currently have a H323 3845 ISR gateway with a MGCP QSIG interface connected to an Ericsson MD110.

When we were running CUCM 7.0 we had calling and called name presentation between both systems however since upgrading to CUCM 7.1(2b) we are not receiving the alerting/called name when CUCM calls Ericsson. However once the call is connected it is then presented. Ericsson to CUCM works fine.

The QSIG Variant in the Service Parametres is set to ISO and using ASN.1 ROSE OID of Local Value which is  now also set on the interface of the gateway since CUCM 7.1.

anyone got any ideas on why its behaving like this??

Any suggestions will be appreciated.

Cheers,

4 REPLIES
Hall of Fame Super Red

Re: MGCP QSIG Issue after upgrade from CUCM 7.0 to 7.1(2b)

Hi Ray,

You may be seeing this bug;

CSCtc68166 Bug Details Bug #16 of 31 | < Previous | Next >

ASN.1 ROSE OID Encoding and Calling Name in setup msg using PRI QSIG.
Symptom:

Outbound calls over QSIG gateway fail
or
supplementary services like calling name, connected name, callback etc.. fail

Conditions:

CUCM 7.X and higher

QSIG configuration :
Serviceparameter - QSIG variant = ECMA
Serviceparameter - ASN.1 ROSE OID Encoding  = ECMA (GLOBAL)

Gateway - QSIG Variant = No Changes
Gateway - ASN.1 ROSE OID Encoding  = No Changes

Workaround:

Configure on gateway

Gateway - QSIG Variant = ECMA
Gateway - ASN.1 ROSE OID Encoding  = ECMA (GLOBAL)

Further Problem Description:

With the configuration documented under conditions, CUCM will encode the Facility/Rose Invoke as ECMA / Local while it is expected to be ECMA / Global. (as configured on the remote PBX)
Depending on the remote PBX configuration/type the call will get released or Rose Invoke will get rejected.
Status
Fixed             

Severity        
3 - moderate


Last Modified
In Last Year        

Product
Cisco Unified Communications Manager (CallManager)         

Technology


1st Found-In
8.0(0.99091.11)       
           
Fixed-In
8.0(0.98000.68)
7.1(3.21900.2)
7.1(2.32020.1)
7.1(3.21005.1)
7.1(4.98000.60)
8.0(1.10000.40)

Cheers!

Rob

Please support CSC Helps Haiti

https://supportforums.cisco.com/docs/DOC-8895

https://supportforums.cisco.com/docs/DOC-8727

New Member

Re: MGCP QSIG Issue after upgrade from CUCM 7.0 to 7.1(2b)

Thanks for the reply Rob.

The bug does seem some what relivant to the issue however we're using the following:


QSIG configuration :
Serviceparameter - QSIG variant = ISO
Serviceparameter - ASN.1 ROSE OID Encoding  = Use Local Value

Gateway - QSIG Variant = No Changes (also tried ISO and ECMA)
Gateway - ASN.1 ROSE OID Encoding  = No Changes (also tried Global ISO, Global ECMA & Local)

But still having issues.

We're looking to upgrade this weekend to 7.1(3b)SU2 and Im hoping that this will fix the issue.

The bug doesn't state if 7.1(3b)SU2 fixes this issue however Im unable to find any of the 7.1(3) versions stated in the Dowlloads.

Cheers,
Ray

Hall of Fame Super Red

Re: MGCP QSIG Issue after upgrade from CUCM 7.0 to 7.1(2b)

Hi Ray,

I would open a TAC case to get the proper "Fixed-In" version which is

almost certainly an ES. They should be able to set this up for you

as a special download file We just ran into a problem recently where the fix

to a problem we were having was NOT in any available downloadable version.

Cheers!

Rob

New Member

Re: MGCP QSIG Issue after upgrade from CUCM 7.0 to 7.1(2b)

Hi Rob,

Just spoke to TAC, they've pointed me to version 7.1(3a)SU1 aka (7.1.3.21900-4) as the work around fix.

I'll be performing the update this evening so I've got my fingers crossed.

Thanks again for help Rob.

Cheers,
Ray

1536
Views
0
Helpful
4
Replies
CreatePlease to create content