Cisco Support Community
Community Member

mgcp qsig trunk calling name display problem

its a cucm 8.6 with 2911 acting as gateway to nortel option61c.  its mgcp based QSIG.  regular call dialing between the system works fine. however, call display from cisco to pbx is not working.  i do not see the cucm sending this information to the 2911 gw at all.  PBX->cisco call display works fine.. also the alerting names both way works fine.

it is just dialing from cisco phone to pbx phone does not display the name nor the gateway shows the name.

this is waht i have under the serial interface.

interface Serial0/0/1:23

no ip address

encapsulation hdlc

isdn switch-type primary-qsig

isdn incoming-voice voice

isdn supp-service name calling profile Network-Extension operation-value-tag local

isdn bind-l3 ccm-manager

isdn send-alerting

isdn sending-complete

isdn outgoing ie progress-indicator

isdn outgoing display-ie

isdn outgoing ie user-user

no cdp enable

this is an mgcp gw and the above mention commands not really going to help. although i tried it.

also got these commands with no luck.

voice service voip

qsig decode

cucm gateway is configured for mgcp with the followings:

PRI protocol type:PRI ISO QSIG T1
qsig varient:no changes
ASN.1 ROSE OID Encoding:no changes

i did tweek the above mentioned values around to do more testing however i couldnt get the callign name to go on the gw at least.

display IE displayed: greyed out
redirect number IE delivery-outbound:checked
redirect number IE delivery-inbound:checked

voice service voip
qsig decode

any feedback /suggestion is appriciated.




mgcp qsig trunk calling name display problem


As you stated the commands are mostly ignored whent the PRI/QSIG is backhauled to MGCP.

Can you post the debug isdn q931 of a call



Regards, Alex. Please rate useful posts.
Community Member

mgcp qsig trunk calling name display problem

Please,put here Screen of your CCM PRI port configuration.

Re: mgcp qsig trunk calling name display problem

hi Vijay,

Can you check the following first?

In Cisco Call Manager Service Parameters , choose Advanced Button at top of window.

Clusterwide Parameters—Device - PRI and MGCP Gateway

    * ASN.1 ROSE OID Encoding—Is it Use Local Value, Use Global Value (ISO) or Use Global Value (ECMA)?

    * Q.SIG Variant—Is it ECMA or ISO?

These two parameters need to match the configuration on the PBXs. These are clusterwide parameters, therefore all PBX trunks must be configured the same as Cisco CallManager.

Hope the above helps!



Hall of Fame Super Gold

mgcp qsig trunk calling name display problem

For each DN, have you filled the "display name" field ?

Community Member

mgcp qsig trunk calling name display problem

thanks for all your help guys.

i have fixed this problem.  i was doing a bug scrup and came up with this bug CSCsr03923

CLID not sent in QSIG call
Calling out of a qsig link does not include a facility message containing clid

Qsig link to pbx on ccm 6.1.2
Call through a Route List containing at least one QSIG enabled device.
The QSIG device must have been added to a Route Group after the Route Group and Route List were created as non-QSIG.

Check the Route List's Q.SIG setting in the database by running the following at the CLI:
< cmd>run sql select tkqsig from device where name = ''< /cmd>
substituting the Route List name (case sensitive) for
If the value for tkqsig is 1 or 2, this is not the correct defect.
If the value for tkqsig is 4, and the Route List has a QSIG device then the database is out of sync.

Add another routelist and use that instead, or remove a route group and add it back.

Further Problem Description:

The QSIG setting setting on a Route List is determined by the combination of devices in its Route Groups. It appears that Route Lists that contain no QSIG devices are not updated correctly when a QSIG device is added to one of the existing Route Groups in the Route List. Changing the content of the Route List forces the QSIG value to be recalculated and corrected.

eventhough it says hte bug has been fixed in cucm ver 7, i tried the workaround, which is to delete and readd route group and list and it worked fine.

thanks again.


CreatePlease to create content