Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

MGCP Registration Issue

hi guys,

i am getting strange problem while registering MGCP gateway with CCM 6.0 ... after configuring MGCP whn i try show ccm on gateway it showing me registered or Gateway in CCM it is showing unregistered ... after finishing the configuration on mgcp i did no mgcp and then mgcp so i got below errors "

NCBC-GW(config)#

*Mar 16 15:21:54.807: //-1/xxxxxxxxxxxx/MGCP/mgcp_check_hostname(8677):[lvl=0]Trying to validate endpoint name

*Mar 16 15:21:54.807: //-1/xxxxxxxxxxxx/MGCP/mgcp_check_hostname(8677):[lvl=0]Trying to validate endpoint name"

on CCM my endpoints are configured as NCBC-GW.ncbc.local (on GW ip domain name is ncbc.local)

if i type sh mgcp end points on gw

NCBC-GW#show mgcp endpoint

Interface E1 2/0

ENDPOINT-NAME V-PORT SIG-TYPE ADMIN

S2/ds1-0/1@NCBC-GW

S2/ds1-0/2@NCBC-GW

S2/ds1-0/3@NCBC-GW

S2/ds1-0/4@NCBC-GW

S2/ds1-0/5@NCBC-GW

S2/ds1-0/6@NCBC-GW

S2/ds1-0/7@NCBC-GW

S2/ds1-0/8@NCBC-GW

S2/ds1-0/9@NCBC-GW

S2/ds1-0/10@NCBC-GW

S2/ds1-0/11@NCBC-GW

S2/ds1-0/12@NCBC-GW

S2/ds1-0/13@NCBC-GW

S2/ds1-0/14@NCBC-GW

S2/ds1-0/15@NCBC-GW

S2/ds1-0/17@NCBC-GW

S2/ds1-0/18@NCBC-GW

S2/ds1-0/19@NCBC-GW

S2/ds1-0/20@NCBC-GW

--More-- S2/ds1-0/21@NCBC-GW

--More-- S2/ds1-0/22@NCBC-GW

--More-- S2/ds1-0/23@NCBC-GW

--More-- S2/ds1-0/24@NCBC-GW

S2/ds1-0/25@NCBC-GW

S2/ds1-0/26@NCBC-GW

S2/ds1-0/27@NCBC-GW

S2/ds1-0/28@NCBC-GW

S2/ds1-0/29@NCBC-GW

S2/ds1-0/30@NCBC-GW

S2/ds1-0/31@NCBC-GW

Interface E1 2/1

ENDPOINT-NAME V-PORT SIG-TYPE ADMIN

aaln/S0/SU2/0@NCBC-GW

NCBC-GW#

NCBC-GW# and my mgcp config is

ccm-manager fallback-mgcp

ccm-manager redundant-host 10.32.64.3

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.32.64.2

ccm-manager config mgcp

mgcp call-agent 10.32.64.2 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp validate domain-name

mgcp validate call-agent source-ipaddr

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface GigabitEthernet0/1

mgcp bind media source-interface GigabitEthernet0/1

mgcp rtp payload-type clear-channel static

!

mgcp profile default

can any one help me urgently plz

9 REPLIES
Hall of Fame Super Red

Re: MGCP Registration Issue

Hi Nasry,

You mentioned the "endpoints" in CCM but what about the Gateway itself? Is it set for NCBC-GW.ncbc.local?

The Domain name issue is outlined nicely in this doc;

MGCP Gateway Registration Failure with Cisco CallManager

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a00805a316c.shtml#prob

If the IP domain name is configured in Cisco IOS on the MGCP gateway, enter the Fully Qualified Domain Name (FQDN) in the Domain Name field.

In the example: test and cisco.com represent the hostname and domain name respectively. If the IP domain name is not configured in Cisco IOS on the MGCP gateway, enter only the hostname of the MGCP gateway in the Domain Name field.

You would enter test.cisco.com (in CCM)

Hope this helps!

Rob

Re: MGCP Registration Issue

can you post the rest of your router config?

Thanks

Re: MGCP Registration Issue

Hi Nasry,

This may be very simple:

Make sure that 'sh ccm | i Name' matches what you've defined for the gateway.

Make sure that the physical layer of your PRI is up.

'show voice port summary' shouldn't show any bad states (very little if it's working right).

Some other random things:

no ip classless

if you're on a LI image: no mgcp lawful

hth,

nick

Re: MGCP Registration Issue

Guys thank you so much for reply so fastly .... really appreciated ....

i think there is some problem in my network module ... i am using 3845 router and my module is NM-CE1T1-PRI ... if im doing show voice port summary .. i am not able to see voice port ..even in sh run my voice-port 2/0:15 is not there you can see.. more over on GW its showing that NCBC-GW.ncbc.local is registered with CCM but CCM is showing only ip of GW but status is unregistered ...

more over while adding GW in CCM i didnt find any module with the same name which i have .. in CCM only WICS or VWICS card are available but the one which i have (NM-CE1T1-PRI) is not there ,so i think i m selecting wrong NM .. how we can sure that i m selecting right NM or wrong NM ??? well my router config is

NCBC-GW#

NCBC-GW#sh run

Building configuration...

Current configuration : 6707 bytes

!

hostname NCBC-GW

!

card type e1 2

!

ip domain name ncbc.local

!

isdn switch-type primary-4ess

voice-card 0

no dspfarm

!

controller E1 2/0

pri-group timeslots 1-31 service mgcp

!

controller E1 2/1

!

interface GigabitEthernet0/0

ip address 10.10.10.1 255.255.255.248

shutdown

!

interface GigabitEthernet0/1

ip address 10.32.64.5 255.255.255.0

duplex auto

speed auto

media-type rj45

!

!

interface Serial2/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-4ess

isdn bchan-number-order ascending

no cdp enable

!

interface Vlan1

no ip address

!

control-plane

!

voice-port 0/2/0

!

voice-port 0/2/1

!

voice-port 0/2/2

!

voice-port 0/2/3

!

voice-port 0/3/0

!

voice-port 0/3/1

!

voice-port 0/3/2

!

voice-port 0/3/3

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/0/2

!

voice-port 1/0/3

!

voice-port 1/0/4

!

voice-port 1/0/5

!

voice-port 1/0/6

!

voice-port 1/0/7

!

ccm-manager fallback-mgcp

ccm-manager redundant-host 10.32.64.3

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.32.64.2

ccm-manager config

mgcp

mgcp call-agent 10.32.64.2 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp validate domain-name

mgcp validate call-agent source-ipaddr

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface GigabitEthernet0/1

mgcp bind media source-interface GigabitEthernet0/1

mgcp rtp payload-type clear-channel static

!

mgcp profile default

!

end

below is show voice port sumary

NCBC-GW#sh voice port summary

IN OUT

PORT CH SIG-TYPE ADMIN OPER STATUS STATUS EC

============== == ============ ===== ==== ======== ======== ==

0/2/0 -- fxs-ls up dorm on-hook idle y

0/2/1 -- fxs-ls up dorm on-hook idle y

0/2/2 -- fxs-ls up dorm on-hook idle y

0/2/3 -- fxs-ls up dorm on-hook idle y

0/3/0 -- fxo-ls up dorm idle on-hook y

0/3/1 -- fxo-ls up dorm idle on-hook y

0/3/2 -- fxo-ls up dorm idle on-hook y

0/3/3 -- fxo-ls up dorm idle on-hook y

1/0/0 -- fxs-ls up dorm on-hook idle y

1/0/1 -- fxs-ls up dorm on-hook idle y

1/0/2 -- fxs-ls up dorm on-hook idle y

1/0/3 -- fxs-ls up dorm on-hook idle y

1/0/4 -- fxs-ls up dorm on-hook idle y

1/0/5 -- fxs-ls up dorm on-hook idle y

1/0/6 -- fxs-ls up dorm on-hook idle y

1/0/7 -- fxs-ls up dorm on-hook idle y

NCBC-GW#

Thanks in Advance

Regards

New Member

Re: MGCP Registration Issue

Hi Nasry,

I don't see any isdn l3-bind ccm-manager command on the Serial 2/0:15 interface. If you manually configured this mgcp configuration then you may have missed the layer 3 back hauling necessary to bind the layer3 q.931 messages back to CCM. The interface will never come up without the bind statement and thus will not show registered

New Member

Re: MGCP Registration Issue

Hi Nasry, I also read somewhere that binding control and media messages only works to the loopback addresses for mgcp. I'll try and dig it out for you but it may be worth a try?

Re: MGCP Registration Issue

no, you can bind to eth or gig interface, loopback is not required.

I saw the L3 bind missing also in his config, but what is odd, is that T1 card he is using. Im not if its supported anymore.

Is this an old card you are re-purposing into a new router?

Re: MGCP Registration Issue

Ok fine .. you all are right that binding command i have missed to configure on Serial 2/0:15 .... i will try it out by today and will come back to you guys ...

Thanks

Regards

Re: MGCP Registration Issue

Hi all guys,

finally i sorted out the problem, actually the problem was in module .. i changed module and register it ...it got registered in 2minutes .... and also before change the module i tried isdn binding command for CCM still with that it didnt work ...

Well thanks for all of you guys for your support and quick responce .. thanks alot for every one ...

Regards

1209
Views
0
Helpful
9
Replies
CreatePlease to create content