Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

MGCP SRST FXO Inbound Call Silence

I am testing SRST situations with 2901 routers, CUCM 9.1, with MGCP and H.323 fall back.There is no PRI, just Centrex lines at each location. Outbound calls work just fine. When inbound calls occur, the call connects but there is just silence. Normally all calls go to an AA. I have set up the voice-ports for connection plar to the internal non-did extension. The only DIDs in the district are the ones that forward to an AA, no DIDs are present on internal phones.

Here is the config, followed be a debug of ccapi inout

Current configuration : 7039 bytes

!

! Last configuration change at 02:19:08 EST Sun Jul 28 2013 by fiadmin

! NVRAM config last updated at 02:19:09 EST Sun Jul 28 2013 by fiadmin

! NVRAM config last updated at 02:19:09 EST Sun Jul 28 2013 by fiadmin

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname FHS-2901-VOICE

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

clock timezone EST -5 0

clock summer-time EST recurring

!

ip cef

!

!

!

!

!

!

no ip domain lookup

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

!

!

!

voice-card 0

!

!

!

!

!

!

!

!

!

!

!

application

global

  service alternate default

!

!

license udi pid CISCO2901/K9 sn FTX172182HV

hw-module pvdm 0/0

!

!

!

username fiadmin privilege 15 secret 4 ZF5KtxAZhTFJ0JRyoATt68n2mVpH3gfrq14eGxSQY8c

!

redundancy

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 10.25.1.254 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 10.25.1.1

!

access-list 2 permit 10.25.5.0 0.0.0.255

access-list 2 permit 10.25.15.0 0.0.0.255

access-list 2 permit 10.25.25.0 0.0.0.255

access-list 2 permit 10.25.35.0 0.0.0.255

access-list 2 permit 10.25.40.0 0.0.0.255

access-list 2 permit 172.18.20.0 0.0.0.255

!

!

!

control-plane

!

!

voice-port 0/0/0

timing hookflash-out 50

timing guard-out 1000

connection plar 5551014500

description 440-965-4255 FHS Pilot

caller-id enable

!

voice-port 0/0/1

timing hookflash-out 50

timing guard-out 1000

connection plar 5551014515

description 440-965-5351 FHS Hunt

caller-id enable

!

voice-port 0/0/2

timing hookflash-out 50

timing guard-out 1000

connection plar 5551014503

description 440-965-5335 FHS Hunt

caller-id enable

!

voice-port 0/0/3

timing hookflash-out 50

timing guard-out 1000

description NOT CURRENTLY IN USE

caller-id enable

!

voice-port 0/1/0

timing hookflash-out 50

timing guard-out 1000

connection plar 5551011010

description 440-965-5701 BOE Pilot

caller-id enable

!

voice-port 0/1/1

timing hookflash-out 50

timing guard-out 1000

connection plar 5551011020

description 440-965-5702 BOE Hunt

caller-id enable

!

voice-port 0/1/2

timing hookflash-out 50

timing guard-out 1000

connection plar 5551011010

description 440-965-5821 BOE Pilot

caller-id enable

!

voice-port 0/1/3

timing hookflash-out 50

timing guard-out 1000

connection plar 5551011010

description 440-965-8425 BOE Hunt

caller-id enable

!

voice-port 0/2/0

description FXS NOT IN USE

!

voice-port 0/2/1

description FXS NOT IN USE

!

voice-port 0/2/2

description FXS NOT IN USE

!

voice-port 0/2/3

description FXS NOT IN USE

!

!

!

!

ccm-manager redundant-host 10.25.1.216

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 10.25.1.216

ccm-manager config

!

mgcp

mgcp call-agent 10.25.1.217 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

!

mgcp profile default

!

!

dial-peer voice 999000 pots

service mgcpapp

port 0/0/0

!

dial-peer voice 999001 pots

service mgcpapp

port 0/0/1

!

dial-peer voice 999002 pots

service mgcpapp

port 0/0/2

!

dial-peer voice 999003 pots

service mgcpapp

port 0/0/3

!

dial-peer voice 999010 pots

service mgcpapp

port 0/1/0

!

dial-peer voice 999011 pots

service mgcpapp

port 0/1/1

!

dial-peer voice 999012 pots

service mgcpapp

port 0/1/2

!

dial-peer voice 999013 pots

service mgcpapp

port 0/1/3

!

dial-peer voice 9000 pots

service mgcpapp

destination-pattern 9T

incoming called-number .

port 0/0/0

forward-digits all

!

dial-peer voice 9001 pots

service mgcpapp

destination-pattern 9T

incoming called-number .

port 0/0/1

forward-digits all

!

dial-peer voice 9002 pots

destination-pattern 9T

incoming called-number .

port 0/0/2

forward-digits all

!

dial-peer voice 9003 pots

service mgcpapp

destination-pattern 9T

incoming called-number .

port 0/0/3

forward-digits all

!

dial-peer voice 9010 pots

preference 3

service mgcpapp

destination-pattern 9T

incoming called-number .

port 0/1/0

forward-digits all

!

dial-peer voice 9011 pots

preference 4

service mgcpapp

destination-pattern 9T

incoming called-number .

port 0/1/1

forward-digits all

!

dial-peer voice 9012 pots

preference 1

service mgcpapp

destination-pattern 9T

incoming called-number .

port 0/1/2

forward-digits all

!

dial-peer voice 9013 pots

preference 2

service mgcpapp

destination-pattern 9T

incoming called-number .

port 0/1/3

forward-digits all

!

dial-peer voice 9911000 pots

preference 2

service mgcpapp

destination-pattern 9911

port 0/0/0

forward-digits 3

!

dial-peer voice 9911001 pots

preference 3

service mgcpapp

destination-pattern 9911

port 0/0/1

forward-digits 3

!

dial-peer voice 9911002 pots

preference 1

destination-pattern 9911

port 0/0/2

forward-digits 3

!

dial-peer voice 9911003 pots

preference 4

destination-pattern 9911

port 0/0/3

forward-digits 3

!

dial-peer voice 9110000 pots

preference 2

destination-pattern 911

port 0/0/0

forward-digits all

!

dial-peer voice 9110001 pots

preference 3

destination-pattern 911

port 0/0/1

forward-digits all

!

dial-peer voice 9110002 pots

preference 1

destination-pattern 911

port 0/0/2

forward-digits all

!

dial-peer voice 9110003 pots

preference 4

destination-pattern 911

port 0/0/3

forward-digits all

!

!

!

!

!

num-exp 4... 5551014...

num-exp 3... 5551013...

num-exp 2... 5551012...

num-exp 1... 5551011...

!

!

gatekeeper

shutdown

!

!

call-manager-fallback

secondary-dialtone 9

max-conferences 8 gain -6

transfer-system full-consult

timeouts interdigit 3

ip source-address 10.25.1.254 port 2000

max-ephones 25

max-dn 50

!

!

banner motd ^C

--------------------------------WARNING---------------------------------

        This is a private and proprietary system. Unauthorized access

        is unlawful and may result in disciplinary action and/or legal

        proceedings. Any access to this system/network may be monitored.

--------------------------------WARNING---------------------------------

^C

!

line con 0

exec-timeout 30 0

logging synchronous

line aux 0

exec-timeout 30 0

logging synchronous

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

exec-timeout 30 0

privilege level 15

logging synchronous

login local

transport input ssh

!

scheduler allocate 20000 1000

ntp server 10.25.1.1

!

end

------------------------------------------------------------------------------------------DEBUG-------------------------------------------------------------------------------------------------------------------

Jul 28 05:50:21.551: //-1/6CC33C6C80E8/CCAPI/cc_api_display_ie_subfields:

   cc_api_call_setup_ind_common:

   cisco-username=

   ----- ccCallInfo IE subfields -----

   cisco-ani=

   cisco-anitype=0

   cisco-aniplan=0

   cisco-anipi=0

   cisco-anisi=0

   dest=5551014500

   cisco-desttype=0

   cisco-destplan=0

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-rdntype=0

   cisco-rdnplan=0

   cisco-rdnpi=0

   cisco-rdnsi=0

   cisco-redirectreason=0   fwd_final_type =0

   final_redirectNumber =

   hunt_group_timeout =0

Jul 28 05:50:21.555: //-1/6CC33C6C80E8/CCAPI/cc_api_call_setup_ind_common:

   Interface=0x3D4F3CA4, Call Info(

   Calling Number=,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),

   Called Number=5551014500(TON=Unknown, NPI=Unknown),

   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE,

   Incoming Dial-peer=999000, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), Calling IE Present=FALSE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1

Jul 28 05:50:21.555: //-1/6CC33C6C80E8/CCAPI/ccCheckClipClir:

   In: Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)

Jul 28 05:50:21.555: //-1/6CC33C6C80E8/CCAPI/ccCheckClipClir:

   Out: Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)

Jul 28 05:50:21.555: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Jul 28 05:50:21.555: :cc_get_feature_vsa malloc success

Jul 28 05:50:21.555: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Jul 28 05:50:21.555:  cc_get_feature_vsa count is 1

Jul 28 05:50:21.555: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Jul 28 05:50:21.555: :FEATURE_VSA attributes are: feature_name:0,feature_time:971323776,feature_id:99

Jul 28 05:50:21.555: //99/6CC33C6C80E8/CCAPI/cc_api_call_setup_ind_common:

   Set Up Event Sent;

   Call Info(Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),

   Called Number=5551014599(TON=Unknown, NPI=Unknown))

Jul 28 05:50:21.555: //99/6CC33C6C80E8/CCAPI/cc_process_call_setup_ind:

   Event=0x2255BBB0

Jul 28 05:50:21.555: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:

   Try with the demoted called number 5551014599

Jul 28 05:50:21.555: //99/6CC33C6C80E8/CCAPI/cc_process_call_setup_ind:

   >>>>CCAPI handed cid 99 with tag 999000 to app "MGCPAPP"

Jul 28 05:50:21.555: //99/6CC33C6C80E8/CCAPI/ccCallSetContext:

   Context=0x21CDA7D0

Jul 28 05:50:21.555: //99/6CC33C6C80E8/CCAPI/ccCallSetupAck:

   Call Id=99

FHS-2901-VOICE#

Jul 28 05:50:21.555: //99/6CC33C6C80E8/CCAPI/cc_api_set_transfer_info:

   Transfer Number=, Transfer Reason=0x0

Jul 28 05:50:21.555: //99/6CC33C6C80E8/CCAPI/ccCallConnect:

   Progress Indication=NULL(0), Data Bitmask=0x0

Jul 28 05:50:21.555: //99/6CC33C6C80E8/CCAPI/ccCallConnect:

   Call Entry(Connected=TRUE, Responsed=TRUE)

FHS-2901-VOICE#

Jul 28 05:50:48.564: //-1/xxxxxxxxxxxx/CCAPI/ccAppShutdownMode:

   remove it from the queue

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

MGCP SRST FXO Inbound Call Silence

Thanks for bringing up this topic.

Check this out:

https://supportforums.cisco.com/docs/DOC-27913

Hope it helps.

“If you have knowledge, let others light their candles in it.”
6 REPLIES
New Member

MGCP SRST FXO Inbound Call Silence

When I remove all dial-peers that relate to the voice-port where I put the PLAR command on, the inbound call works.

New Member

MGCP SRST FXO Inbound Call Silence

I am not sure whether you should use such long dial peer tags like "dial-peer voice 9110001 pots"

dial-peer voice 9111 can be used instead.

I have hear long dial-peer tags causing problems..

Let me know if i am wrong.

“If you have knowledge, let others light their candles in it.”
New Member

MGCP SRST FXO Inbound Call Silence

I noticed that when I have a dial-peer without the service mgcpapp command the inbound calls route just fine. What I tried doing is putting my SRST dial-peers after my mgcp dial-peers, but the problem now is that when the call managers are up, they are bypassing the mgcp dial-peers and are hitting the SRST ones.

When I do a show ccm-manager, it shows mgcp fallback mode not selected, even though I have that configured. Why aren't my dial-peers working when they should? Shouldn't the service mgcpapp command under the dial-peer only be valid when the call managers are up, and when they aren't, use H.323 (default)?

New Member

MGCP SRST FXO Inbound Call Silence

Thanks for bringing up this topic.

Check this out:

https://supportforums.cisco.com/docs/DOC-27913

Hope it helps.

“If you have knowledge, let others light their candles in it.”
New Member

MGCP SRST FXO Inbound Call Silence

Hey no problem. I did look at that page and tried following the advice that was given. It still didn't solve my issue. What did solve my issue were these commands:

RemoteSite# configure terminal

RemoteSite(config)# ccm-manager fallback-mgcp

RemoteSite(config)# application

RemoteSite(config - app)# global

RemoteSite(config - app -global)# service alternate default

RemoteSite(config - app -global)# end

The problem I was having was that I was trying to enter in the call-manager fallback-mgcp, which I referenced directly from the link below:

https://supportforums.cisco.com/docs/DOC-24097

That command kept giving me an error that the syntax was incorrect. I tried entering in the service application default commands under global config mode which also didn't do anything. Once I entered in the correct command and doing a show ccm-manager, "MGCP Fallback mode: Enabled/Off" displayed. I then created my SRST dial peers which do not have the service mgcpapp command and the inbound calls worked just fine. I then brought up my call managers and the inbound calls do not hit those SRST dial peers.

I do have several questions:

1. Am I doing it the correct way as far as having seperate dial peers that do not have the service mgcpapp command?

2. Also, I have the command incoming called-number . for each of my SRST dial peers. Is that command needed if I              specified the connection plar command under the voice-port?

3. Is it recommend to have seperate inbound and outbound dial peers for the same port?

Thanks for you help so far amansin74

New Member

Re: MGCP SRST FXO Inbound Call Silence

Hi Daniel,

 

Just checking if you have this issue.. What is the resolution for this??

1563
Views
3
Helpful
6
Replies
CreatePlease to create content