Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

MGCP, SRST, FXO

Hi, Friends

I already have read a lot of descussions about this problen in forum, but I've not find the decision.

I have CUCM 9.1.2 and a lot of MGCP gateways with SRST and FXO ports, in SRST mode I can make outbound calls just fine. But when I try to make inbound call from PSTN on my FXO, I hear 'busy tone'. I use c2900-universalk9-mz.SPA.153-3.M.bin IOS on my routers.

Part of configuration:

application
 global
  service alternate Default
!
voice-port 0/0/0
 trunk-group FXO-Ports
 cptone RU
 timing hookflash-out 50
 timing guard-out 1000
 connection plar 164010
 caller-id enable
!
voice-port 0/0/1
 trunk-group FXO-Ports
 cptone RU
 timing hookflash-out 50
 timing guard-out 1000
 connection plar 164001
 caller-id enable
!
voice-port 0/0/2
 cptone RU
 timing hookflash-out 50
 timing guard-out 1000
 connection plar 164004
 caller-id enable
!
ccm-manager fallback-mgcp
ccm-manager redundant-host 192.168.103.37
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 192.168.103.36  
ccm-manager config
!
mgcp
mgcp call-agent 10.0.32.3 2427 service-type mgcp version 0.1
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp bind control source-interface GigabitEthernet0/1.20
mgcp bind media source-interface GigabitEthernet0/1.20
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/1.20
!
dial-peer voice 999001 pots
 service mgcpapp
 port 0/0/1
!
dial-peer voice 999002 pots
 service mgcpapp
 port 0/0/2
!
dial-peer voice 999000 pots
 service mgcpapp
 port 0/0/0
!
call-manager-fallback
 secondary-dialtone 9
 max-conferences 8 gain -6
 transfer-system full-consult
 user-locale RU
 timeouts interdigit 15
 timeouts ringing 40
 ip source-address 10.5.164.124 port 2000
 max-ephones 15
 max-dn 60 dual-line
 system message primary SRST
 system message secondary SRST
 no huntstop
 time-format 24
 date-format dd-mm-yy

I have the same problem like the person in this topic https://supportforums.cisco.com/discussion/11884511/mgcp-srst-fxo-inbound-call-silence

Can you give any advice

Thank you

2 REPLIES

Could you share your dial

Could you share your dial-peers that are configured on the gateway? Do you have an incoming pots dial-peer with direct-inward-dial configured on it? Also, do you have 1640XX configured on a phone or do you need translation patterns to complete the PLAR calls?

Please rate useful posts.
New Member

Hi, I've already solved the

Hi, I've already solved the problem. Configuration was correct. I checked SRST mode working by access list and this list was incorrect. Now everything is working fine.

Thank you everybody.

 

141
Views
0
Helpful
2
Replies
CreatePlease to create content