Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Modem not working on an analog port after voice gateway upgrade

We have a Pitney Bowes mail machine that connects via a modem to a location to load mail data. It has worked fine for years on an analog port using a VG248 and CallManager 6.1   About 3 weeks ago we upgraded our voice gateways to use Cisco 2911 devices and since then the mail modem doesn't seem to work. It works fine on a POTS line but when we try to use it on the Analog port, the modem dials and sounds like it's trying to connect but never does. Voice calls work fine on this port.


Any ideas on where to look?

Thanks

4 REPLIES
Cisco Employee

Re: Modem not working on an analog port after voice gateway upgr

What is the topology of the call?

Is the FXS gateway of the machine the same device with the PSTN connection?

What type of PSTN connection do you have?

Can you post your configuration from each device?

The short answer is that you need modem-passthrough configured on each device.  That's an NSE based switchover, so it needs to be between two Cisco gateways.  And modem-passthrough officially supports speeds up to 33.6 (v.34), so make sure the modems don't negotiate anything faster (v.90/v.92).

It may be worth noting that I think Pitney Bowes makes postage meters which can integrate via IP, for what it's worth.  Why go digital>analog>digital>analog>digital when you can keep it digital all the way through? :-P

Silver

Re: Modem not working on an analog port after voice gateway upgr

Hi Jim,

What protocol are you now using for controlling the voice port?  If it is H323 you want to make sure that you configure for G.711 since G.729 is the default.

Oh yeah  - no vad and disable echo cancellation too...

HTH,

Art

Message was edited by: asandborgh

Cisco Employee

Re: Modem not working on an analog port after voice gateway upgr

Codec configuration on the dialpeer won't matter, since we need to go to modempass for the modem communication anyway (we do special things to the DSP jitter buffer for modem communication), so a g729 voice call will still upspeed to g711 when the ANSam is detected.  That will trigger a NSE 192 and (if there is phase reversal in the ANSam) a 193 to the other side to also switch to g711.

Silver

Re: Modem not working on an analog port after voice gateway upgr

If you are running MGCP (ugh) see the following string:

https://supportforums.cisco.com/message/1330179

1176
Views
5
Helpful
4
Replies
CreatePlease to create content