Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

MOH not working CME 9.5 for PSTN

Have the following configuration:

Cisco 2921 Router with SRE-710 running CME 9.5

No calls are working when using the MOH file that we had been using on a 2821 with CME 8.6 with no problems

 

Have following commands in place

voice-port 0/0/0:23
 local-alerting
 timeouts interdigit 3
 !
 !
 !
!
ccm-manager music-on-hold


telephony-service

 

moh "flash0:/butler5.au"
 multicast moh 239.1.1.1 port 16384 

 

phones have multicast moh enabled and default code for ephone is g722-64

 

Is it possible this is getting tied up by my switches (Cisco 2960S)?

 

All calls are getting tone on hold.

 

 

 

 

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

The link below should help

The link below should help you out.

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/admin/configuration/guide/cmeadm/cmemoh.html

Regards,

Yosh

HTH Regards, Yosh
15 REPLIES
Bronze

 Hi, Check answer in this

 

Hi,

 

Check answer in this post, might be of help.

https://supportforums.cisco.com/discussion/11421511/cant-hear-moh-pstn-help

hikindly find the below:-1

hi

kindly find the below:-

1-multicast moh 239.1.1.1 port 16384 route x.x.x.x y.y.y.y  where x.x.x.x the ip address of a loopback address and y.y.y.y the ip address of your voice vlan ip address.

2- can you test the MOH internally between two internal extensions .

3-Add the following under telephony-service

multicast-moh

4-Test without  " . use the below

moh flash0:butler5.au

5- yes , 2960 support IGMP and it is enabled by default.

6- Final thing , you have to do it , if nothing work from above. enable ip pim dense-mode under voice vlan interface and loopback

 

Thanks

please rate all useful information

Made the changes and still

Made the changes and still have the tone on hold, below is config changes:

 

interface Loopback10
 ip address 192.168.117.1 255.255.255.0
 ip pim dense-mode
 ip nat inside
 ip virtual-reassembly in
!
interface Tunnel1
 no ip address
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description -LAN-SW-LAUNCH-INFO-GE 0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.1
!
interface GigabitEthernet0/0.10
!
interface GigabitEthernet0/0.20
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.1
 description Management
 encapsulation dot1Q 1 native
 ip address 172.20.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/1.10
 description Data
 encapsulation dot1Q 10
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/1.20
 description Voice
 encapsulation dot1Q 20
 ip address 172.20.10.1 255.255.255.0
 ip pim dense-mode
 ip nat inside
 ip virtual-reassembly in
 ip policy route-map policymap
!
interface GigabitEthernet0/2
 ip address 
 ip nat outside
 ip inspect firewall out
 ip virtual-reassembly in
 duplex auto
 speed auto
 crypto map CMAP_1
!
interface Serial0/0/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bchan-number-order ascending
 no isdn outgoing ie redirecting-number
 no cdp enable
!
interface SM1/0
 ip unnumbered GigabitEthernet0/1.20
 service-module ip address 172.20.10.2 255.255.255.0
 !Application: CUE Running on SM
 service-module ip default-gateway 172.20.10.1
!
interface SM1/1
 description Internal switch interface connected to Service Module
 no ip address
!
interface Vlan1
 no ip address
!
interface Vif1
 ip address 192.168.6.1 255.255.255.0
 ip pim sparse-dense-mode

 

Here is telephony service:

moh flash0:butler5.au
multicast moh 239.1.1.1 port 16384  route 192.168.117.1  172.20.10.1

 

 

One thing I forgot to mention is that MOH works fine when call is parked but not when put on hold.  

 

Thank you

hello1)can you add the below:

hello

1)can you add the below:-

router(config)#ip multticast-routing

and enable  ip pim sparse-dense mode instead of dense mode under voice and loopback interface.

 

Thanks

please rate all useful information

ip multicast-routing was

ip multicast-routing was already enabled

 

The sparse-dense mode did not work

 

I have attached the primary config. thank you again

+5 Islam for the good

+5 Islam for the good information.

I just want to add a few things.

1 - You need to type the following command "ccm-manager music-on-hold"

2 - You don't need to turn on "ip multicast-routing" and definitely don't turn on "ip pim dense-mode". If you wanted to use "pim" use "sparse-mode". The reason you don't need to turn on "ip-multicast" is because you are already routing the traffic to the specific networks "multicast moh 239.1.1.1 port 16384  route 192.168.117.1  172.20.10.1"

3 - Also do a"show ip mroute" to make sure that you're using the correct "IP multicast address'. Remember that Cisoc IOS routers MOH only uses G711ulaw.

HTH

Regards,

Yosh

 

HTH Regards, Yosh

Here is ip mroute info

Here is ip mroute info

 

BEC2921#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 5d19h/00:02:06, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse-Dense, 5d19h/stopped

That's my bad, I meant to say

That's my bad, I meant to say run a "show ip mroute" while you are on hold and only if you kept the "ip multicast-routing" on. As a side note, try changing the codec on your phone to G711ulaw and place a call between the phones, to verify that MOH is working. If it's not working make sure that the location of the MOH file is correct.

Regards,

Yosh

HTH Regards, Yosh

I thought that MOH is not

I thought that MOH is not used when internal phones are placed on hold, commands with phone on hold:

 

Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 5d19h/00:02:57, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse-Dense, 5d19h/stopped

 

 

BEC2921#dir flash0:/
Directory of flash0:/


  314  -rw-      185180   Jun 6 2013 20:34:48 -04:00  butler5.au

 

 

 

The link below should help

The link below should help you out.

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/admin/configuration/guide/cmeadm/cmemoh.html

Regards,

Yosh

HTH Regards, Yosh

The solution was that the

The solution was that the G722-64 codec needed to be added to the dsp farm.  Make sure you shutdown the dspfarm first to add the codec.  Thank you again for all your help.

hi1-+5 for yosh as usual for

hi

1-+5 for yosh as usual for his great explanation. I need to add something for multicast-routing we use this command to allow transfer multicast packets between routers , l3 devices  , host (source) to send packets to a group of hosts (receivers) anywhere within the IP network by using a special form of IP address called the IP multicast group address and to allow pim protocol work properly  under interfaces. As you mentioned if i define a static multicast and define source , group and we have only one cme , ip multicast-routing enable or disable won't affect .

2-can you replace ccm-manager music-on-hold  to ccm-manager music-on-hold bind "voice vlan interface"

 

3- do "debug ccm-manager music-on-hold" and catch logs

 

Thanks

please rate all useful information

Can you share with us 

router#show ccm-manager music-on-hold

So I have gotten internal moh

So I have gotten internal moh calls working using an moh-group.  I still do not have pstn calls working and just get tone on-hold for the pstn calls. When on hold I do not get any logs from ccm-manager and current active multicast sessions are 0.

So I have gotten internal moh

So I have gotten internal moh calls working using an moh-group.  I still do not have pstn calls working and just get tone on-hold for the pstn calls. When on hold I do not get any logs from ccm-manager and current active multicast sessions are 0.

The solution was that the

The solution was that the G722-64 codec needed to be added to the dsp farm.  Make sure you shutdown the dspfarm first to add the codec.  Thank you again for all your help.

409
Views
15
Helpful
15
Replies
CreatePlease to create content