Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

MoH Not Works.

Hello MoH not works. I have collect logs from RTMP and faced the logs which was listed below. What is your advice about this problem.

When click hold(nothing heared). There is problem in ip phone to ip phone or pstn to ip phone.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

MoH Not Works.

The MOH files are not replicated and it doesn't matter that they register to the SUB1.

You need to upload the MOH file to ALL the MOH servers manually.

HTH

java

If this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
7 REPLIES
New Member

MoH Not Works.

Hello Log file;

23:24:16.874 HDR|07/04/2011 VoiceStrm,IST-IPTCM-1-Cluster,172.x.x.x,Error,8.5.1.11900-21

23:24:16.874 |   PITrace: *ERROR* [CRITIAL INFO]: platform install api isDeployedStandalone()= true

23:24:16.874 |   PITrace: *ERROR* [CRITIAL INFO]: platform install api prods[0]=CallManager

23:24:16.874 |   PITrace: *ERROR* [CRITIAL INFO]: Platform Box Configuration :0 (CCM:0,UNITY:1,CoRes:2,Unknown:3)

23:24:16.875 |   PITrace: *ERROR* Important info only, Category[DBMon]: productid_enable_flag=1, system_enable_flag=1

23:24:16.875 |   PITrace: *ERROR* Important info only, Category[Cisco Tomcat]: productid_enable_flag=1, system_enable_flag=1

23:24:16.875 |   PITrace: *ERROR* Important info only, Category[CAR]: productid_enable_flag=1, system_enable_flag=1

23:24:16.875 |   PITrace: *ERROR* Important info only, Category[CallManager]: productid_enable_flag=1, system_enable_flag=1

23:24:16.875 |   PITrace: *ERROR* Important info only, Category[CmiManager]: productid_enable_flag=1, system_enable_flag=1

23:24:16.875 |   PITrace: *ERROR* Important info only, Category[CtiManager]: productid_enable_flag=1, system_enable_flag=1

23:24:16.875 |   PITrace: *ERROR* Important info only, Category[Cisco TFTP]: productid_enable_flag=1, system_enable_flag=1

23:24:16.875 |   PITrace: *ERROR* Important info only, Category[CiscoAXLWebService]: productid_enable_flag=1, system_enable_flag=1

23:24:16.875 |   PITrace: *ERROR* Important info only, Category[Cisco Media Streaming App]: productid_enable_flag=1, system_enable_flag=1

23:24:16.875 |   PITrace: *ERROR* Important info only, Category[CiscoEM]: productid_enable_flag=1, system_enable_flag=1

23:24:16.875 |   PITrace: *ERROR* Important info only, Category[CiscoWebdialer]: productid_enable_flag=1, system_enable_flag=1

23:24:16.875 |   PITrace: *ERROR* Important info only, Category[CiscoIPMA]: productid_enable_flag=1, system_enable_flag=1

23:24:16.875 |   PITrace: *ERROR* Important info only, Category[RISSystemAccess]: productid_enable_flag=1, system_enable_flag=1

23:24:16.875 |   PITrace: *ERROR* [IMPORTANT INFO]  AppCrashCheckBase::AppCrashCheckBase() the RW_Process_Mutex is :/dev/shm/Category_CiscoMediaStreamingApp_Mutex_crash_checker

23:24:16.875 |   PITrace: *ERROR* [IMPORTANT INFO] AppCrashCheckBase::AppCrashCheckBase() acquire lock successed. : errno = 0; strerr = Success

23:24:16.875 |   PITrace: *ERROR* [IMPORTANT INFO]WriterSideCheck() open existing flag_check_mmf left from last run. : errno = 17; strerr = File exists

23:24:16.875 |   PITrace: *ERROR* [IMPORTANT INFO]ExAppCrashCheck::WriterSideCheck() create/open flag_check_mmf successed!!! : errno = 17; strerr = File exists

23:24:16.876 |   PITrace: *ERROR* {Debug infomation}: look from writer side, writer crashed last time : true

23:24:16.876 |   PITrace: *ERROR* CPICategory::loadXmlFile() Category: [Cisco Media Streaming App] xmlfile: [/usr/local/cm/conf/MediaAppPerfmon.xml]

23:24:16.888 |   PITrace: *ERROR* CPIClass::createMMF() MMF file : [/Category_CiscoMediaStreamingApp_PIClass_MEDIAAPP_GLOBAL_OBJECT_MDB] is started.(no error)

23:24:16.890 |   PITrace: *ERROR* ExObjectUpdateTracker::ExObjectUpdateTracker::_synchronizeMAP() m_nIndex 

m_nRoundCount : 0  m_nTick: 0

23:24:16.890 |   PITrace: *ERROR* [SIGNIFICANT INFO]Category Name: Cisco Media Streaming App file: /usr/local/cm/conf/MediaAppPerfmon.xml enbled_flag: 1

23:24:16.890 |   PITrace: *ERROR* [SIGNIFICANT INFO]Add ITraceObj for Category Name: Cisco Media Streaming App, tid:27703l

23:24:16.890 |   PITrace: *ERROR* [SIGNIFICANT]::statsInit() enable_flag=1

00:05:22.959 HDR|07/05/2011 VoiceStrm,IPTCM-1-Cluster,172.x.x.x,Error,8.5.1.11900-21

00:05:22.959 |   [MTP][172.x.x.x]CTTCPSocket::HandleWrite *ERROR* EMPTY in TCP Write

00:05:22.963 |   [MTP][172.x.x.x.2]CTTCPSocket::HandleWrite *ERROR* EMPTY in TCP Write

03:18:59.348 |   [MTP][172.x.x.x]CTTCPSocket::HandleWrite *ERROR* EMPTY in TCP Write

03:18:59.359 |   [MTP][172.x.x.x]CTTCPSocket::HandleWrite *ERROR* EMPTY in TCP Write

....

...

Cisco Employee

MoH Not Works.

Have you started by reviewing the basics??

MOH server registered?

MOH in right codec?

MOH in devices MRGL?

Tried restarting IPVMS?

HTH

java

If this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

MoH Not Works.

Hello,

I want to explain the problem. I have 5 cucm server in cluster(pub-sub1-sub2-sub3-sub4). I used specific audio file (

Myfile 72sn.g729.wav). This file upload to pu(just pub. not uploaded to subs)b. But when I looked the MOH audio server all moh servers looks register to sub1. Maybe this explain my problem.

the some logs is below;

17:03:16.471 |   CMOHMgr::PlayStream (12,2005,0) /usr/local/cm/moh/Myfile 72sn.g729.wav failed to start

17:03:38.241 |   [ANN][x.x.x.x] DeviceMgr::recvStationStopMediaTransmissionMsg *ERROR* Conference ID is invalid!, passThruPartyID=101460594, callRef=102603193

17:03:41.865 |   [ANN][x.x.x.x] DeviceMgr::recvStationStopMediaTransmissionMsg *ERROR* Conference ID is invalid!, passThruPartyID=50534249, callRef=65959921

17:03:50.552 |   [ANN][x.x.x.x] DeviceMgr::recvStationStopMediaTransmissionMsg *ERROR* Conference ID is invalid!, passThruPartyID=50534292, callRef=65960048

17:03:54.056 |   [ANN][x.x.x.x] DeviceMgr::recvStationStopMediaTransmissionMsg *ERROR* Conference ID is invalid!, passThruPartyID=67734390, callRef=83576315

17:03:55.635 |   CIpPlayWav::StartPlaying.ST_PLAYING_FIRST (12,2001,0) *ERROR* Error openning WAV file (/usr/local/cm/moh/Myfile 72sn.g729.wav)

17:03:55.635 |-->CIpPlayWav::ErrorCleanup.ST_ERROR (12,2001,0)

17:03:55.635 |<--CIpPlayWav::ErrorCleanup.ST_ERROR (12,2001,0)

17:03:55.635 |   CMOHMgr::PlayStream (12,2001,0) /usr/local/cm/moh/Myfile 72sn.g729.wav failed to start

17:03:59.651 |   CIpPlayWav::StartPlaying.ST_PLAYING_FIRST (12,2001,0) *ERROR* Error openning WAV file (/usr/local/cm/moh/Myfile 72sn.g729.wav)

17:03:59.651 |-->CIpPlayWav::ErrorCleanup.ST_ERROR (12,2001,0)

17:03:59.651 |<--CIpPlayWav::ErrorCleanup.ST_ERROR (12,2001,0)

17:03:59.651 |   CMOHMgr::PlayStream (12,2001,0) /usr/local/cm/moh/Myfile72sn.g729.wav failed to start

17:04:12.706 |   CIpPlayWav::StartPlaying.ST_PLAYING_FIRST (12,2001,0) *ERROR* Error openning WAV file (/usr/local/cm/moh/Myfile 72sn.g729.wav)

17:04:12.706 |-->CIpPlayWav::ErrorCleanup.ST_ERROR (12,2001,0)

17:04:12.706 |<--CIpPlayWav::ErrorCleanup.ST_ERROR (12,2001,0)

Have you started by reviewing the basics??

-(dont understand what you mean)

MOH server registered?

-Yes all servers looks register to sub1

MOH in right codec?

-all supported codecs was selected.

MOH in devices MRGL?

-yes

Tried restarting IPVMS?

-yes

Cisco Employee

MoH Not Works.

The MOH files are not replicated and it doesn't matter that they register to the SUB1.

You need to upload the MOH file to ALL the MOH servers manually.

HTH

java

If this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

MoH Not Works.

Thanks. I will do what you said and reply to you.

New Member

MoH Not Works.

I have uploded the file to all servers. And problem was solved.

Thanks.

New Member

MoH Not Works.

As a result;

1 ) The moh file must uploaded to all servers.

2 ) Moh File type should be PCM 16bit mono( 16,32,48 KHz....I used: 32KHz)

....

1337
Views
0
Helpful
7
Replies