Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

MoH troubleshooting

Moh isnt working, it used to be and I didnt know it was broke until a user pointed it out.

The MoH server is running and all the phones in question are set for the correct sources and media resource groups.

Where else can I look?

10 REPLIES
New Member

Re: MoH troubleshooting

Do you get silence or 3 beeps? If silence, i think its a config issue. If 3 beeps, probably codec negotiation.

Anonymous
N/A

Re: MoH troubleshooting

I get 3 beeps every 10 seconds. (which is aggravating and I have changed that in the service parameters to 90 seconds and it still happens every 10 seconds)

I had that thought but I wont even produce hold music if I call another cisco of the same type.

I stopped advertising G722 and even put the phones in a 729 only region and still no music. Im stumped.

Bronze

Re: MoH troubleshooting

Hi, confirm these stepss please: (what is the CUCM version?).

- Ensure that media resource is enabled. Media Resource->MoH Server and verify that the run flag is set to YES.

- Restart the Cisco IP Voice Media Stream App service.

- Check if G711,G729 is enabled for MoH in Service Parameters->Call Manager->Cisco IP Voice Media Stream App service.

- Make sure that the IP Phones or Gateways has assigned the MRGL that include the MOH resource.

Hope this help

David

Re: MoH troubleshooting

Does MoH work at all? I've seen that sometimes MoH will work with users on a local LAN but it will not work for external callers.

Hall of Fame Super Silver

Re: MoH troubleshooting

Are you using unicast or multicast MOH, if multicast is this at remote site where you stream it from flash?

Have you already reset the MOH server in CM?

Chris

Re: MoH troubleshooting

Hi David and hope u r in a good health.

I`ve MOH issue:


i`m using cisco cucm-BE with mgcp protocol with the gateways,

When someone called form the pstn to the cucm and after he hear the autoattendant:

the    MOH only works when i press 0 (the operator) and when i press an    internal extension i hear a ring back tone and sometimes i hear the MOH  for one second but when i dial 0 i hear the   MOH Normally after "wait  while i transfer your call"

how i can hear the MOH too after i dial the internal extension normally?

the following is done:

-am using unicast MOH

- that media resource is enabled. Media Resource->MoH Server and verify that the run flag is set to YES.

- Restart the Cisco IP Voice Media Stream App service.

- Check if G711,G729 is enabled for MoH in Service Parameters->Call Manager->Cisco IP Voice Media Stream App service.

- the IP Phones or Gateways has assigned the MRGL that include the MOH resource.

thanks

New Member

Re: MoH troubleshooting

We have this same issue. Were you able to resolve it?

The 3 beep setting not changing according to the parameter for us is because this parameter does not apply to H.323 or SIP devices.

New Member

Re: MoH troubleshooting

Got the same problem, MOH worked well untill last week, no configuration changes were made, I can see through packet analizer that Ip Phone receives multicast packets, but it doesnt play them..

Re: MoH troubleshooting

any recent config change or upgrade?

Sent from Samsung tablet

Apologies for any typo

New Member

Re: MoH troubleshooting

No..

1947
Views
0
Helpful
10
Replies