Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

New Member

Multicast over BT MPLS

Hi

Requirement is to multicast music on hold RTP stream from a Data Center to a remote site over BT IP Clear MPLS network. Catalyst 3750 switches (both running IP Services Image) will BGP peer with BT PE equipment. The Catalyst 3750 switches will also be configured with PIM-SM.

Does BT MPLS support IP Multicast? I could not find any info on the web so I am hoping people have tried it and (hopefully) it worked for them!

7 REPLIES
Hall of Fame Super Gold

Re: Multicast over BT MPLS

Hi,

I think you will find that multicast is not supported on MPLS. Consequently, you will need to setup GRE tunnels to carry multicast. Since the 3750s are not apt for that, you will need dedicated routers.

VIP Super Bronze

Re: Multicast over BT MPLS

Hi,

you can configure the remote site routers to stream MOH from flash because MPLS network will not support multicast.

I just did an install over BT IP Clear MPLS network and it was okay.

Here is a link to configuring this. You must follow every step of it. In some cases after you configure the gateway you may need to reload for it to work, I had to do this.

http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a00802d1c31.html

Below is a sample configuration I used.

NB Ensure the MOH file you use is in router's flash memory.

interface Loopback0

ip address 192.168.145.1 255.255.255.255

ip pim sparse-dense-mode

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.145.1

!

interface FastEthernet0/0

no ip address

ip pim sparse-dense-mode

duplex auto

speed auto

!

interface FastEthernet0/0.50

description Data VLAN 50

encapsulation dot1Q 50

ip address 10.144.50.254 255.255.0.0

ip pim sparse-dense-mode

!

interface FastEthernet0/0.144

description Voice VLAN 144

encapsulation dot1Q 144

ip address 192.168.144.1 255.255.255.0

ip helper-address 10.144.10.1

ip pim sparse-dense-mode

!

ccm-manager music-on-hold

!

call-manager-fallback

max-conferences 8 gain -6

transfer-system full-consult

ip source-address 10.144.50.254 port 2000

max-ephones 42

max-dn 144 dual-line

system message primary WAN Circuit Down

transfer-pattern .T

pickup 4625

call-forward pattern .T

moh SampleAudioSource.ulaw.wav

multicast moh 239.1.1.1 port 16384 route 192.168.145.1 192.168.144.1 10.144.50.

254

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
Hall of Fame Super Gold

Re: Multicast over BT MPLS

That seems a great recommendation, I've rated your post aokanlawon.

VIP Super Bronze

Re: Multicast over BT MPLS

Paolo,

Thanks for the appreciation and as always you remain a model and inspiration here...

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Re: Multicast over BT MPLS

Thanks for the replies so far.

MoH is requred for external callers (over PRI ISDN circuits) as well as internal callers. My understanding that 'Non-Fallback Mode' will not provide MoH over POTs interfaces.

Looks like my options are limited.

If I deploy standalone MoH server, does this have to be on the same LAN as the UCM cluster or can it be on the remote site (RTT is less than 30 ms between the sites)?

VIP Super Bronze

Re: Multicast over BT MPLS

This will work for external and internal callers in NON-Fallback Mode.

Please take a minute to read the documentation. This will work even if the router is not in SRST Mode, which is what you want

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Re: Multicast over BT MPLS

Thanks - I'll have a look through the documnentation. I'm glad it worked for you. I appreciate the configuration.

The SRND for 6.x mentions multicasting moh over 'local Cisco Communications devices' for Non-Fallback mode (no mention of POTS interfaces) and 'analog and digital ports within the chassis' for Fallback mode, which is why I queried this.

464
Views
5
Helpful
7
Replies
CreatePlease to create content